• Welcome to Simple Machines Community Forum. Please login or sign up.

Bridge 1.1.4

Started by Orstio, April 23, 2006, 07:59:20 AM

Previous topic - Next topic

paki

Quote from: chinathetimes on April 28, 2006, 12:58:45 AM
Orstio,

In case we don't say it enough:

No whines ...

No complaints ...

Just a message to say ... You're the best.

And you have the patience of Job.



I agree 110% :)
http://www.dfwhyundais.com <-- Dallas/Ft. Worth's Local Hyundai Group

bremil

Hi, I have a brand new install of Joomla 1.0.8 and SMF 1.1RC2, running on MySQL 5. Got the following error trying to install this bridge:

QuoteDB function failed with error number 1264
Out of range value adjusted for column 'id' at row 1 SQL=INSERT INTO jos_components VALUES( '', 'SMF Bridge', 'option=com_smf', 0, 0, 'option=com_smf', 'SMF Bridge', 'com_smf', 0, 'js/ThemeOffice/component.png', 0, '' )
SQL =

INSERT INTO jos_components
VALUES( '', 'SMF Bridge', 'option=com_smf', 0, 0, 'option=com_smf', 'SMF Bridge', 'com_smf', 0, 'js/ThemeOffice/component.png', 0, '' )

Any ideas?

Orstio

Did it install correctly?

bremil

No, doesn't look like it. Creates the com_smf directory but doesn't show in the components list. My guess would be the '' for ID is causing the problem. I'm not sure, but I thought on auto-increment values you needed to submit NULL not an empty string. But I can't find the line where this code is being executed to test it.

Orstio

Do any other components install correctly?

bremil

April 29, 2006, 01:46:34 PM #45 Last Edit: April 29, 2006, 03:49:25 PM by bremil
I hadn't thought to try that. Got the same error on another component, same error when I tried to run the statement manually through MySQL. Changed the '' to NULL and it worked, but install is incomplete. Apparently it's a Joomla problem.

Thanks.

[EDIT]

FYI... found a better fix:

hxxp:forum.joomla.org/index.php/topic,47032.0.html [nonactive]

opt

Why loggin module identify lowercase and uppercase?

lowercase = uppercase, fix?

Orstio

Joomla is case sensitive.  It has nothing to do with the bridge.  It has nothing to do with the login module.  The bridge cannot fix this.

keirlawson

I cant seem to set the default groups on my forum to have author privledges, the setting just seems to revent when i try to change it :(

Orstio

You're going to have to explain to me how you are trying to give your members author privileges....

keirlawson

In the "groups" tab of the bridge configuration you can select which groups correspond to which...

Orstio

Yes, and after you set them, you click "Save".

Then you need to go to the Synch Tab, and click the third button to perform the synchronization.

keirlawson

yeah i click save but they still revert :(

Orstio

Can you PM me a URL and super admin access?

keirlawson


Orstio

Thanks.  I've replied.  I am seeing both you Global Moderator and Moderator SMF groups synched to Author in Joomla.  Is that what you want?

Orstio

Thank you very much for granting me access so I could see what was going on.  This bug will be fixed in future versions of the bridge.  :)

mpetrie

Oristo wrote:
QuoteOK, it is attached to the bottom of this post

It would be helpful to warn people that you've set the forum to hide attachments unless you've logged in! I've just spent ages hunting for a copy of the latest bridge!

Mike

Orstio


Moonray

May 01, 2006, 11:33:10 AM #59 Last Edit: June 11, 2006, 09:43:00 AM by shashikiranu
I am in "situation"  :o

After Synch'ing, I have lost the Super Admin power at my Joomla site! How do I get it back?


EDIT: Solved it myself...

Had to edit the jos_users and jos_core_acl_groups_aro_map in phpMyAdmin...
Those who need help on this, please feel free to contact me. I think I can handle it..

EDIT 2: Tutorial

For those who are in this "situation", now I have posted a tutorial at Joomlaspan.
See it here: Joomla-SMF Tutorial, How to recover Super Admin Status?

Good luck

Advertisement: