• Welcome to Simple Machines Community Forum. Please login or sign up.
November 28, 2021, 01:29:30 AM

News:

SMF 2.0.18 has been released! Please update. Read more.


SMF 1.0 Beta 4.1 Public Available

Started by [Unknown], March 27, 2004, 10:31:10 PM

Previous topic - Next topic

[Unknown]

March 27, 2004, 10:31:10 PM Last Edit: March 27, 2004, 10:36:26 PM by [Unknown]
We would like to invite all of you to test this new version of the public beta.  It is considered a critical update, because bugs have been found and resolved that might cause data loss in some cases.  Remember, we expect there to be bugs, and the purpose of a beta release is to facilitate finding and fixing all of them - but we're still trying to keep on top of the more critical bugs, as closely as possible.  Please don't ask for a final release date, because we are still working on it.

While updating, please note that many templates and language files have changed.  For details, you can check the changelog - however, in most cases these changes won't cause problems unless you:
  - modified the default theme. (you should create a copy instead...)
  - are using language files other than the default four. (they should be updated soon, though.)

Remember that we always listen to feature requests, bug reports, and questions about the code.  Code review is a wonderful and great part of any project like this.  For more information on how to get involved with SMF, please see the page about just that.  But remember, sometimes what you think is a bug might not be what we think is a bug; sometimes you will want a feature we don't see as part of the distribution.  We still want you involved, and some of you can help even more by making packages, themes, and so forth for SMF.

Please remember to read the license.  Even if you do not, you are bound by it and may not redistribute SMF or change/remove any displayed copyrights.  We will go after people who do not follow these terms, so if you are not willing to abide by them please do not use SMF.  Remember that, currently, you are not allowed to redistribute any of the files, in part or full, released in the packages available for download.

For new users - it's important to note that this is a big change from YaBB SE.  While it may seem to work the same in many ways, one look at the code... one look at the templating system... should show you it is not at all the same.  Many settings and options have changed and been moved, and it is highly recommended that you play with a separate install or upgrade before upgrading your main forum - if you must, indeed, use it in production.  It will take you time to get used to where the new settings are, and it will take time to ask questions here.  If you prepare, you won't have to worry about emergencies later.

You can always find information posted here about things like installation, upgrade, and more.  As development continues, you will see more and more tutorials, FAQs, and manuals for SMF - this is just another part of development.

If you need any more help with anything to do with SMF, please do not hesitate to ask questions. And for those who need a little to get going, the downloads themselves are, of course, here:
http://www.simplemachines.org/download.php

Thank you for being a part of SMF,
Simple Machines

Nathan

March 28, 2004, 01:12:17 AM #1 Last Edit: March 28, 2004, 01:14:00 AM by Nathan
Ran the update succesfully and get this error on top of every Administration Center page in the default and classic themes:

Notice: Undefined index: theme_current_settings in /home/joker/public_html/smf/Sources/Subs.php on line 1277

Any ideas?

[Unknown]

Please try to upload the language files again.  If you're using SmartFTP, it was probably caused by "that SmartFTP problem".

-[Unknown]

Springer

March 28, 2004, 01:19:27 AM #3 Last Edit: March 28, 2004, 01:23:21 AM by Springer
All the smilies are pictures of X's, other than that no problems.


I deleted the folder with smilies, then uploaded one from an install.zip and it works now.

Nathan

I don't use SmartFTP but that worked..... thx Unknown!

[Unknown]

Quote from: Springer on March 28, 2004, 01:19:27 AM
All the smilies are pictures of X's, other than that no problems.


I deleted the folder with smilies, then uploaded one from an install.zip and it works now.

Hmm, the update package shouldn't even contain any smileys at all... I don't think... or does it?

-[Unknown]

Springer

From what I see in the update the smilie images were not touched. 

One thing I forgot to post earlier.  When I was trying to fix it through admin the save buttons would not display.  I tried many times refreshing the screen.  I then closed IE and open a new one and none of that worked.  Tried all that again with more time between open and close, no effect.

I deleted and then uploaded the smilies folder.  Hit refresh on IE and all of a sudden the images could be seen and the save button was there.

[Unknown]

Odd.... really odd.  I'll be rewriting that interface soon, though.  It's horrible...

-[Unknown]

andrewwest

Wow,  I must say that the package downloader is GREAT! If all mods were downloadable through that, as they few of them already are it would be great.

Winters

We do not need to run upgrade.php again, do we?

smacktalk


[Unknown]

Quote from: Winters on March 28, 2004, 02:59:07 AM
We do not need to run upgrade.php again, do we?

Always a good idea, but I think you may not actually need to.

-[Unknown]

Peter Duggan

Just used this to upgrade a local Beta -3.1415 because I still have two similar live boards (not to mention a live YaBB SE) and it went straight through first time. But it's also wrecked my theme, which was based off a copy of the old YaBB SE style SMF default theme and is now appearing as a horrid mixture of my theme and the new default theme, so I'm afraid I won't be upgrading the live boards till I work out why...

Peter Duggan

OK, just tried another local one in case 'Convert the existing template and set it as default' did any good, but it's just the same...

NB There's no index.template.php etc. in these themes, of course, so the board's apparently using the new default version! So perhaps I should find that template converter, go back to my old YaBB SE templates and start again from there?

[Unknown]

Quote from: Peter Duggan on March 28, 2004, 03:14:36 AM
Just used this to upgrade a local Beta -3.1415 because I still have two similar live boards (not to mention a live YaBB SE) and it went straight through first time. But it's also wrecked my theme, which was based off a copy of the old YaBB SE style SMF default theme and is now appearing as a horrid mixture of my theme and the new default theme, so I'm afraid I won't be upgrading the live boards till I work out why...

Probably because they relied on the default theme's URLs.  Try going into their settings and using the "classic" theme instead as a base.

-[Unknown]

Peter Duggan

Quote from: [Unknown] on March 28, 2004, 03:29:47 AM
Quote from: Peter Duggan on March 28, 2004, 03:14:36 AM
Just used this to upgrade a local Beta -3.1415 because I still have two similar live boards (not to mention a live YaBB SE) and it went straight through first time. But it's also wrecked my theme, which was based off a copy of the old YaBB SE style SMF default theme and is now appearing as a horrid mixture of my theme and the new default theme, so I'm afraid I won't be upgrading the live boards till I work out why...

Probably because they relied on the default theme's URLs.  Try going into their settings and using the "classic" theme instead as a base.

No, I'm afraid that's not it!

The real problem appears to be that, in Beta -3.1415, we have:

QuoteModify the index.php template. (the main template)

But, in Beta 4.1 (and 4.0) Public:

QuoteModify the index template. (the main template)

Which leads to:

QuoteThe file you are trying to edit... can't even be found!

But I still have copies of the Beta -3.1415 templates if that helps!

[Unknown]

Oh, just rename index.php to index.template.php.

-[Unknown]

Peter Duggan

Quote from: [Unknown] on March 28, 2004, 03:56:10 AM
Oh, just rename index.php to index.template.php.

Now, that's so obvious that I should have done it anyway! :-X

DeadMetal

Great, a new beta :)
Update succeeded.

I have a dutch forum so I removed the english language files. But the upgrade.php script said some files were missing. (the english language files) so I had to upload them again. Maybe this can be improved.

[Unknown]

Quote from: DeadMetal on March 28, 2004, 06:12:03 AM
Great, a new beta :)
Update succeeded.

I have a dutch forum so I removed the english language files. But the upgrade.php script said some files were missing. (the english language files) so I had to upload them again. Maybe this can be improved.

! Upgrade wouldn't work properly without English installed.

-[Unknown]

Advertisement: