• Welcome to Simple Machines Community Forum. Please login or sign up.
December 05, 2021, 04:18:48 AM

News:

Want to get involved in developing SMF, then why not lend a hand on our github!


[DONE] Magic Llama mod

Started by Aquilo, April 04, 2004, 08:03:55 AM

Previous topic - Next topic

Aquilo

here is a little bit extra for some of ya'll that use SSI.

the only thing is that you need edit index.template.php by hand to add the full url to MoveObj.js where you see
<script language="JavaScript" type="text/javascript" src="MoveObj.js"></script>

please don't make this real hard just make
<script language="JavaScript" type="text/javascript" src="MoveObj.js"></script>

look like substituting "http://www.yoursite.com/PATH_TO_SMF_FORUM/" with the url to your board!
<script language="JavaScript" type="text/javascript" src="http://www.yoursite.com/PATH_TO_SMF_FORUM/MoveObj.js"></script>

here is the small mod file!
http://www.aquilo.us/files/SSI_mod.txt

BigMike

Hey Aquilo,

I just made the changes in the mod file to Profile.php, Load.php, and Profile.template.php and all of my members profiles are working out GREAT!! You are amazing. My members love the script. They have gone nuts over it!

A+ work!

BigMike

tradenet

Hi,
After applying 0.6 version of the mod I get this:
Notice: Undefined variable: modSettings in ~/Themes/default/index.template.php on line 346

Any ideas?

Thanks in advance.

tradenet

Interesting I had to redeclare  global $modSettings, $user_info;
before the:
  if (($modSettings['freeLlamas'] == 1) && ($user_info['is_guest'] != 1) && ($context['LlamaInfo']['Llamaid'] != ''))

Ben_S

I'm realllllly tempted to install this, but am currently resisting the urge.
Liverpool FC Forum with 14 million+ posts.

tradenet

Well, I'm still struggling with the Karma +/- Good Evil points showing up in the profile.

Aquilo

that is interesting that you have to redeclare global $modSettings, $user_info; becouse that function don't use $modSettings so it's not destroying it before the mod.

what issue are you having with the profiles?

Thanks for the help BigMike!!

tradenet

Hi Aquilo,
The profile is not showing the "Caught" values. ie.
Karma: from Good Llama:  +/ Good Llama Caught: 
Karma: from Evil Llama:  -/ Evil Llama Caught: 

They appear in the database but not in the user profile.

Also, if I don't redeclare global $modSettings I get this and the mod doesn't work:
Notice: Undefined variable: modSettings in ~/Themes/default/index.template.php on line 327


Quote from: Aquilo on June 10, 2004, 01:50:54 AM
that is interesting that you have to redeclare global $modSettings, $user_info; becouse that function don't use $modSettings so it's not destroying it before the mod.

what issue are you having with the profiles?

Thanks for the help BigMike!!

Aquilo

tradenet I don't know what to say, That's the same info from your other posts and unless BigMike caught something I messed putting in the mod file he has it working on his site.

QuoteName: BigMike
Posts: 2697 (3.489 per day)
Position: Administrator
Turtle Points 100
Turtle Points from Good Turtle: +224/ Good Turtle Caught: 42
Turtle Points from Evil Turtle: -128/ Evil Turtle Caught: 41

But by any chance did you forget to upload the modified Load.php file?

tradenet

"Upload" the modified Load.php?
Ah, not sure what you mean there. I did modify it according to the instructions in the mod file.

Quote from: Aquilo on June 11, 2004, 03:20:01 AM
tradenet I don't know what to say, That's the same info from your other posts and unless BigMike caught something I messed putting in the mod file he has it working on his site.

QuoteName: BigMike
Posts: 2697 (3.489 per day)
Position: Administrator
Turtle Points 100
Turtle Points from Good Turtle: +224/ Good Turtle Caught: 42
Turtle Points from Evil Turtle: -128/ Evil Turtle Caught: 41

But by any chance did you forget to upload the modified Load.php file?

babylonking

Hi Aquilo

Any chance converting this mod to beta6 for charter members ?

Aquilo

I'm not a charter member so it will have to wait until it goes public. sorry I didn't get it upgraded for beta5p but I've been in north Alabama for the last three weeks working so I haven't been around my pc, but when 6p is public I'll get it converted!

treo

Beta 6 isn't going to be public, the next public release will be RC1 ... afaik ;D

babylonking

Quote from: Aquilo on July 05, 2004, 01:44:23 AM
I'm not a charter member so it will have to wait until it goes public. sorry I didn't get it upgraded for beta5p but I've been in north Alabama for the last three weeks working so I haven't been around my pc, but when 6p is public I'll get it converted!

Thats fine don't worry no rushing  ;)

Aquilo

ok, I have just had my heart attack for the day! :-\

any way I have the mod updated for SMF RC1 and when they are done installing a new hard drive I'll upload it to Xtram and post it here!! but it done!! ;D

babylonking

Quote from: Aquilo on August 12, 2004, 10:48:45 PM
ok, I have just had my heart attack for the day! :-\

any way I have the mod updated for SMF RC1 and when they are done installing a new hard drive I'll upload it to Xtram and post it here!! but it done!! ;D

wow that was fast Aquilo ........... did you test it yet ?

Vinoth

great, an mod seem to get here soon!

i am happy that members are making mods, and if the mod site is also alive ( which would be coming soon) ! SMF gonna be a great one.

Sachin is making some mods, for the SMF. He will release it soon and also some intergation with postnuke.

Vinoth And Sachin ( SpecHackers Team )
The Best  Way to Help Poor Is not Becoming One Of Them.

Aquilo

Quote from: babylonking on August 13, 2004, 08:11:35 AM
wow that was fast Aquilo ........... did you test it yet ?

Yes, and this server being down was a good thing as it allowed me to test it more! :D

any who!

Magic Llama mod FULL 0.8 for SMF RC1
http://www.xtram.net/index.php?op=download;id=20

Søren Bjerg

August 14, 2004, 06:41:21 AM #178 Last Edit: August 14, 2004, 07:06:22 AM by Søren Bjerg
I applied the changes as specified in the .mod file, and uploaded the files to the server... but I now get a notice on the "Look and Layout Preferences" page when editing my profile;

QuoteNotice: Undefined index: llamaoption in /customers/<bleh>/httpd.www/forums/Sources/Load.php(1101) : eval()'d code on line 1188

EDIT:

This at the very bottom of all pages too (EDIT2: seems to be only when using a different theme but the default - despite having made the changes to those files present in the theme directory the .mod file tells to make modifications to);

QuoteNotice: Undefined variable: modSettings in /customers/<bleh>/httpd.www/forums/Sources/Load.php(1101) : eval()'d code on line 274

:-/

EDIT3:

Sorry for being a pest, but the "auto detect" routine of the height and width of the image didn't work for me... and would break the mod - not releasing a llama (in shoddy IE anyways... Firefox would display a llama... but it wouldn't fly around).

The line...

Llama1 = new Chip("Llama1",', $width, ',', $height, ');

...would spit out...

Llama1 = new Chip("Llama1",,);

...in the HTML.

When putting in values it worked as supposed to in both :).
RUNE HORDES dot INFO - SMF 1.1.10 w/ Custom Profile Mod... and various permissions hooks and template changes (new topic form).

babylonking

Thanks Aquilo for the update  :)

one question: how can i reset all members bad and good llama to zero for the members profile cuz i still have the old llama count? 

Advertisement: