• Welcome to Simple Machines Community Forum. Please login or sign up.

[DONE] Magic Llama mod

Started by Aquilo, April 04, 2004, 08:03:55 AM

Previous topic - Next topic

Aquilo

babylonking I'm going to unzip a new copy of smf and install these three real quick to find he error, I but just a few minutes!

Homie if you can set those settings the default was 40 but I like 25! ;D

Homie

Set what settings for Llamas to appear

Aquilo

homie your not getting any errors?

how about a yellow exclamation mark in the bottom left corner of your browser?

every thing installed great except I lost other mods on my test board, but there was one error the javascript llama_speed var has to be before the moveobj.js include. so if you are getting that yellow exclamation,

open index.template.php and find this and remove it!

checkbrOK();
var llama_speed = ', (!empty($modSettings['Llamaspeed']) ? $modSettings['Llamaspeed'] : '40'), '


now go up just a little and find this:

echo '
<script language="JavaScript" type="text/javascript" src="moveobj.js"></script>


and replace it with:
echo '
<script language="JavaScript" type="text/javascript">
var llama_speed = ', (!empty($modSettings['Llamaspeed']) ? $modSettings['Llamaspeed'] : '40'), ';
</script>
<script language="JavaScript" type="text/javascript" src="moveobj.js"></script>


this will make the llama's popup on your screen!

Homie

Im getting this error at bottom of my forum thats only error  i see

Notice: Undefined index: LlamaInfo in /home/abhost/public_html/abhosting/abhosting/Themes/default/index.template.php on line 347

babylonking

Quote from: Aquilo on April 05, 2004, 08:01:06 PM
homie your not getting any errors?

how about a yellow exclamation mark in the bottom left corner of your browser?

every thing installed great except I lost other mods on my test board, but there was one error the javascript llama_speed var has to be before the moveobj.js include. so if you are getting that yellow exclamation,

open index.template.php and find this and remove it!

checkbrOK();
var llama_speed = ', (!empty($modSettings['Llamaspeed']) ? $modSettings['Llamaspeed'] : '40'), '


now go up just a little and find this:

echo '
<script language="JavaScript" type="text/javascript" src="moveobj.js"></script>


and replace it with:
echo '
<script language="JavaScript" type="text/javascript">
var llama_speed = ', (!empty($modSettings['Llamaspeed']) ? $modSettings['Llamaspeed'] : '40'), ';
</script>
<script language="JavaScript" type="text/javascript" src="moveobj.js"></script>


this will make the llama's popup on your screen!

Thanks that fixed the Modsetting error message........ I have 2 more errors  :P

1- the llama is not floating.
2- when i click on View Llama Log i get this error "Unable to load the 'llama' template".

Aaron Nelsen

Here's how I got it to float in IE...

Leave this code in index.template.php
checkbrOK();
var llama_speed = ', (!empty($modSettings['Llamaspeed']) ? $modSettings['Llamaspeed'] : '40'), '


Then find and replace
  echo '
<script language="JavaScript" type="text/javascript" src="moveobj.js"></script>


with

  echo '
<script language="JavaScript" type="text/javascript">
var llama_speed = ', (!empty($modSettings['Llamaspeed']) ? $modSettings['Llamaspeed'] : '40'), ';
</script>
<script language="JavaScript" type="text/javascript" src="moveobj.js"></script>


In other words, do everything Aquilo told you to except the first step.

That's what worked for me...

As for the template problem, check and make sure you have two files Llama.template.php and Llamas.template.php

Homie

Im Proud to Announce that my Forum now has Magic Llama Mod installed and working

http://abhosting.uni.cc/abhosting/abhosting/index.php

It was a pain to get it working thanks to Auqilo for editing the template stuff
SO please go check it out. + You cant view Llamas without being registered

Regards
Homie

Homie

Will you soon ad a Llama mod for the Llama mod where the Admin can set it up also so he can make it so Llama attacks certian members and gives them a certain good or bad karama just to annoy the member it would be cool

Aquilo

01001101 01100101 I found the template error also!

rename Llama.template.php to llama.template.php notice the L's

Aaron Nelsen

Okay, I had it working on my localhost install of SMF, but now that I'm trying to run it off my server I'm getting the same error as babylonking

Notice: Undefined variable: modSettings in /home/r1478142/public_html/forum/Themes/hsu/index.template.php on line 416

Aquilo

check index.php and load.php those where wear that error where coming from for homie, check that the mod is correct!

babylonking

Thanks Aquilo your llama mod rocks now  :)

Aquilo

WOOT! Magic Llamas update 0.4 is up this is a quick overwrite of the moveobj.js file so it works in FireFox!!

the download this is in this post!

babylonking

Quote from: Aquilo on April 06, 2004, 09:20:20 AM
WOOT! Magic Llamas update 0.4 is up this is a quick overwrite of the moveobj.js file so it works in FireFox!!

the download this is in this post!

Nice one Aquilo ......... Thanks again  :D

[Unknown]

My moveobj.js is still better.

-[Unknown]

babylonking


[Unknown]

I rewrote the whole thing so it doesn't ever go off screen and works on Opera, Mozilla, etc.  Tested it on several browsers.  Also more commented and better coding, etc. :P.

-[Unknown]

babylonking

Quote from: [Unknown] on April 06, 2004, 10:25:36 AM
I rewrote the whole thing so it doesn't ever go off screen and works on Opera, Mozilla, etc.  Tested it on several browsers.  Also more commented and better coding, etc. :P.

-[Unknown]

I just noticed that Aquilo moveobj.js for FireFox is not making the llama image floating.  ::)

Aquilo

do you think it's better if it's stays in the window and not move down? if so along the way I did come up with a version that will not go lower then the viewing window! but I think it better if they have to chase it not just bouncing around in there face, I was also thinking of adding a few extra lines that would make it disappear and reappear I thought that would give it a fun twist!

Quote from: [Unknown] on April 06, 2004, 10:25:36 AM
I rewrote the whole thing so it doesn't ever go off screen and works on Opera, Mozilla, etc. Tested it on several browsers. Also more commented and better coding, etc. :P.

-[Unknown]

but what good is it if your the only one who sees it? ;D
Well the Resistance version is out! :P and the Llama have been Freed! :D

but honestly how is this for something I could only conceive how it worked?
plus I'm not done there are some things I may work on! oh since I only have IE6 and FireFox what other browsers does this version work in or don't?

Aquilo

April 06, 2004, 10:41:47 AM #119 Last Edit: April 06, 2004, 10:43:23 AM by Aquilo
Quote from: babylonking on April 06, 2004, 10:35:03 AM
Quote from: [Unknown] on April 06, 2004, 10:25:36 AM
I rewrote the whole thing so it doesn't ever go off screen and works on Opera, Mozilla, etc.  Tested it on several browsers.  Also more commented and better coding, etc. :P.

-[Unknown]

I just noticed that Aquilo moveobj.js for FireFox is not making the llama image floating.  ::)

what? do you have them turned on on your site? becouse they are moving on localhost and Xtram! what are they doing?

oh also go into tools and clear out the cache so the old version is purged!

Advertisement: