Advertisement:

Author Topic: Fatal error: Load.php(1040)  (Read 2392 times)

Offline PJP

  • Newbie
  • *
  • Posts: 6
Fatal error: Load.php(1040)
« on: May 17, 2006, 06:05:20 PM »
Hello first of all and thank you for the forum software, I have a problem. I installed the forum and when I click on a topic, I receive this error, any ideas?

Thank you in advance!

Fatal error: Call to undefined function: create_button() in /home/dothack/public_html/bb/Sources/Load.php(1040) : eval()'d code on line 238
« Last Edit: May 19, 2006, 01:45:05 AM by Amacythe »

Offline kegobeer

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 3,994
  • Gender: Male
  • I am ninja!
    • The Kazebeer Family Website
Re: Fatal error: Load.php(1040)
« Reply #1 on: May 17, 2006, 07:35:32 PM »
Make sure you uploaded all of the files.  If you installed any mods, make sure you installed them according to the directions.
"The truth of the matter is that you always know the right thing to do. The hard part is doing it." - Norman Schwarzkopf
Posting and you (Click "WATCH THIS MOVIE")

Offline PJP

  • Newbie
  • *
  • Posts: 6
Re: Fatal error: Load.php(1040)
« Reply #2 on: May 18, 2006, 01:05:58 AM »
I have installed anything but themes, which is uploading. I don't see what else it can be, maybe an error with the theme.

Offline gamesmad

  • SMF Hero
  • ******
  • Posts: 1,667
  • Gender: Male
Re: Fatal error: Load.php(1040)
« Reply #3 on: May 18, 2006, 01:56:47 AM »
Does it work with the default theme??  If not, reupload sources/Load.php

Will
1 on 1 SMF Help - Want 1 on 1 SMF Help? Post in Help Wanted or drop me a message!

Go Charter! - Please consider becoming a charter member to support SMF development.

Please do not PM me with general questions, posting in the appropriate board will ensure everyone benefits from the advice given.

Offline PJP

  • Newbie
  • *
  • Posts: 6
Re: Fatal error: Load.php(1040)
« Reply #4 on: May 18, 2006, 02:18:30 AM »
yes, it works fine with the default theme, the theme I'm using is called bluBlur, which can be found in the download section on this site.

Offline kegobeer

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 3,994
  • Gender: Male
  • I am ninja!
    • The Kazebeer Family Website
Re: Fatal error: Load.php(1040)
« Reply #5 on: May 18, 2006, 09:22:06 AM »
You haven't mentioned your SMF version.  You must use a theme for your version of SMF.  RC2 requires RC2 compatible themes, 1.0.7 requires themes compatible with 1.0.7, etc.
"The truth of the matter is that you always know the right thing to do. The hard part is doing it." - Norman Schwarzkopf
Posting and you (Click "WATCH THIS MOVIE")

Offline PJP

  • Newbie
  • *
  • Posts: 6
Re: Fatal error: Load.php(1040)
« Reply #6 on: May 18, 2006, 12:22:35 PM »
I have the latest version:

SMF File   Your Version   Current Version
SMF Package   SMF 1.0.7   SMF 1.0.7

Offline kegobeer

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 3,994
  • Gender: Male
  • I am ninja!
    • The Kazebeer Family Website
Re: Fatal error: Load.php(1040)
« Reply #7 on: May 18, 2006, 01:27:31 PM »
1.0.7 requires themes compatible with 1.0.7, etc.

If your custom theme isn't 1.0.7 compatible it will causes all sorts of errors.
"The truth of the matter is that you always know the right thing to do. The hard part is doing it." - Norman Schwarzkopf
Posting and you (Click "WATCH THIS MOVIE")

Offline PJP

  • Newbie
  • *
  • Posts: 6
Re: Fatal error: Load.php(1040)
« Reply #8 on: May 18, 2006, 03:31:17 PM »
It was because I didn't have 1.1 RC2, thank you all for your help.

PROBLEM SOLVED!