SMF Trader System

Started by SMFHacks.com Team, July 12, 2006, 12:35:09 AM

Previous topic - Next topic

vbgamer45

change TimeOffset to time_offset for SMF 2.0 will fix that
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Cutter65

Quote from: vbgamer45 on February 19, 2010, 08:48:36 PM
change TimeOffset to time_offset for SMF 2.0 will fix that

That seems to have fixed it!  ;D

Thanks again for the help!

Cutter

vbgamer45

Quote from: Cutter65 on February 20, 2010, 07:51:55 AM
Quote from: vbgamer45 on February 19, 2010, 08:48:36 PM
change TimeOffset to time_offset for SMF 2.0 will fix that

That seems to have fixed it!  ;D

Thanks again for the help!

Cutter
No problem just released an update to fix this issue.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

vbgamer45

Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Nick Whetstone

Thanks, vbgamer. :) Still one of the best mods out there.
The artist formerly known as (Ha)²

Former Support Specialist

Please do not solicit support via PM. Here's why!

Bugo

It seems that you forgot to add a line in smftrader2rc2.xml for Modifications.english *. php:
$txt['permissiongroup_simple_smftrader'] = 'SMF Trader';

Arantor

Bugo: If you omit the _simple version it should load the non simple version.
No good deed goes unpunished / All helpful urges should be circumvented

I have something to say: it's better to burn out than to fade away. There can be only one.

vbgamer45

Quote from: Bugo on March 15, 2010, 04:36:28 AM
It seems that you forgot to add a line in smftrader2rc2.xml for Modifications.english *. php:
$txt['permissiongroup_simple_smftrader'] = 'SMF Trader';

Fixed thanks
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Arantor

No good deed goes unpunished / All helpful urges should be circumvented

I have something to say: it's better to burn out than to fade away. There can be only one.

vbgamer45

What I have seen in my mods at least up to RC2 was you needed both strings defined I forgot to add the simple version in this case.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Arantor

You shouldn't need both in RC2+. I found a case in SimpleDesk where I had typo'd the _simple version but the language string was still listed by using the non _simple version.
No good deed goes unpunished / All helpful urges should be circumvented

I have something to say: it's better to burn out than to fade away. There can be only one.

BrewserBrad

I am using SMF 1.1.11. When I use Classifieds and leave feedback I get an error - You must select a Classifieds listing that you have bid on or created to leave feedback for this user.

What does that mean? I am in the listing when I select leave feedback.
Please help.
Thanks.

vbgamer45

There is an option enabled inside the Classifieds mod called "Trader system feedback only after winning a listing or auction"

If that is checked  you can only leave feedback if the listing/auction is completed and you won the listing/auction.

If it isn't checked anyone can leave feedback at any time.
The reason you get that error is since there is no completed auction/listing there is listings listed in the dropdown menu to select to leave feedback on.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

aw06

If i upgrade from 1.1.11 to 2.0RC then re-install back trader system will it retain all user ratings ?
:: ShopinJA.com Powered by SMF 1.1.19 | Ig-Oh Theme by Koni | 70 Rock Solid Error Free Mods | Many Custom Edits & Tweaks ::
- Host Unlimited Websites - Free Website Builder & Templates - Unlimited Disk Space & Bandwidth

vbgamer45

Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Kermit

I don't know if i'm the only who has experienced such an issue,but the thing is when one member made a tradereview and after a while this account is deleted,then from that time on it's no more possible to see that review,which has been made by that deleted member

I think the problem line is here

WHERE f.ID_MEMBER = " . $context['traderid'] . " AND f.FeedBackMEMBER_ID = m.ID_MEMBER

especially this part

AND f.FeedBackMEMBER_ID = m.ID_MEMBER


PS: Only on 1.1.11, did not try on 2.0 RC3
My Mods
Please don't PM/mail me for support,unless i invite you
Formerly known as Duncan85
Quote
"Two things are infinite: the universe and human stupidity; and I'm not sure about the the universe."

A. Einstein

vbgamer45

Quote from: Duncan85 on May 31, 2010, 12:37:57 PM
I don't know if i'm the only who has experienced such an issue,but the thing is when one member made a tradereview and after a while this account is deleted,then from that time on it's no more possible to see that review,which has been made by that deleted member

I think the problem line is here

WHERE f.ID_MEMBER = " . $context['traderid'] . " AND f.FeedBackMEMBER_ID = m.ID_MEMBER

especially this part

AND f.FeedBackMEMBER_ID = m.ID_MEMBER


PS: Only on 1.1.11, did not try on 2.0 RC3
Fixed released new update

1.5
!Fix bug not showing reviews if a member deleted their account
!Fixed missing language string on delete rating added Short Comment
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Siirist

Hello, :)

Simply didn't want to read through 24 pages of replies.  :(

Is this stand-alone, or do I need something else so members can buy and sell online?

Thanks in advance, ;)
Cloud 8)
Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

vbgamer45

This does not do like selling or buying of items. It is more of a feedback system for users to rate other users. Some people have like for sale boards on their forums and would use a system like this to sell items.

If you want selling items I have classifieds system that ties into the Trader System at
http://www.smfhacks.com/smf-classifieds.php
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Cutter65

Running 2.0 RC3 and trader 1.5 installed.

I get the following 2 errors in my error log each time I visit the trader settings in the admin area.

Anyone have any idea as to how to fix this issue? Happens with both custom theme and the default.

index.php?action=admin;area=trader;sa=admin;sesc;sa=admin;b684f0cf=2442c18dd0a18a1f6ca5b5b58ecf5cc5
8: Undefined offset: 119
File: /forum/Themes/default/Trader2.template.php
Line: 399

This is what on that line.
==>399:  <input type="checkbox" name="trader_approval" ' . ($modSettings['trader_approval'] ? ' checked="checked" ' : '') . ' />' . $txt['smftrader_trader_approval'] . ' <a href="', $scripturl, '?action=helpadmin;help=trader_approval" onclick="return reqWin(this.href);" class="help"><img src="', $settings['images_url'], '/helptopics.gif" alt="', $txt[119], '" align="top" /></a><br />

index.php?action=admin;area=trader;sa=admin;sesc;sa=admin;b684f0cf=2442c18dd0a18a1f6ca5b5b58ecf5cc5
8: Undefined offset: 119
File: /forum/Themes/default/Trader2.template.php
Line: 400

This is whats on that line.
==>400:  <input type="checkbox" name="trader_use_pos_neg" ' . ($modSettings['trader_use_pos_neg'] ? ' checked="checked" ' : '') . ' />' . $txt['trader_use_pos_neg'] . ' <a href="', $scripturl, '?action=helpadmin;help=trader_use_pos_neg" onclick="return reqWin(this.href);" class="help"><img src="', $settings['images_url'], '/helptopics.gif" alt="', $txt[119], '" align="top" /></a><br />

Thanks!
Cutter

Advertisement: