Advertisement:

Author Topic: Having problems with the package manager?  (Read 610294 times)

Offline DarrenOMG

  • Semi-Newbie
  • *
  • Posts: 10
Re: Having problems with the package manager?
« Reply #720 on: November 27, 2007, 03:32:23 PM »
This is an error in my error log:

Code: [Select]
Apply Filter: Only show the error messages of this URL  http://imdarren.com/index.php?action=packages;sa=install2;package=FlashChatSMF_1-0.zip
Apply Filter: Only show the errors with the same message
2: packageinstall(/hsphere/local/home/carrotda/imdarren.com/Packages/temp/./add_settings.php): failed to open stream: No such file or directory
File: /hsphere/local/home/carrotda/imdarren.com/Sources/Packages.php
Line: 552

This one, too.

Code: [Select]
Apply Filter: Only show the error messages of this URL  http://imdarren.com/index.php?action=packages;sa=install2;package=FlashChatSMF_1-0.zip
Apply Filter: Only show the errors with the same message
2: file_get_contents(/hsphere/local/home/carrotda/imdarren.com/Packages/temp/./install.xml): failed to open stream: No such file or directory
File: /hsphere/local/home/carrotda/imdarren.com/Sources/Packages.php
Line: 544

Offline Ricky.

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 4,056
    • Indian Linux Forums
Re: Having problems with the package manager?
« Reply #721 on: November 28, 2007, 12:08:29 AM »
This is truely path problem !
What did you give in ftp as path to smf ?
I guess that in ur case must be :
/carrotda/imdarren.com

Offline Sarge

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 6,209
  • Gender: Male
    • Zëri YT!
Re: Having problems with the package manager?
« Reply #722 on: November 28, 2007, 04:09:15 AM »
DarrenOMG, upload and run repair_settings.php:
What is repair_settings.php?

Click on all the small "Recommended" blue links in the Paths & URLs section and then click the Save button. Be sure to delete repair_settings.php immediately after saving, for security reasons.

If mod installations still don't work, go to Admin > Packages and click on the Options tab. There you should see two sections:

The first section is named Installation Options. There you can enter the FTP server -- normally localhost, because SMF is running from inside the server, and your FTP Username. Verify that these settings are correct and click the Save button.

The second section is Cleanup Permissions. You can use it to automatically chmod SMF files and directories to 777 (or, depending on the server configuration 755 -- SMF will first try 777 and then 755). Select "All files are writable" and press the "Change file permissions" button.

If you see a new screen, be sure to enter the correct FTP info there:
  • FTP Server (usually localhost)
  • Port (usually 21)
  • Username
  • Password (these two settings are your login details for FTP)
  • Local path to SMF
What is shown as the "Local path to SMF"?

To explain a bit more: when you log in to the FTP server using a FTP program (client), you enter a username and password and then the FTP client should show your initial path. Sometimes, your initial FTP path is simply:
/
or it can be something else, like:
/var/www/your_username/

Browse to your forum directory and write down the path to there. For example, it can be:
/public_html/forum/
or:
/var/www/your_username/forum/

This is exactly what "Local path to SMF" is about. It is your forum's path from the start directory of your FTP login.

Note 1: Do not confuse "SMF Directory" (from Admin > Server Settings > Core Configuration tab) with "Local path to SMF". They're different. "SMF Directory" is the complete path of your forum directory from / (the root directory of the server), whereas "Local path to SMF" is the path of your forum starting from where you log in via FTP. Sometimes, "Local path to SMF" is the last part of your "SMF Directory", but this is not always the case; sometimes they could be the same or totally different.

Note 2: You cannot see or modify "Local path to SMF" in repair_settings.php.



If you don't get a new screen, open phpMyAdmin, select the database where your forum resides, browse the smf_settings table and run this query:

Code: [Select]
SELECT * FROM smf_settings WHERE variable =  'package_path'
This query works if the database tables prefix for your forum is smf_ (which is the default). The actual prefix can be found in Admin > Server Settings > "Database Tables Prefix" or as the value for $db_prefix in Settings.php (which is located in your forum directory).

To run the query, click on the SQL link at the top of the right pane (see the image below), enter the query in the box and click the Go button.



Do you get any results from the query?
« Last Edit: November 28, 2007, 07:34:47 AM by Sarge »
    Please do not PM me with support requests unless I invite you to.

http://www.zeriyt.com/   ~   http://www.galeriashqiptare.net/


Quote
<H> I had zero posts when I started posting

Offline Ricky.

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 4,056
    • Indian Linux Forums
Re: Having problems with the package manager?
« Reply #723 on: November 28, 2007, 07:27:42 AM »
Sarge.. thats pretty good post.. :) Hope he get solution through it !

Offline DarrenOMG

  • Semi-Newbie
  • *
  • Posts: 10
Re: Having problems with the package manager?
« Reply #724 on: December 01, 2007, 12:33:45 PM »
Here's what I get back:

Code: [Select]
Error

SQL query: Documentation

SELECT *
FROM smf_settings
WHERE variable = 'package_path'
LIMIT 0 , 30

MySQL said: Documentation
#1146 - Table 'Carrotd_smf039586840598395.smf_settings' doesn't exist

I also don't use localhost, my host does not use that, if it helps.

Offline funcouldron

  • Jr. Member
  • **
  • Posts: 288
  • funcouldron.co.cc rox!!
    • 4MoreFun
Re: Having problems with the package manager?
« Reply #725 on: December 03, 2007, 07:48:21 AM »
plz reply ,,,

i asked many time no one replying
 in my forum in packages i m getting there is no packages yet,,

i cnat upload new packaege and even cant upgread forum i tried to chmod777 and also adding temp dir but nthing happnd ,,, plz plzzz plz helpppppppppppppp
Visit us at  ww.4moreFun.com

Offline Sarge

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 6,209
  • Gender: Male
    • Zëri YT!
Re: Having problems with the package manager?
« Reply #726 on: December 03, 2007, 10:41:38 AM »
Here's what I get back:

Code: [Select]
Error

SQL query: Documentation

SELECT *
FROM smf_settings
WHERE variable = 'package_path'
LIMIT 0 , 30

MySQL said: Documentation
#1146 - Table 'Carrotd_smf039586840598395.smf_settings' doesn't exist

I also don't use localhost, my host does not use that, if it helps.

Select your forum database before running the query. Also, check out the SMF database tables prefix in Admin > Server Settings > "Database Tables Prefix" -- for example, if the prefix there is myforum_ then the query should be:

Code: [Select]
SELECT * FROM myforum_settings WHERE variable = 'package_path'
Your forum would not load if the prefix_settings table was not found.
    Please do not PM me with support requests unless I invite you to.

http://www.zeriyt.com/   ~   http://www.galeriashqiptare.net/


Quote
<H> I had zero posts when I started posting

Offline Sarge

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 6,209
  • Gender: Male
    • Zëri YT!
Re: Having problems with the package manager?
« Reply #727 on: December 03, 2007, 10:45:54 AM »
plz reply ,,,

i asked many time no one replying
 in my forum in packages i m getting there is no packages yet,,

i cnat upload new packaege and even cant upgread forum i tried to chmod777 and also adding temp dir but nthing happnd ,,, plz plzzz plz helpppppppppppppp

OK, send me the username and password via PM for temporary FTP and SMF admin accounts and I will take a look.
    Please do not PM me with support requests unless I invite you to.

http://www.zeriyt.com/   ~   http://www.galeriashqiptare.net/


Quote
<H> I had zero posts when I started posting

Offline Ch4rOon

  • Newbie
  • *
  • Posts: 9
  • Gender: Male
    • Erebe
Re: Having problems with the package manager?
« Reply #728 on: December 03, 2007, 03:29:52 PM »
Hello ;)

Same problem on free.fr server :

I can upload & install other mods.
I already have these installed :
                                                  1. Spoiler Tag 0.3.2 
                                                  2. Attachments Positioning 1.1
                                                  3. Auto Embed Video Clips 1.6    
                                                  4. Remove Post Modified Time 1.1

I already have "temp" directory in forum/packages/
I've got this error whan applicate the mod :

07.  Appliquer la modification     ./Sources/Post.php     Échec du test
17.  Appliquer la modification     ./Sources/Load.php    Échec du test

07. apply modification     ./Sources/Post.php       Test failed
17. apply modification   ./Sources/Load.php      Test failed

It's not possible to chmod 777 on this server
Any idea please ? Eldacar's method doesn't work too.
« Last Edit: December 05, 2007, 11:32:17 AM by Ch4rOon »

Offline Sarge

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 6,209
  • Gender: Male
    • Zëri YT!
Re: Having problems with the package manager?
« Reply #729 on: December 06, 2007, 04:54:11 AM »
It's not possible to chmod 777 on this server

Can you chmod to 755?
    Please do not PM me with support requests unless I invite you to.

http://www.zeriyt.com/   ~   http://www.galeriashqiptare.net/


Quote
<H> I had zero posts when I started posting

Offline Herman's Mixen

  • SMF Hero
  • ******
  • Posts: 7,228
    • Herman's Mixen
Re: Having problems with the package manager?
« Reply #730 on: December 06, 2007, 05:08:53 AM »
try 666 instead of 777 does the same  ;D
Met vriendelijke groet, The Burglar!

 House Mixes | Mixcloud | Any Intelligent fool can make things bigger, more complex, and more violent.
It takes a touch of genius - and a lot of courage - to move in the opposite direction. - Albert Einstein

Former Godfather of our dutch community ;)

Offline Ch4rOon

  • Newbie
  • *
  • Posts: 9
  • Gender: Male
    • Erebe
Re: Having problems with the package manager?
« Reply #731 on: December 07, 2007, 08:23:28 AM »
;)

I've tryed 666/755 too, but no way to affect these attributes to the files in /sources/.

I've test with making a file with mkdir : chmod.php
- I have renamed "sources" -> sources 2
- In the chmod.php i've entered : <?php  mkdir ("./sources/", 0775); ?>
- Uploaded file by ftp in "/forum" and executed it by firefox : hxxp:mysite/forum/chmod.php [nonactive]
- A directory "sources" has been created with chmod 775 (yes!) (noway with 777)
- just to drap/drop the files in "sources 2" to "sources" but same thing all files are in 644.
-So i've tried to copy theses files on my pc and reuploading them ( when a file is upload in a ftp, it's taking the same chmod as the parent directory) but no way.
- always in chmod 644 ...

Does anyone know the command for create a file instead of a directory in a ".php"
I think that it may be work if I create a virgin "load.php" in chmod 775 and paste the lines in it after.

( I've already tried to install it manually but when i'm searching for theses lines : 
"$context['show_spellchecking']" or "global $ID_MEMBER, $user_info, $board_info, $options;" in the file Post.php i can't find nothing. So i've got no idea of where i've got to put the code in :D.
(Free.fr servers does not have spellcheck.dll for exemple)
And as far as i'm a nOob, i'll not try to "macguyverise" it xD

thanks ;)

(sorry for my english, I need to practice more often xD)
« Last Edit: December 07, 2007, 08:37:40 AM by Ch4rOon »

Offline funcouldron

  • Jr. Member
  • **
  • Posts: 288
  • funcouldron.co.cc rox!!
    • 4MoreFun
Re: Having problems with the package manager?
« Reply #732 on: December 09, 2007, 12:44:58 AM »
i sent u mail plz reply me ,, u can mail me on samkikani@gmail.com ,,,plzzzz
Visit us at  ww.4moreFun.com

Offline funcouldron

  • Jr. Member
  • **
  • Posts: 288
  • funcouldron.co.cc rox!!
    • 4MoreFun
Re: Having problems with the package manager?
« Reply #733 on: December 10, 2007, 04:07:56 AM »
plzzz reply ..........
Visit us at  ww.4moreFun.com

Offline Sarge

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 6,209
  • Gender: Male
    • Zëri YT!
Re: Having problems with the package manager?
« Reply #734 on: December 10, 2007, 04:14:39 AM »
plzzz reply ..........

Did you get a PM from me?
    Please do not PM me with support requests unless I invite you to.

http://www.zeriyt.com/   ~   http://www.galeriashqiptare.net/


Quote
<H> I had zero posts when I started posting

Offline funcouldron

  • Jr. Member
  • **
  • Posts: 288
  • funcouldron.co.cc rox!!
    • 4MoreFun
Re: Having problems with the package manager?
« Reply #735 on: December 10, 2007, 04:39:15 AM »
plz reply to my pm or i m onlnie on samkikani@gmail.com  and samkikani@yahoo.co.in
Visit us at  ww.4moreFun.com

Offline funcouldron

  • Jr. Member
  • **
  • Posts: 288
  • funcouldron.co.cc rox!!
    • 4MoreFun
Re: Having problems with the package manager?
« Reply #736 on: December 10, 2007, 04:49:23 AM »
detail sent..plz reply
Visit us at  ww.4moreFun.com

Offline funcouldron

  • Jr. Member
  • **
  • Posts: 288
  • funcouldron.co.cc rox!!
    • 4MoreFun
Re: Having problems with the package manager?
« Reply #737 on: December 10, 2007, 05:02:08 AM »
u thr???
Visit us at  ww.4moreFun.com

Offline funcouldron

  • Jr. Member
  • **
  • Posts: 288
  • funcouldron.co.cc rox!!
    • 4MoreFun
Re: Having problems with the package manager?
« Reply #738 on: December 10, 2007, 05:54:34 AM »
u thr???
Visit us at  ww.4moreFun.com

Offline funcouldron

  • Jr. Member
  • **
  • Posts: 288
  • funcouldron.co.cc rox!!
    • 4MoreFun
Re: Having problems with the package manager?
« Reply #739 on: December 10, 2007, 06:12:58 AM »
detail sent..plz reply
Visit us at  ww.4moreFun.com