Advertisement:

Author Topic: Search Bug with this forum  (Read 1972 times)

Offline Piggie

  • Semi-Newbie
  • *
  • Posts: 23
Search Bug with this forum
« on: April 18, 2010, 08:55:56 AM »
Hi,

If you use two (common) search parameters, show results as messages, and specify certain boards to search, several pages of results will be returned. However, subsequent result pages (beyond the first) will indicate that there are no results.

This behaviour does not occur when a single search parameter is chosen. I've not tested for other conditions that trigger this bug. The problem may be more general.
« Last Edit: April 23, 2010, 03:31:00 AM by Norv »

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 70,998
    • StoryBB/StoryBB on GitHub
Re: Search Bug with this forum
« Reply #1 on: April 18, 2010, 10:19:03 AM »
This has been reported before and is a known bug with 2.0 RC3 and is related to multiple terms not being handled correctly.
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline Norv

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 18,313
  • Blue Wolf
Re: Search Bug with this forum
« Reply #2 on: April 18, 2010, 04:37:48 PM »
Seems similar to: http://www.simplemachines.org/community/index.php?topic=371048.0
(and other topics).

Thank you for your report.
To-do lists are for deferral. The more things you write down the later they're done… until you have 100s of lists of things you don't do.
File a security report | Developers' Blog | Bug Tracker

Also known as Norv on D* | Norv N. on G+ | Norv on Github