Advertisement:

Author Topic: Member Registration Problem  (Read 2967 times)

Offline NezumiRyu

  • Semi-Newbie
  • *
  • Posts: 14
Member Registration Problem
« on: December 08, 2005, 01:07:02 PM »
I wasn't sure how to fix this error, but it's preventing regular member registration. O_o

I have a buddy list modification, installed, but I don't see how that would effect regular registration.

Quote
Database Error: Field 'buddyList' doesn't have a default value
File: g:\Inetpub\wwwroot\Dracnir\Forum\Sources\Register.php
Line: 336

I opened up the register php file and searched through it for a buddyList entry and didn't come up with anything.

~Nez~

Offline Oldiesmann

  • Developer
  • SMF Super Hero
  • *
  • Posts: 24,814
  • Gender: Male
  • Ask me about the function DB :)
    • oldiesmann on Facebook
    • Oldiesmann on GitHub
    • http://www.linkedin.com/in/michaeleshom on LinkedIn
    • @oldiesmann on Twitter
    • Archie Comics Fan Forum
Re: Member Registration Problem
« Reply #1 on: December 08, 2005, 01:44:07 PM »
That's a MySQL error. For some reason it doesn't think there's a default value for that MySQL column.

Go into phpMyAdmin, select your database and click on "smf_members".
Next, click on the pencil icon next to BuddyList. Don't change anything, but click "save" anyway. This will update the field and should give it a default value (even if you don't fill one in).
Michael Eshom
Webmaster / SMF Lead Developer
oldiesmann@simplemachines.org

Offline NezumiRyu

  • Semi-Newbie
  • *
  • Posts: 14
Re: Member Registration Problem
« Reply #2 on: December 08, 2005, 02:10:29 PM »
Hrrmm... I did a search and could not find it.

Where would I find phpMyAdmin?

*hides incase it's probably something right under her nose and she just can't find it or see it*

Offline Oldiesmann

  • Developer
  • SMF Super Hero
  • *
  • Posts: 24,814
  • Gender: Male
  • Ask me about the function DB :)
    • oldiesmann on Facebook
    • Oldiesmann on GitHub
    • http://www.linkedin.com/in/michaeleshom on LinkedIn
    • @oldiesmann on Twitter
    • Archie Comics Fan Forum
Re: Member Registration Problem
« Reply #3 on: December 08, 2005, 02:11:30 PM »
Michael Eshom
Webmaster / SMF Lead Developer
oldiesmann@simplemachines.org

Offline NezumiRyu

  • Semi-Newbie
  • *
  • Posts: 14
Re: Member Registration Problem
« Reply #4 on: December 08, 2005, 04:52:25 PM »
Well, that fixed the buddy list error and now another one has popped up. XD Just my luck.

Quote
2: mail() [<a href='function.mail'>function.mail</a>]: Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set()
 File: g:\Inetpub\wwwroot\Dracnir\Forum\Sources\Subs-Post.php
 Line: 377

Offline Oldiesmann

  • Developer
  • SMF Super Hero
  • *
  • Posts: 24,814
  • Gender: Male
  • Ask me about the function DB :)
    • oldiesmann on Facebook
    • Oldiesmann on GitHub
    • http://www.linkedin.com/in/michaeleshom on LinkedIn
    • @oldiesmann on Twitter
    • Archie Comics Fan Forum
Re: Member Registration Problem
« Reply #5 on: December 08, 2005, 08:44:09 PM »
Try switching the mail method to SMTP (Admin -> Edit Features and Options) and then talk to your host about this issue.
Michael Eshom
Webmaster / SMF Lead Developer
oldiesmann@simplemachines.org

Offline NezumiRyu

  • Semi-Newbie
  • *
  • Posts: 14
Re: Member Registration Problem
« Reply #6 on: December 09, 2005, 12:43:34 AM »
^_^;; I own the server running this so I'm the only one messing around with all the settings.

I changed the setting and now I get this error.
Quote
Apply Filter: Only show the errors with the same message
2: fsockopen() [<a href='function.fsockopen'>function.fsockopen</a>]: unable to connect to :25 (A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
)
File: g:\Inetpub\wwwroot\Dracnir\Forum\Sources\Subs-Post.php
Line: 556

Blarg... what a mess. XD

EDIT:
After doing some reasearch on google, I found out that I need to set up a mail sever, such as exchange, on the server to route mail. I'm not sure how to do it, but I'll figure it out eventually. XD At least the buddy list issue is fixed.

Thanks for the help! :)
« Last Edit: December 09, 2005, 01:51:54 AM by NezumiRyu »