• Welcome to Simple Machines Community Forum. Please login or sign up.

SMF Registration issue

Started by SlammedDime, August 19, 2006, 06:44:56 AM

Previous topic - Next topic

SlammedDime

August 19, 2006, 06:44:56 AM Last Edit: August 19, 2006, 06:04:08 PM by Orstio
I have my bridge set to SMF registration, and I have it set for member activation by email, but the email gets foobared in the process of things.  The activation link comes out like this...

http://www.airridetalk.com/component/option,com_smf/Itemid,26/action,activate/u,49/code,0d1c4b6462____Should you have any problems with activation, please use the code "0d1c4b6462".

BUT

If I access my forum directly, without going through Joomla, the link is formatted properly...

http://www.airridetalk.com/forum/index.php?action=activate;u=50;code=d36ea2083d

Should you have any problems with activation, please use the code "d36ea2083d".


[italicied for effect]

As you can see, this would create some difficulties for the users and force them manually enter the activation code on the screen.

I've scoured over the code for hours and I can't figure out why its happening.  Its as if the \n\n in the smf template is somehow getting marred by some piece of code causing the _____ rather than two new line statements.  Any help??  I would really prefer to use the SMF registration.

I should note that I'm using Joomla 1.0.10 and SMF 1.1RC2 with Bridge 1.1.5a
SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

Orstio

From where did you get that version of 1.1.5a?

The 1.1.5a bridge, as downloaded from here, should not do that.  However, one that I modified for a client did that for a short period of time...

SlammedDime

I downloaded it straight from the Sticky thread.
SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

SlammedDime

If its any help, I've narrowed it down to an issue with the Joomla SEO.  With SEO enabled (with or without OpenSEF), it messes up the email, but with SEO disabled in Joomla, it works as it should.  This would lead me to believe that there is an issue with the Joomla SEO core code that re-writes urls to SEF urls that is causing the issue (but I haven't dove into the code that far yet)
SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

Orstio

So, you have OpenSEF installed?

SlammedDime

Yes.

But, I quickly did a fresh, clean install of Joomla, SMF, and the bridge on my test server, and thats all, and with the Joomla SEF urls, it messes up.

And on the live server with OpenSEF it does the same thing.  But on both live and test servers, with Joomlas SEF disabled, it works as it should.
SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

Orstio

August 19, 2006, 05:40:23 PM #6 Last Edit: August 19, 2006, 05:49:54 PM by Orstio
in your components/com_smf folder is a file named smf.php.  In that file, you will find a function named integrate_outgoing_email.  Just before the close of that function, add this line:

$message=str_replace ('_____', '
', $message);

SlammedDime

After a little formatting, that works perfect.  I simply modified it to this so that it flows better in the email...

$message=str_replace ('____', '

', $message);
SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

afonic

Hi,

I have the same problem with 1.1.6 bridge. Just Joomla! SEO enabled. Using the code above didn't fix it. (or maybe I misplaced it?)

I have the exact problem with "____Should" getting in the link and the remember password email also looks like:

Quote
http://www.dvd-guides.com/component/option,com_smf/Itemid,95/action,reminder/sa,setpassword/u,31516/code,cb77b8afb0____IP:
XX.XX.XX.XX____Username: XXXX____Regards,__The DVD-Guides.com Forum
Team."

I am using Joomla 1.0.11 with core SEO, 1.1.6 Bridge, SMF 1.1RC3. URL: www.dvd-guides.com

Thanks in advance.

tracilynnb

SMF 1.1.1
Joomla Bridge 1.6
Joomla 1.0.12

afonic

shameless bump

I feel this is pretty important tbh, just happened in a vanilla installation. (again only when SEO is on)

tracilynnb

In fact all of my emails ae messed up. They all have the line of underscores ________ for registration emails, lost passwords, etc
SMF 1.1.1
Joomla Bridge 1.6
Joomla 1.0.12

SlammedDime

Your best bet is to make a new thread guys.  This one has a check mark on it, meaning its been solved for my case.  I know this issue has come up before and there was a lengthy thread on fixing it with replace instructions, but I can't find it at the moment.
SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

afonic

Can you modify your post and change the icon to a question mark then?  ;)

Why make a new thread, the problem is the same just the solution given here does not work. Also imho this is a pretty serious bug if it happens in all installations.

tracilynnb

SMF 1.1.1
Joomla Bridge 1.6
Joomla 1.0.12

Advertisement: