Advertisement:

Author Topic: Problème "BoardIndex.php" à la ligne 83 : que faire ?  (Read 1552 times)

Offline nicolinux

  • Semi-Newbie
  • *
  • Posts: 32
Problème "BoardIndex.php" à la ligne 83 : que faire ?
« on: November 05, 2006, 12:07:52 PM »
Bonjour,
Je m'occupe d'un  forum à jour (1.1 RC3 avec le patch récent) et qui fonctionnait encore parfaitement il y a quelques heures...
Mais maintenant, j'ai un gros problème : en effet, le forum n'est pas accessible et je ce message d'erreur :
"Erreur de base de données
Fichier: /cloud1/forum3/Sources/BoardIndex.php
Ligne: 83"
J'ai aussi reçu un mail indiquant que j'avais un problème avec la base de donnée et qu'il y avait eu une réparation automatique. Apparemment, ce n'a pas été si efficace.

Je ne peux donc pas accéder à l'index du forum. Par contre, le centre d'administration est tout à fait disponible (pratique pour prévenir) et, plus étrange, je peux regarder mes nouveaux messages (je peux le faire mais je ne sais pas si ça marche : il n'y a pas de nouveaux messages...).

Étant donné que c'était un problème avec les fichiers sources, après un backup, j'ai tenté de re-uploader le dossier "Sources", sans succès.

Je vous donne enfin la fameuse ligne 83 de ce "Boardindex.php", moi je n'y comprends rien :
Code: [Select]
AND b.childLevel <= 1" : ''), __FILE__, __LINE__);
Dernier élément qui vous aidera peut-être : j'ai fouillé la liste des erreurs et avant la très longue liste indiquant l'erreur ci-dessus, j'en ai une autre qui me dit que j'ai un problème de base de donné avec la table "smf_members" et qu'il faut essayé de réparer. J'ai essayé, sans succès non plus apparemment". L'erreur renvoyait à un autre fichier du dossier Sources, nommé "Subs.php" et à la ligne 630.

Voilà, ce forum étant très important, il est très sollicité, j'espère avoir des éléments de réponses assez rapidement. Merci beaucoup par avance ! Et si vous avez besoin d'autres éléments pour m'aider, demandez.

Offline bline

  • Semi-Newbie
  • *
  • Posts: 64
  • Gender: Male
    • St-fanémule
Re: Problème "BoardIndex.php" à la ligne 83 : que faire ?
« Reply #1 on: November 13, 2006, 08:19:54 AM »
si tu n'as pas touché à tes sources c'est alors surement du à ton boardindex dans ton dossier themes, si tu connais un peu le php ( sinon je te conseille de voire au moins les bases parceque tu apprendras plein de choses avec smf une fois les bases apprises) verifies du coté de ton linktree si tu n'as pas un appel de fonction corrompu par une erreure de syntaxe, le fichier est assez simple il est composé du link tree, de la structure de ton index de sections ainsi que de ton menu... si mes souvenirs sont bons je n'ai rien oublié... bref à mon avis c'est là qu'il faut chercher, je n'ai pas touché aux sources pour ma part et j'ai tout refondu moi meme, c'est plus facile :)
« Last Edit: November 13, 2006, 08:25:40 AM by bline »
my Atari ST website: https://www.st-fanemule.fr - http://blog.st-fanemule.fr - http://forum.st-fanemule.fr
forum powered by smf for the 3rd time :D

Offline nicolinux

  • Semi-Newbie
  • *
  • Posts: 32
Re: Problème "BoardIndex.php" à la ligne 83 : que faire ?
« Reply #2 on: November 13, 2006, 12:10:46 PM »
Merci pour ton aide.

En fait, le problème venait de la base de donnée : j'ai perdu tous mes messages ou presque. Je n'avais pas fait de sauvegardes de la base de donnée donc je n'ai rien pu faire si ce n'est tout refaire à la main.

Depuis, j'ai eu une nouvelle fois le problème, mais sans perte.

Et je n'ai vraiment pas le temps d'entrer dans l'apprentissage du php. Ce n'est pas vraiment que l'envie n'y soit pas, mais ce n'est pas possible.