• Welcome to Simple Machines Community Forum. Please login or sign up.
September 18, 2021, 03:32:27 PM

News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord


RSS Feed Poster

Started by SMFHacks.com Team, January 11, 2007, 07:46:04 PM

Previous topic - Next topic

davieb

Not too sure what I'm doing wrong with this mod. It installed fine but I can't get anything to display, absolutely nothing. I've even tried using some of the feeds that others have added in their posts over the last 30 odd pages and nothing shows. When I've tried opening up the cronrss.php (http://davidbrennan.co.uk/epv3/simplemachinesforum/cronrss.php) all I get is a blank page with Feed Poster Configuration in the corner.

Can someone please help me to get this working?

Fabiolas

My rss feed poster only work if i open this link http://www.mywebsite.org/forum/cronrss.php

And i get this errors:

Quote
Notice: Undefined variable: cnum in /home/myusername/public_html/mywebsite/forum/Sources/Load.php(1737) : eval()'d code on line 103

Notice: Undefined variable: cnum in /home/myusername/public_html/mywebsite/forum/Sources/Load.php(1737) : eval()'d code on line 104

Notice: Undefined variable: cnum in /home/myusername/public_html/mywebsite/forum/Sources/Load.php(1737) : eval()'d code on line 105

Notice: Undefined variable: cnum in /home/myusername/public_html/mywebsite/forum/Sources/Load.php(1737) : eval()'d code on line 106

Notice: Undefined variable: cnum in /home/myusername/public_html/mywebsite/forum/Sources/Load.php(1737) : eval()'d code on line 107

Notice: Undefined variable: cnum in /home/myusername/public_html/mywebsite/forum/Sources/Load.php(1737) : eval()'d code on line 108

Notice: Undefined variable: cnum in /home/myusername/public_html/mywebsite/forum/Sources/Load.php(1737) : eval()'d code on line 109

Notice: Undefined variable: cnum in /home/myusername/public_html/mywebsite/forum/Sources/Load.php(1737) : eval()'d code on line 110

Notice: Undefined variable: cnum in /home/myusername/public_html/mywebsite/forum/Sources/Load.php(1737) : eval()'d code on line 111
Feed Poster Configuration

Fabiolas

Someone can tellme how can i  make auto cronjobs ?  i have 9 rss feeds to update..

vbgamer45

Check with your host or the control panel on your site. If it's a linux based host normally they have a section called cron jobs.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

spiros

Strange thing with stats. I created a user just for the feeds and the stats appear in all cases apart from the daily and the monthly detail view.

I think it would be a good option not to have the user for feeds appear in any of the stats :)

http://www.nonsmokersclub.com/forum/

ApplianceJunk

I get this message when I try to upload it though Admin>package manager

QuoteThe package you tried to upload either is not a valid package or has become corrupted.

I downloaded the file a second time from the mod page link and tried to upload it a second time though admin and still got the same message.

Using SMF 1.1.4 and TP with DilberMc theme.
No errors in our log.

I would really like to give this mod a try.

What I m I doing wrong?

Thanks,

ApplianceJunk

Ok, file is fine. I had to change something in my Admin>Package Manager after switching to a different host. :)

Installed just fine.

Thanks,

davieb

Quote from: davieb on March 07, 2008, 03:32:05 AM
Not too sure what I'm doing wrong with this mod. It installed fine but I can't get anything to display, absolutely nothing. I've even tried using some of the feeds that others have added in their posts over the last 30 odd pages and nothing shows. When I've tried opening up the cronrss.php (http://davidbrennan.co.uk/epv3/simplemachinesforum/cronrss.php) all I get is a blank page with Feed Poster Configuration in the corner.

Can someone please help me to get this working?

Any help on this please?

davieb

Quote from: davieb on March 24, 2008, 03:43:55 AM
Quote from: davieb on March 07, 2008, 03:32:05 AM
Not too sure what I'm doing wrong with this mod. It installed fine but I can't get anything to display, absolutely nothing. I've even tried using some of the feeds that others have added in their posts over the last 30 odd pages and nothing shows. When I've tried opening up the cronrss.php (http://davidbrennan.co.uk/epv3/simplemachinesforum/cronrss.php) all I get is a blank page with Feed Poster Configuration in the corner.

Can someone please help me to get this working?

Any help on this please?

Following on from this, I've managed to set up cron jobs from my host control panel which e-mails me each time it tries to do something. Currently I'm getting the following message

/var/chroot/home/content/d/a/v/davieb/html/epv3/simplemachinesforum/cronrss.php: line 1: ?php: No such file or directory
/var/chroot/home/content/d/a/v/davieb/html/epv3/simplemachinesforum/cronrss.php: line 2: /Packages: Permission denied
/var/chroot/home/content/d/a/v/davieb/html/epv3/simplemachinesforum/cronrss.php: line 3: RSS: command not found
/var/chroot/home/content/d/a/v/davieb/html/epv3/simplemachinesforum/cronrss.php: line 4: Version: command not found
/var/chroot/home/content/d/a/v/davieb/html/epv3/simplemachinesforum/cronrss.php: line 5: by:vbgamer45: command not found
/var/chroot/home/content/d/a/v/davieb/html/epv3/simplemachinesforum/cronrss.php: line 6: http://www.smfhacks.com: No such file or directory
/var/chroot/home/content/d/a/v/davieb/html/epv3/simplemachinesforum/cronrss.php: line 7: cgi/: is a directory
/var/chroot/home/content/d/a/v/davieb/html/epv3/simplemachinesforum/cronrss.php: line 9: //: is a directory
/var/chroot/home/content/d/a/v/davieb/html/epv3/simplemachinesforum/cronrss.php: line 10: syntax error near unexpected token `'SSI.php''
/var/chroot/home/content/d/a/v/davieb/html/epv3/simplemachinesforum/cronrss.php: line 10: `require('SSI.php');'


Hope this info helps to aid someone in pointing me in the right direction.

Randy A.

Is there anyone providing support for this MOD?  If not, I think SMF should officially pull this MOD from the site.  I was just over at smfhacks.com and they don't even have any support for it. 

My error message:
8: Undefined offset: 25
File: /home/talkdavi/public_html/forum/Sources/Subs-RSS.php
Line: 141

What does this error mean?

And, I can't get the feed to work unless I manually kick off the cron url.  I'd love to get this up and running, but no one will even answer support questions.  So many pages here with problems.  These people create MODS and expect all users to be proficient in all the terminology.  Quick wake up call, we're not as smart as you.  Please talk slowly and clearly so that I can understand you vast knowledge.

ApplianceJunk

QuoteIf not, I think SMF should officially pull this MOD from the site.

I disagree.

I don't see how pulling this mod would help anyone.

I find the mod very usefull.


Randy A.

Then maybe someone who has use for it would kindly step in and help those that are having troubles with it. :)

ApplianceJunk

I also just click the link to make it work as I have no idea how to create a cron job.

We dump the RSS feeds into a board only I can see. After reading each post and making sure it's something I want on our forums I move it to the correct board.

I could not get this mod to work at first, not even by using the cron url.
This was when we used godaddy hosting. I did everything I could think of and I jjust could not get it to work.

Then a couple day's ago we move our site to TP Hosting and the RSS feed starting working. I don't know why, but it works. :)

A lot of things started working after we moved to TP Hosting, such as spell check and eAccelerator caching.

I can't say the RSS feed has been 100% error free as every now and then we get a error or two that shows up in our error log after getting some feeds.

Sometimes I get a blank post along with the new feed too, but these are all small things that I can work around.

QuoteMy error message:
8: Undefined offset: 25
File: /home/talkdavi/public_html/forum/Sources/Subs-RSS.php
Line: 141

What does this error mean?

Wish I knew as I would be glad to help, sorry...




Randy A.


davieb

So I think what we can assume is that if you use GoDaddy for hosting you can forget about using this mod? Or is someone out there using GoDaddy and also has this mod working?

Randy A.

I know one thing.  I will never recommend any of smfhacks.com MODS.  No support for their work.  :(

davieb

I think what this mod needs (apart from the support mentioned earlier) is a basic step by step guide of exactly how to use it (i.e. click this part, put xxxx info in here, that kind of stuff). To me anyway it seems that if a question has not already been asked over the previous pages then it doesn't get replied to. Also the earlier replies could have done with having the question quoted so it's obvious who the reply is aimed at, as there seems to be times when a few questions are posted by different people and then a reply appears but no indication who it is at.

ApplianceJunk

Quote from: Randy A. on March 28, 2008, 11:02:06 AM
I know one thing.  I will never recommend any of smfhacks.com MODS.  No support for their work.  :(

Wow, it's not like you paid for this.

It would be different is you paid for something and expected support to come with the product you purchased.

I have gotten lots of help from SMFHacks. :)

I work with a lady that once won a big screen tv. It was given to here, for free!
Yet she complained about the store she won it from because she thought they should deliver it and show her how to use it for free.


Randy A.

They have asked SMF to offer their stuff thru this site.  Support of those things offered, should be a given.  I'm surprised SMF would allow a relationship like this.

Randy A.

It's a good thing that I have such a great host.  My feeder is now working, with no help from any smfhack support.

Advertisement: