• Welcome to Simple Machines Community Forum. Please login or sign up.
September 22, 2021, 01:02:25 PM

News:

Want to get involved in developing SMF, then why not lend a hand on our github!


RSS Feed Poster

Started by SMFHacks.com Team, January 11, 2007, 07:46:04 PM

Previous topic - Next topic

Mack450

Quote from: vbgamer45 on April 28, 2009, 11:03:47 PM
No theme edits, just need to setup a cron job.
Oh...how do I do that?
www.atvsector.com

Powered by SMF

Mack450

www.atvsector.com

Powered by SMF

vbgamer45

Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Mack450

So my command shoudl be something like this? /usr/bin/php /home/cronrss.php
www.atvsector.com

Powered by SMF

vbgamer45

Yeah replace /home with the full path to the cronrss.php
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Mack450

Ok I ended up with

/usr/local/bin/php -f /home/atvcath/public_html/cronrss.php

Will test it out!

Thanks for the help!
www.atvsector.com

Powered by SMF

steve51184

hi there i have a site setup with wordpress and a forum with smf and i have the posts on wordpress posted to the forum with "feed poster" but it includes a link to the wordpress post at the bottom of the post is there a way to remove this?

vbgamer45

Quote from: somerandomdude on April 29, 2009, 04:43:08 AM
hi there i have a site setup with wordpress and a forum with smf and i have the posts on wordpress posted to the forum with "feed poster" but it includes a link to the wordpress post at the bottom of the post is there a way to remove this?
No it posts what ever is inside the rss feed that you are importing.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

steve51184

Quote from: vbgamer45 on April 29, 2009, 07:49:44 PM
Quote from: somerandomdude on April 29, 2009, 04:43:08 AM
hi there i have a site setup with wordpress and a forum with smf and i have the posts on wordpress posted to the forum with "feed poster" but it includes a link to the wordpress post at the bottom of the post is there a way to remove this?
No it posts what ever is inside the rss feed that you are importing.

actually you can by editing Subs-RSS.php and removing this from the bottom of the file:



break;

case "LINK":
$context['feeditems'][$feedcount]['link'] .= $data;

Mack450

Everything should be set up. Yet this is still not working. Any other ideas?
www.atvsector.com

Powered by SMF

Underfunded

I am new to SMF and am using 1.1.8 along with TinyPortal for a test website with the intention of leaving PHPBB3.

I run a guild website for a Warhammer Online guild and the game publisher provides a news RSS that I want to post to my website as a forum post. I have your mod installed and it works well but the feed I am using has HTML code in it that displays instead of providing the proper formatting.

I am posting the news as an administrator.

I have basic HTML enabled in the forum.

If I modify each post and add in the  ...   tags then it will utilize the formatting.

Is there a way to automatically append those tags to each post the RSS Feed Poster posts? Is there a different work around other than just stripping all html out of the post?

Underfunded

After digging through the code a little the HTML Enabled? checkbox should be doing this automatically for me but it is not. Any suggestions?

Quote from: Underfunded on May 10, 2009, 10:01:31 AM
I am new to SMF and am using 1.1.8 along with TinyPortal for a test website with the intention of leaving PHPBB3.

I run a guild website for a Warhammer Online guild and the game publisher provides a news RSS that I want to post to my website as a forum post. I have your mod installed and it works well but the feed I am using has HTML code in it that displays instead of providing the proper formatting.

I am posting the news as an administrator.

I have basic HTML enabled in the forum.

If I modify each post and add in the  ...   tags then it will utilize the formatting.

Is there a way to automatically append those tags to each post the RSS Feed Poster posts? Is there a different work around other than just stripping all html out of the post?

Underfunded

For good measure I just did a clean install of SMF 1.1.8 (including this mod) and it still is not parsing the HTML properly (at all). Is anybody else having this problem and do you have any suggestions?  It is posting the HTML tags, just not using them for the formatting.

cybergoblin

May 24, 2009, 02:59:55 PM #1313 Last Edit: May 28, 2009, 02:58:35 AM by cybergoblin
I have installed this on smf 1.1.9 and it worked perfect, for 30 seconds, posted 21 posts then died, anyone know what is the problem?
I have my own server, fsockopen, and curl, but it dies after a few posts, wth?
:'(  ???

ccraciun

I finally got this mod working, using the settings:
In Feed poster configuration (SMF Admin, i set:
- Use fake Cron jobs. Checks if feeds need to be updated on each page load. - CHECKED
- Feed download method - ALL
In Cron manager (cPanel), i set:
wget -t 4 --delete-after http://www.your-site.com/cronrss.php
to run every fifteen minutes (or how often do you wish...)


Now, i have a question:
I want to replace the link from the end of each post with an anchored link (like read more)
I guess i need to modify something from the code below, but i don't know what...

         break;

         case "LINK":
            $context['feeditems'][$feedcount]['link'] .= $data;

mghq

Could someone tell me how to make the html tags be in the post because it is not including them

mghq

I made a modification to the code and am wondering would this work

Subs-RSS.php
'body' => '[b]' . $msg_title . "[/b]\n\n" . '[html]' . $msg_body . '[/html]',

vbgamer45

Would not work the last time I tried it.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

mghq

Well the one for SMF 2.0 works but i do not want to use that version of smf. Could you possibly upload the zip of that one so i can see if i can find the fix.

mghq

So can anyone help
mghq

Advertisement: