• Welcome to Simple Machines Community Forum. Please login or sign up.
January 27, 2022, 06:57:05 AM

News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord


[Theme] xtEnhanced for SMF 1.0.3

Started by A.M.A, August 15, 2004, 03:51:19 AM

Previous topic - Next topic

A.M.A

Could you please show me the code you are trying to use.
Really sorry .. real life is demanding my full attention .. will be back soon hopefully :)

kenchix1

August 25, 2004, 11:09:45 PM #41 Last Edit: August 25, 2004, 11:18:13 PM by kenchix1
Quote from: A.M.A on August 25, 2004, 09:20:44 PM
Could you please show me the code you are trying to use.

It's the google ads leader board 728x90 code that I tried to insert below the code that you mentioned.

kenchix1

August 25, 2004, 11:15:43 PM #42 Last Edit: August 25, 2004, 11:17:47 PM by kenchix1
this is the site http://www.philippineforums.com. When you use mozilla to browse it, everything is perferct, But if you use Internet Explorer, page increase it's width and exceed the screen as if the whole page was stretch to the right.

kenchix1

I replaced the banner ads with a smaller one  so it would look clean for awhile. but I'm still hoping to put the 728x90 banner.

thank you very much for all the help. :)

A.M.A

August 26, 2004, 10:58:50 AM #44 Last Edit: August 26, 2004, 11:00:37 AM by A.M.A
oh .. I don't really know how Google Ads work, but from the following thread I guess there is a problem with their script that makes tables exceed its limit.
http://www.simplemachines.org/community/index.php?topic=1301.0

by the way do you have this problem with the 'default' theme!
Really sorry .. real life is demanding my full attention .. will be back soon hopefully :)

Jazhawk

A.M.A

I just want to say again that xtEnhanced is one good looking theme.  Clean, easy on the eyes and cleaver.  (not sure how to explain 'cleaver' but somehow it fits) ;)  I want to remove the text beside the control block and replace it my own logo.  Is there a thread for that already?

-Jazhawk

Springer

Does anyone have a forum running this that I could look over?.

Jazhawk

Quote from: Springer on August 26, 2004, 04:07:48 PM
Does anyone have a forum running this that I could look over?.

Come over to

http://sweatsocks.shorturl.com

Login: test
Password: tester

-Jazhawk

A.M.A

Jazhawk
thanks :)

The header contains three columns .. Menu , Forum's name , Logo

If you want to change the Forum's name or delete it or even replace it with a logo .. you have to find in index.template.php :
Quote<td width="40%" align="center" style="background-image: url(', $settings['images_url'], '/xtHEAD.gif);" bgcolor="#83B3E0"><span style="font-family: Georgia, sans-serif; font-size: xx-large;">', $context['forum_name'], '</span></td>
what you need is change , delete , replace the red code only.

Logo will appear on the far right of the header .. and there is already an image which is found in the (xtEnhanced\images) folder under the name 'xtLOGO.gif' .. you cannot see it cause it has the same background colors ..
You need to open that image in your favorite graphic program and add a logo to it , save it then upload it back to your server.
Really sorry .. real life is demanding my full attention .. will be back soon hopefully :)

Jazhawk


kenchix1

August 26, 2004, 09:07:28 PM #50 Last Edit: August 26, 2004, 10:46:05 PM by kenchix1
Quote from: A.M.A on August 26, 2004, 10:58:50 AM
by the way do you have this problem with the 'default' theme!

I don't have any problem with the default theme using the 728x90 banner, both in IE and mozilla. as I said before, the 728x90 banner in XTenhanced theme doesn't have any problem with mozilla BUT with IE, the table exceeds the screen. I think it has something to do with the div on top of the whole table.  :-\

Thanks again for the help.

Springer

How did you get the image border around the forum?  Edit index.template?

A.M.A

kenchix1
I'll do some test on an image with your desired dimension and see what I can come up with.

Springer
Yes.
Really sorry .. real life is demanding my full attention .. will be back soon hopefully :)

A.M.A

kenchix1 , I hope this will fix the sizing problem , in 'index.template.php' look for:
        <td width="0%" style="background-image: url(', $settings['images_url'], '/xtHEAD.gif);">';
change to:
        <td width="20%" style="background-image: url(', $settings['images_url'], '/xtHEAD.gif);">';

also look for:
        <td width="40%" align="center" style="background-image: url(', $settings['images_url'], '/xtHEAD.gif);" bgcolor="#83B3E0"><span style="font-family: Georgia, sans-serif; font-size: xx-large;">', $context['forum_name'], '</span></td>
        <td width="60%" align="center" style="background-image: url(', $settings['images_url'], '/xtHEAD.gif);" bgcolor="#83B3E0"><img src="', $settings['images_url'], '/xtLOGO.gif"  alt=""/></td>

change to:
        <td width="20%" align="center" style="background-image: url(', $settings['images_url'], '/xtHEAD.gif);" bgcolor="#83B3E0"><span style="font-family: Georgia, sans-serif; font-size: xx-large;">', $context['forum_name'], '</span></td>
        <td width="50%" align="center" style="background-image: url(', $settings['images_url'], '/xtHEAD.gif);" bgcolor="#83B3E0"><img src="', $settings['images_url'], '/xtLOGO.gif"  alt=""/></td>

You just need to change the width of the columns ( <td> )

my mistake .. was depending on the browser to render images size correctly even if the width of the columns is short .. I guess FireFox passes the test while the old IE did not  :-\
Really sorry .. real life is demanding my full attention .. will be back soon hopefully :)

turtleman

If I might make a suggestion...

This theme is totally awesome BTW  :D

The one problem that I saw right away was if you have the quick reply displayed, the little smiley faces squash the size of the reply box.

If you go into the Display.template.php toward the bottom you will see:
<a href="javascript:void(0);" onclick="replaceText(\' :-\\\ \', document.postmodify.message); return false;"><img src="' . $settings['images_url'] . '/undecided.gif" align="bottom" alt="Undecided" title="Undecided" border="0" /></a>
<a href="javascript:void(0);" onclick="replaceText(\' :-*\', document.postmodify.message); return false;"><img src="' . $settings['images_url'] . '/kiss.gif" align="bottom" alt="Kiss" title="Kiss" border="0" /></a>
<a href="javascript:void(0);" onclick="replaceText(\' :\\\'(\', document.postmodify.message); return false;"><img src="' . $settings['images_url'] . '/cry.gif" align="bottom" alt="cry" title="cry" border="0" /></a>
<textarea cols="75" rows="7" style="width: 95%; height: 100px;" name="message" tabindex="1"></textarea><br />


All you need to do is just add an html line return before the textarea.  Kind of makes it look nicer in my opinion.  Thanks!

Vinoth

Vinoth And Sachin ( SpecHackers Team )
The Best  Way to Help Poor Is not Becoming One Of Them.

Durriken

LOL I seem to suck major booty at installing themes.  Grrr... *keeps trying*.

BTW kenchix1, I am having the same problem you originally reported.  How did you fix that?

kenchix1


kenchix1

Quote from: A.M.A on August 27, 2004, 10:34:04 PM
kenchix1 , I hope this will fix the sizing problem , in 'index.template.php' look for:
        <td width="0%" style="background-image: url(', $settings['images_url'], '/xtHEAD.gif);">';
change to:
        <td width="20%" style="background-image: url(', $settings['images_url'], '/xtHEAD.gif);">';

also look for:
        <td width="40%" align="center" style="background-image: url(', $settings['images_url'], '/xtHEAD.gif);" bgcolor="#83B3E0"><span style="font-family: Georgia, sans-serif; font-size: xx-large;">', $context['forum_name'], '</span></td>
        <td width="60%" align="center" style="background-image: url(', $settings['images_url'], '/xtHEAD.gif);" bgcolor="#83B3E0"><img src="', $settings['images_url'], '/xtLOGO.gif"  alt=""/></td>

change to:
        <td width="20%" align="center" style="background-image: url(', $settings['images_url'], '/xtHEAD.gif);" bgcolor="#83B3E0"><span style="font-family: Georgia, sans-serif; font-size: xx-large;">', $context['forum_name'], '</span></td>
        <td width="50%" align="center" style="background-image: url(', $settings['images_url'], '/xtHEAD.gif);" bgcolor="#83B3E0"><img src="', $settings['images_url'], '/xtLOGO.gif"  alt=""/></td>

You just need to change the width of the columns ( <td> )

my mistake .. was depending on the browser to render images size correctly even if the width of the columns is short .. I guess FireFox passes the test while the old IE did not  :-\


Thank you very much, I'll try to do it. :)

Francisco

 Nice work!  :D

One question, could you give me an example link to change it on our forums?

Thank you!

Advertisement: