News:

SMF 2.0.19 has been released! Please update. Read more.

Main Menu

Visual Warning Mod

Started by Eleglin, July 31, 2007, 08:53:40 AM

Previous topic - Next topic

IVIIVI4ck3y27

#400
Quote from: F.L.A.M.E.R on September 02, 2008, 03:58:07 PM
oh thanks.. i was wondering about it... it also would be better if there was warn in the profile aswell... would also be better if there is a warning bar which would show how much they are warned... i think that is there..but not sure...just confirming.. is it?

Actually it will display what warning level they're on under their name at the left when a user is warned, banned, etc.  In as far as incorporating one in the profile, I don't know that is necessary really.  The way this system works it's designed to be used on the fly during postings.  One of the advantages with SMF and other boards is that you don't have to go out of your way to administrate and can do it right there in the front pane while reading a posting, which is why I find it far more elegant than even some of the module-based boards for Joomla (why I choose to use SMF wrapped in our Joomla install; I dislike using Fireboard which feels far more clunky in that to administrate/moderate I find myself spending more time in the Joomla back end than I would like; SMF's administration on the fly = far superior, as is PHPbb3 for that matter).  You can not only specify the user warning level but can tell them why they're being warned on each posting on the fly.  Yes you can see the user warning level in their profile as well as on the board, but it's really redundant to have it in the profile section IMHO, at least with how this module works.  Honestly, compared to some of the more confounded warning systems I've seen/read about in boards, I actually like the way this one is conceived the best.  It's more intuitive and cut and dry.

Adish - (F.L.A.M.E.R)

hmm ok.. i am fine with it.. :)

Eleglin

Updated to work with SMF 1.1.6.
No support by PM or Mail.

Adish - (F.L.A.M.E.R)

well i upgraded to 1.1.6 and it removed the uninstall option for this mod.. i dont actually want to remove it but i want it all proper that when ever i want i can do the needful instead of the manual editing... Can you create an update for this please...

Josh-

Hey, I was using this mod on a 1.1.5 and today I patched to 1.1.6 and now when I go to install (I removed the package completely from my server before patching and now I re-installed with the 1.1.6 version) it gives me this error:

512: parseBoardMod(): The filename 'index.php' is not a full path!
File: /home/vol1/byethost32.com/b32_2329877/htdocs/forums/Sources/Subs-Package.php
Line: 1660


Any idea how I can fix this?
"Whoever fights monsters should see to it that in the process he does not become a monster" -Unknown

Rumbaar

Can I ask why you removed the mod in the first place, the nature of forum upgrades and the beauty of the system is that you aren't meant to or need to remove alter anything when upgrading your forum within the AdminCP and of this type of upgrade.

Are you able to install any other mods, or just not this one?
"An important reward for a job well done is a personal sense of worthwhile achievement."

[ Themes ]

Josh-

Quote from: Rumbaar on September 08, 2008, 06:01:59 PM
Can I ask why you removed the mod in the first place, the nature of forum upgrades and the beauty of the system is that you aren't meant to or need to remove alter anything when upgrading your forum within the AdminCP and of this type of upgrade.

Are you able to install any other mods, or just not this one?

I removed the mod in an attempt to fix the error. And I do have other mods in that where in when I had 1.1.5 and all worked correctly together.
"Whoever fights monsters should see to it that in the process he does not become a monster" -Unknown

Adish - (F.L.A.M.E.R)

kind of same problem with me... the difference is that i havnt removed it.... and well i cannot upgrade this mod which can be compatible with 1.1.6 ... i mean it doesnt have uninstall option.. so i think thats where i think its not compatible... any updating patch for this mod ?

Rumbaar

Well the package file stored in the packages folder probably doesn't have the xml data to indicate it's compatible with 1.1.6.  An option is to download the file, extract, edit the package-info.xml file and add 1.1.6 compatibility. Re-compress and copy back to the packages folder.  You should now have the uninstall option.
"An important reward for a job well done is a personal sense of worthwhile achievement."

[ Themes ]

Josh-

I can't uninstall it because I cannot install it...
"Whoever fights monsters should see to it that in the process he does not become a monster" -Unknown

Eleglin

There is no difference for this mod between SMF 1.1.5 and 1.1.6.
So if there is no problem and if you are enjoying this mod, you shouldn't have to uninstall it.

IF you want to uninstall it after an update for 1.1.6 and doesn't see the option, you should redownload the mod on this site and replace the old package on your server with this one.

OR, you just have to add ;version_emulate=1.1.5 in your URL
For example :  http://myforum.com/index.php?action=packages;version_emulate=1.1.5
No support by PM or Mail.

digit

#411
I was just trying to manually install this mod, and came upon this in the mod.....



<file name="$themedir/Profile.template.php">
          <operation>
             <search position="after"><![CDATA[ <td colspan="2"><hr size="1" width="100%" class="hrcolor" /></td>
</tr><tr>
<td><b>', $txt[231], ': </b></td>
<td>', $context['member']['gender']['name'], '</td>
]]></search>
             <add><![CDATA[';
if (isset($message['member']['group']) && $message['member']['group'] != '')
echo '
', $message['member']['group'], '<br />';
]]></search>
             <add><![CDATA[';

//  Mod Visual warning :: Hide these things for people unable to warn?
     if ($modSettings['visualw_hide'] == 0 && $context['member']['warning']['link'] !== '')
echo'
<td><b>' . $txt['visual_current_level'] . ' </b></td>
<td>' . $context['member']['warning']['link'] . '</td>
</tr><tr>
';
      elseif (AllowedTo('visual_warn_any') && $context['member']['warning']['link'] !== '')
echo'
<td><b>' . $txt['visual_current_level'] . ' </b></td>
<td>' . $context['member']['warning']['link'] . '</td>
</tr><tr>
';

echo'
]]></add>



Shouldn't that after be before:-\

Edit: hmm, either that is wrong, or this is wrong ...



           <operation>
             <search position="after"><![CDATA[ $context['post_url'] = $scripturl . '?action=featuresettings2;save;sa=karma';
$context['settings_title'] = $txt['smf293'];

prepareDBSettingContext($config_vars);
}
]]></search>
             <add><![CDATA[
function VisualWarningSettings()
{
global $txt, $scripturl, $context, $settings, $sc;

$config_vars = array(
// Visual Warning Options?
array('text', 'visualw_mess_ban'),
array('text', 'visualw_mess_mute'),
array('text', 'visualw_mess_pmod'),
array('text', 'visualw_mess_warn'),
'',
array('text', 'visualw_color_ban'),
array('text', 'visualw_color_mute'),
array('text', 'visualw_color_pmod'),
array('text', 'visualw_color_warn'),
'',
array('text', 'visualw_image_ban'),
array('text', 'visualw_image_mute'),
array('text', 'visualw_image_pmod'),
array('text', 'visualw_image_warn'),
'',
array('text', 'muteAutoTime'),
array('text', 'moderationAutoTime'),
array('text', 'warningAutoTime'),
'',
array('check', 'visualw_pmod_edit'),
array('check', 'visualw_hide'),
);

// Saving?
if (isset($_GET['save']))
{
saveDBSettings($config_vars);
redirectexit('action=featuresettings;sa=visualwarning');
}

$context['post_url'] = $scripturl . '?action=featuresettings2;save;sa=visualwarning';
$context['settings_title'] = $txt['visual_warning_mod'];

prepareDBSettingContext($config_vars);
}
]]></add>

Happily using a heavily modified 1.1.16 version of SMF!

2748011 Posts in 320998 Topics by 50986 Members


SOLD my website - thanks it was a good run - they converted to vbadvanced. (and screwed it up good!)

Josh-

Quote from: Eleglin on September 12, 2008, 06:23:56 AM
There is no difference for this mod between SMF 1.1.5 and 1.1.6.
So if there is no problem and if you are enjoying this mod, you shouldn't have to uninstall it.

IF you want to uninstall it after an update for 1.1.6 and doesn't see the option, you should redownload the mod on this site and replace the old package on your server with this one.

OR, you just have to add ;version_emulate=1.1.5 in your URL
For example :  http://myforum.com/index.php?action=packages;version_emulate=1.1.5

I fixed it. Thanks anyway.
"Whoever fights monsters should see to it that in the process he does not become a monster" -Unknown

digit

#413
For the record, there are two files in the download.....

VisualWarning_SMF11.mod

and

modification.xml

The modification.xml file is bunged up in a couple of places.

For example....  from line 120


        <file name="$themedir/Profile.template.php">
          <operation>
             <search position="after"><![CDATA[ <td colspan="2"><hr size="1" width="100%" class="hrcolor" /></td>
</tr><tr>
<td><b>', $txt[231], ': </b></td>
<td>', $context['member']['gender']['name'], '</td>
]]></search>
             <add><![CDATA[';
if (isset($message['member']['group']) && $message['member']['group'] != '')
echo '
', $message['member']['group'], '<br />';
]]></search>


It appears someone inadvertently copied and pasted some text there.

from line 565....


$txt['visual_list_desc']='This lists all users that currently have some form of warning (levels 1,2 or 3. Level 4 is not listed as these members have alre
$txt['visual_member']='Member';



It appears a line was cut off at a margin.

You can see when you compare the two above mentioned files.

My advice?  DO NOT USE modification.xml from the 142 version at least!



Happily using a heavily modified 1.1.16 version of SMF!

2748011 Posts in 320998 Topics by 50986 Members


SOLD my website - thanks it was a good run - they converted to vbadvanced. (and screwed it up good!)

Filipoday

please, I can`t see that image, the button RED on the left:
V


I only see this

Rumbaar

Have you installed all the applicable mod code into applicable custom theme template files?  As it looks like you're using a custom theme in that screen shot.
"An important reward for a job well done is a personal sense of worthwhile achievement."

[ Themes ]

BarfBag

Board URL: http://www.chexquest.org/

SMF 1.1.6

Mods:
SMF Gallery Lite
Redirection Boards
Ad Management
FavIcon
Todays Birthday
SMF Links
YouTube BBCode
Chatroom Button

This is the error I get:
   Execute Code     VisualWarningPdb.php     
2.    Execute Modification    ./index.php    Test successful
3.    Execute Modification    ./Sources/ModSettings.php    Test successful
4.    Execute Modification    ./Themes/default/Profile.template.php    Test successful
5.    Execute Modification    ./Sources/Display.php    Test successful
6.    Execute Modification    ./Themes/default/Display.template.php    Test successful
7.    Execute Modification    ./Sources/Post.php    Test successful
8.    Execute Modification    ./Themes/default/Post.template.php    Test successful
9.    Execute Modification    ./Sources/Karma.php    Test successful
10.    Execute Modification    ./Sources/Subs.php    Test successful
11.    Execute Modification    ./Sources/Security.php    Test successful
12.    Execute Modification    ./Sources/ManagePermissions.php    Test successful
13.    Execute Modification    ./Themes/default/index.template.php    Test successful
14.    Execute Modification    ./Sources/Load.php    Test successful
15.    Execute Modification    ./Themes/default/languages/Modifications.english.php    Test successful
16.    Extract File    ./Sources/VisualWarning11.php    
17.    Extract File    ./Themes/default/VisualWarning.template.php    
18.    Extract File    ./Themes/default/images/warnban.gif    
19.    Extract File    ./Themes/default/images/warnpmod.gif    
20.    Extract File    ./Themes/default/images/warnmute.gif    
21.    Extract File    ./Themes/default/images/warnwarn.gif    
22.    Extract File    ./Themes/default/images/members.gif    
23.    Extract File    ./Themes/default/images/buttons/warn.gif    
24.    Execute Modification    ./Themes/default/languages/Modifications.french.php    File not found
25.    Execute Modification    ./Themes/default/languages/Modifications.polish.php    File not found
26.    Execute Modification    ./Themes/default/languages/Modifications.turkish.php    File not found
27.    Execute Modification    ./Themes/default/languages/Modifications.croatian.php    File not found
28.    Execute Modification    ./Themes/default/languages/Modifications.danish.php    File not found
29.    Execute Modification    ./Themes/default/languages/Modifications.spanish.php    File not found
30.    Execute Modification    ./Themes/default/languages/Modifications.portuguese.php    File not found
31.    Execute Modification    ./Themes/default/languages/Modifications.brazilian.php    File not found

Any suggestions?

Rumbaar

There are no errors in that test?  If you are not using those languages then you can proceed.
"An important reward for a job well done is a personal sense of worthwhile achievement."

[ Themes ]

Eleglin

#418
hello Digit. You're right. I'm sorry for these problems, I haven't use the manual modification for a while, so I haven't seen these bugs.
I try to generate a new modification file for version 1.42. *Done and updated for 1.42. I must test 1.3x again*
No support by PM or Mail.

quiz_modder

I have visualwarning142.zip installed. I have SMF 1.1.6. I get the following errors in my Forum Error Log. Seems to be a coding error? Thanks

8: Undefined index: warning
File: /public_html/community/Sources/Post.php
Line: 1092

8: Undefined index: warning
File: /public_html/community/Sources/Post.php
Line: 103

8: Undefined index: warning
File: /public_html/community/Sources/Post.php
Line: 101

Advertisement: