• Welcome to Simple Machines Community Forum. Please login or sign up.
December 07, 2021, 03:35:28 PM

News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord


Türkçe Karakter Problemi Çözümleri (UTF-8, latin, vs...)

Started by 4LP3RUZ1, November 23, 2007, 10:01:19 AM

Previous topic - Next topic

4LP3RUZ1

SMF ile özellikle yedekleme veya site taşıma sırasından MySQL ayarları ve/veya SMF'nin ayarlarındaki hatalar yüzünden sıkça Türkçe karakter problemleri ile karşılaşılmaktadır.

Aslında kod sayfalarını hep sabit tutarsanız, yükleme ve yedeklemeler sırasında elde ettiğiniz dosyaların da kodlama sayfasını aynı şekilde ayarlarsanız bu sorun ile hiç karşılaşmayabilirsiniz.

Yine de eğer bir kere verilerinizde belirmiş ise, bu problem oldukça can sıkmaktadır. Bu yüzden bazı arkadaşlar bu konuda rehberler hazırlamışlardır.

Bu konuda bu rehber veya tüyoları bulabilirsiniz.

dberdi'nin MySQL Control Center kullanma rehberi: http://www.simplemachines.org/community/index.php?topic=116963.0

temkick'in HeidiSQL anlatımı: http://www.simplemachines.org/community/index.php?topic=168335.0

K@TİL'in Settings.php tüyosu: http://www.simplemachines.org/community/index.php?topic=200352.0

Tavsiyem, eğer yeni bir SMF kurulumu yapacaksanız, UTF-8 ile kurmanız, ve sonrasında tüm yedeklemeleri, MySQL ayarlarını UTF-8 yapmanızdır.
Frozen frogs are back :(

Bitirim

Selamın aLeykum Hocam Birşey sormak istiyordum cahilliğime bağışlayın forumum Türkçe Karakterli kelimeleri çoğunu desteklemiyor yani i harfini ? olarak ßelirtior ş mesela ? olarak çıkıor yani desteklemior ama arkadaşlar yeniden kurmaktan ßaşka çaren yok gißilerinden kelimeler kullandılar dblerim silinmicek şekilde.. bunu düzeltmeme yardım ederseniz sevinirim.. yada yardım edeßilecek ßir arkadaş MSN adresini yazaßilirse memnun olurum şimdiden teşekkürler yardımlarinizi ßekliyorum..

βluΣ ЯosΣ

arkadaşım forumu hangi dil paketiyle kurdun utf8 mi yoksa türkce mi

onrozcn

benim forumum UTF-8 ama yinede sql u yujledikten sonra türkçe pakette değil ama foruma eski yazılmıs olan postlarda TR problemi oluyor.. ama yeni msj yazanlarda tüm karakterler normal olarak gozukuyor.. bunun sebebi ne olabilir?

www.nfstr.com


4LP3RUZ1

Quote from: onrozcn on December 14, 2007, 03:04:38 AM
benim forumum UTF-8 ama yinede sql u yujledikten sonra türkçe pakette değil ama foruma eski yazılmıs olan postlarda TR problemi oluyor.. ama yeni msj yazanlarda tüm karakterler normal olarak gozukuyor.. bunun sebebi ne olabilir?
İki problem olabilir, ya yedek dosyasındaki türkçe karakterler de yedeklenirken oluşan bir hata yüzünden bozuktur.
Ya da yedek yüklenirkenki mySQL bağlantı ayarlarında sorun vardır, onların da UTF-8 olarak ayarlanması gerekmektedir
Frozen frogs are back :(

pnyr

hocam selam, UTF-8 ile kurdum forumu. Daha sonra ufak bir portal yaptim ve portala SSI ile veri gosterdim. Fakat yaptigim portal utf degil normal turkish dil destegi oldugu icin SSI verileri hatali cikiyor. UTF-8 den Turkish-1254 e nasil gecirebilirim forumu?
tesekkurler.

4LP3RUZ1

niye portalı değiştirmeyi düşünmüyorsunuz? Dediğiniz şey "downgrade" gibi birşey olur.
Frozen frogs are back :(

pnyr

hocam portalı çok büyüttüm ayrıntıları var. O yüzden onu değiştirmek ölüm olur... başka bir yol yok mu?
DB yi windows char dan UTF ye çeviren özellik var da, tersi yok mu?

iyi bayramlar

AODWeb

Merhaba,

Öncelikle dokümanları yazan, derleyen ve bize yardımcı olan herkese teşekkürler. Türkçe karakterlerle ilgili ilginç bir problem de ben yaşıyorum.

Kurulumu yaparken MySQL Karşılaştırma Dili ve tüm veritabanı seçimlerinde UTF-8 Unicode seçtim. Türkçe paket olarak da UTF-8 indirip bu şekilde kurulum yaptım. Sorunsuz bir şekilde tamamladım. Fakat yeni bir tema yüklediğimde temanın dosyalarından düzenleneceğini tahmin ettiğim kısımlarda Türkçe karakterler yerine tanımsız işaretler çıkıyor.

Aşağıdaki görüntünün yardımı olacaktır diye umuyorum.

Bunu düzeltmemde yardım edebilir misiniz ?

Kullandığım Tema (b_gray) ve Görüntü Resmi :

hxxp:img149.imageshack.us/img149/4383/dilsorunuqt6.jpg [nonactive]

Özveriniz için teşekkürler.

AODWeb

İnsan bir süre kendi sorunuyla başbaşa kalıp düşününce illa ki çözümü buluyor. :)

SMF'yi Yeni Kuracaksınız ve İleride Hiçbir Yönden Türkçe Karakter Sorunu Yaşamak İstemiyor Musunuz ?

Cevabınız "Evet" ise defalarca test ettiğim ve hiçbir sorun yaşamadığım aşağıdaki yöntemi uygulamanızı öneririm.

Ayrıca @alperuzi ;

Eğer uygun görürseniz bu vereceğim linkteki anlatımı bu başlığa da koymanızı rica edebilir miyim ?

http://www.simplemachines.org/community/index.php?topic=213751.0

Herkese başarılar.

yaseys

merhaba.. benim sitemde türkçe karakter sorunu var.. forumu daha yeni yükledim.. türkçe olarak yükledim.. ama karakterlerde bir problem yaşadım.. dil paketi indirip ftp den yeniledim yine düzeltemedim.. burdaki tüm seçenekleri denedim ama olmadı.. utf-8 değil forumum..

bana yardımcı olabilirmisiniz bu sorun neden kaynaklanıyor olabilir?

4LP3RUZ1

@AODWeb

çok detaylı ve yararlı bir anlatım. Ancak tek bir problemi var :) O da tüm SMF Türkçe içeriğini eski kod sayfalarından UTF-8'e geçirmeye çalışıyor olmam.

SMF başlangıçta tüm dillerde UTF-8 dil desteği ile başlasaydı ve UTF-8 deneyimli geliştiriciler bulsaydı karşılaşılan birçok problem başlamadan çözülürdü. Ama olsun, şimdi yapmamız gereken yavaş yavaş da olsa durumu düzeltmeye çalışmak.
Frozen frogs are back :(

AODWeb

@alperuzi,

Yorumun için teşekkürler. Fakat UTF-8'e geçirme işleminden haberim yoktu. Gerçi bir şey değiştirmez. Çünkü makalede prototipten anlaşıldığı gibi veritabanında latin5 seçildiği zaman kullanılan modifikasyonların ilgili dosyalarında veritabanı bağlantısından sonra MySQL'e latin5 kullanılacağını söylersek otomatik düzeliyor.

Tabi her şey UTF-8 olduktan sonra UTF-8 kullanmamak için de hiçbir neden kalmyacak.

Biraz uzun sürecek fakat iki türlü çözüm ortaya çıkacak. Buna sevindim.

Çalışmalarından dolayı tebrik ederim. ;)


JeeFo

Arkadaşlar selam ufak bi sorunum var sitemi kurarken utf8 ile kurmuşum e doğal olarakda mod kurarken Türkçe karakter sorunu oluyor bunu en kolay nasıl halledebilirim birde utf8 i nasıl normale geçiririm

4LP3RUZ1

Modları UTF-8'e göre uyarlayacaksınız, tersi değil

Yapmak oldukça basit, diğer konuda da cevaplamıştım.

Mod dosyalarını açıp *.turkish.php leri *.turkish-utf8.php yapacaksınız. Sonra da notepad ile save-as diyerek UTF8 kodlamasını seçeceksiniz. Bu kadar basit, Modifikasyonlar bölümünde de sabit başlıkta yazıyor zaten.
Frozen frogs are back :(

JeeFo

Quote from: alperuzi on February 28, 2008, 07:05:16 AM
Modları UTF-8'e göre uyarlayacaksınız, tersi değil

Yapmak oldukça basit, diğer konuda da cevaplamıştım.

Mod dosyalarını açıp *.turkish.php leri *.turkish-utf8.php yapacaksınız. Sonra da notepad ile save-as diyerek UTF8 kodlamasını seçeceksiniz. Bu kadar basit, Modifikasyonlar bölümünde de sabit başlıkta yazıyor zaten.

Alperuzi çok konumu kitledin çok canımı yaktın :P ama bu sefer çok teşşekkürler süpersin :)

coolike

Ben Yedegi uft-8 e dönüştürmüştüm fakat veritabanini komple sildim yeni yaptım yedegi attim uft-8 türkçe yide attim ama menüler haric heryerde sorun var kısacası forumda yedek uft-8 oldugu için sıkıntı yaratıyor diye düşnüyorm. MySQL karakter seti:  UTF-8 Unicode (utf8) ama gende olmuyor neden  ?

moodle

Selam arkadaslar, vbulletin forumumu tasimak icin smf kuruyorum. Fakat kurdugum smf forumda türkce karakterler soru isareti olarak cikiyor. Temada hic bir sorun yok, yalniz mesaj ve basliklardaki karakterlerde hata var. Hem utf8 hem de latin 5 secerek kurmayi denedim. Ikiside ise yaramadi.

Internette günlerdir cözüm bulmaya calisiyorum ama hic biri ise yaramadi. Bana yardimci olabilecek biri var mi?

YuC3L

ya bu yedek alma bölümüne utf 8 koyulması yanlıs deilmi yedek alırken bastım mahvoldu geri nasıl cevrilcek arıyorum bulamıyorum 1 allahın kulu da yardım etsin lütfen ya o kadar üye konu gitmesin nasıl olacak bu iş ? lütfen

Echo91

ya ben direk fantasticodan yükledim utf8 olarak direk yüklendi ama hala problem yapıor anamadım ve bide dberdi arkadaş anlatmış çok güzelde ben host ipte takıldım host ip dns ipleri deilmi domaini yönlerdiirdimiz? yoksa farklımı?

playbek.com

merhaba arkadaşlar beni forum sürümü 1.1.11

üyelere e posta atınca e posta sadece başlıklarında türkçe katrakter sorunu oluyor

ama forumumda utf 8 değil normal turkish ama neden türkçe karakter sorunu oluyor e postalarda

lodos0677

Merhabalar,
Siteme Top10 ve bir kaç ekleme yaptım.Sonrasında admın panelınde tabloları en ıyı hale getır sekmesıne tıklayınca forumda kı butun karakterlerde ff ve ? soru işaretleri şeklinde bozulmalar oldu.
Bu hatayı duzeltmek ıcın forum admın panelınden veri-tabanını ve veriyi UTF-8 dönüştür dedim. orjınal UTF-8 Türkçe dil dosylarını buradan bulup yükledim. Ama hata düzelmedi.Resimde görüleceği üzere bu hataları düzeltmek için başka hangi dosyaları değiştirmem gerekecek.



Advertisement: