Advertisement:

Author Topic: Error: "not an error<br />"  (Read 9468 times)

Offline Moptop650

  • Semi-Newbie
  • *
  • Posts: 13
Error: "not an error<br />"
« on: March 18, 2008, 04:35:10 PM »
Ok, so I installed the latest under SQLite, then moved it to another server. I am CONFIDENT I have all the paths right, but when I go to the index, all it outputs is "not an error<br />"

What causes this? I searched all the the files for the string "not an error" but nothing came up?

Offline karlbenson

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 15,629
  • Gender: Male
    • Criminal Brief UK
Re: Error: "not an error<br />"
« Reply #1 on: March 18, 2008, 05:01:46 PM »
Have you ran repair_settings.php?

I'll have a test of this myself i think.

Offline CmptrWz

  • Jr. Member
  • **
  • Posts: 378
  • Gender: Male
Re: Error: "not an error<br />"
« Reply #2 on: March 18, 2008, 05:06:22 PM »
That is the sqlite call, I believe. It is apparently caused when you tell sqlite to do stuff with a file that sqlite does not understand, or does not exist.

Or, at least, that is what google said.

Check your sqlite file permissions and paths and try again?

Offline Moptop650

  • Semi-Newbie
  • *
  • Posts: 13
Re: Error: "not an error<br />"
« Reply #3 on: March 18, 2008, 06:14:45 PM »
The database is 777. I tried exporting the database and reimporting it to another file with SQLiteManager and switching to that database, to make sure its read/writable.

As for the paths, they are fine -

Quote
iMac:~ Dave$ ssh root@10.0.1.91
root@10.0.1.91's password:
Permission denied, please try again.
root@10.0.1.91's password:
Last login: Tue Mar 18 16:40:33 2008 from 10.0.1.90
# cd /var/root/Media/WebServer/Documents/smf
# cd /var/root/Media/WebServer/Documents/smf/Sources
# cd /var/root/Media/WebServer/Documents/smf/cache
# cd /thisDoesntExistButIsAnErrorExample
cd: no such file or directory: /thisDoesntExistButIsAnErrorExample
#

As for repair_settings.php, I do not seem to have that.

Offline karlbenson

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 15,629
  • Gender: Male
    • Criminal Brief UK
Re: Error: "not an error<br />"
« Reply #4 on: March 18, 2008, 06:39:02 PM »
Personally, I wouldn't recommend using Sqlite for anything other than very small forums.
If you can use mysql or postgresql you should use that instead.

Eg it might be possible to get away with it for a small intranet site.

Offline Moptop650

  • Semi-Newbie
  • *
  • Posts: 13
Re: Error: "not an error<br />"
« Reply #5 on: March 18, 2008, 06:54:54 PM »
Well its not really intended for use, just for checking it out..

Offline JayBachatero

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 19,562
  • Gender: Male
    • @jaycreations on Twitter
    • JayBachatero.com
Re: Error: "not an error<br />"
« Reply #6 on: March 18, 2008, 11:58:28 PM »
Where do you have the .db file and what is the value for $db_name in the Settings.php file?
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

Offline Moptop650

  • Semi-Newbie
  • *
  • Posts: 13
Re: Error: "not an error<br />"
« Reply #7 on: March 19, 2008, 06:12:46 PM »
Its in the root smf directory, file is smfnew.db, and the settings file has

Code: [Select]
$db_name = 'smfnew.db';

Offline JayBachatero

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 19,562
  • Gender: Male
    • @jaycreations on Twitter
    • JayBachatero.com
Re: Error: "not an error<br />"
« Reply #8 on: March 19, 2008, 06:30:26 PM »
Try setting the full path to the file.  /public_html/smf/smfnew.db.  Something like that.  What ever your path is.
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

Offline Moptop650

  • Semi-Newbie
  • *
  • Posts: 13
Re: Error: "not an error<br />"
« Reply #9 on: March 19, 2008, 06:53:16 PM »
From the root of my drive or apache documentroot?

Edit: Tried both, same thing. :S  If I put in an invalid path, Sqlite errors do come up (I have modified the file to show errors), so I think it is connecting to the database... Hmm
« Last Edit: March 19, 2008, 06:56:06 PM by Moptop650 »

Offline JayBachatero

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 19,562
  • Gender: Male
    • @jaycreations on Twitter
    • JayBachatero.com
Re: Error: "not an error<br />"
« Reply #10 on: March 19, 2008, 07:11:50 PM »
Post the .db file.  Let me take a look at it and see if SMF was installed correctly.  OR you can just try reinstalling SMF and see if it works.
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

Offline Moptop650

  • Semi-Newbie
  • *
  • Posts: 13
Re: Error: "not an error<br />"
« Reply #11 on: March 19, 2008, 08:14:43 PM »
When I use the installer on that server, I get...

SQL logic error or missing database

On install.php?step=1 after I submit the form with correct info and stuff...


And by playing with Subs-Db-sqlite.php, I found that it is trying to run the query...

Code: [Select]
INSERT INTO smf_settings(variable, value) VALUES
Followed by a blank query when I install....

Edit: Attached are the 2 different databases I tried - smf.db is a copy from the other server that worked, the other is a SQLiteManager export then imported copy.

Edit: More server info.
Apache 1.3.37
PHP 5.2.3
SQLite 2.8.17
« Last Edit: March 19, 2008, 08:25:39 PM by Moptop650 »

Offline JayBachatero

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 19,562
  • Gender: Male
    • @jaycreations on Twitter
    • JayBachatero.com
Re: Error: "not an error<br />"
« Reply #12 on: March 20, 2008, 12:29:11 AM »
Umm I just loaded those two files and they work file.  I tested my SQLite install with those files and they work.  What are the permissions on the files?

BTW what version of SQLite are you running?

EDIT:  Are you running under safe mode?
« Last Edit: March 20, 2008, 12:34:56 AM by JayBachatero »
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

Offline Moptop650

  • Semi-Newbie
  • *
  • Posts: 13
Re: Error: "not an error<br />"
« Reply #13 on: March 20, 2008, 10:25:21 AM »
SQLite 2.8.17

Both files were 777.

For safe mode, I am not sure. Is that an apache settings? Or smf?

Offline karlbenson

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 15,629
  • Gender: Male
    • Criminal Brief UK
Re: Error: "not an error<br />"
« Reply #14 on: March 20, 2008, 11:17:13 AM »
PHP.
It would be shown a phpinfo

(eg create a .php file and add to it)
Code: [Select]
<?php 
phpinfo
();
?>

Offline Moptop650

  • Semi-Newbie
  • *
  • Posts: 13
Re: Error: "not an error<br />"
« Reply #15 on: March 21, 2008, 09:05:12 PM »
Ah.

Safe mode is off.

Offline JayBachatero

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 19,562
  • Gender: Male
    • @jaycreations on Twitter
    • JayBachatero.com
Re: Error: "not an error<br />"
« Reply #16 on: March 21, 2008, 10:32:49 PM »
Umm can't think of anything.  Try this.

Code: [Select]
<?php
error_reporting
(E_ALL);
$open sqlite_open('smfnew.sql'0666$error);
if (
$open === true)
   echo 
'opened';
else
    echo 
$error;
?>


Save that as sqlitetest.php and access it from your browser and tell me the output.
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

Offline Moptop650

  • Semi-Newbie
  • *
  • Posts: 13
Re: Error: "not an error<br />"
« Reply #17 on: March 22, 2008, 11:09:03 AM »
Nothing at all, just a blank page...  :o

Offline CmptrWz

  • Jr. Member
  • **
  • Posts: 378
  • Gender: Male
Re: Error: "not an error<br />"
« Reply #18 on: March 22, 2008, 12:18:51 PM »
Enable display_errors. Usually can be done with a .htaccess file in the directory, containing:

php_flag display_errors on

Then try again?

Offline Moptop650

  • Semi-Newbie
  • *
  • Posts: 13
Re: Error: "not an error<br />"
« Reply #19 on: March 26, 2008, 03:22:23 PM »
Doing that gives me an error 500 internal server error...