SMF 2.0 Beta 3.1 Upgrade !!Error

Started by d58e7, May 18, 2008, 04:29:49 PM

Previous topic - Next topic

d58e7

For some reason the update starts but it doesn't do anything once it starts. It says updating the database then after a few minutes I get a box with !!Error with no information as to the error. Is there a work around? If not is there anyway to just update the database manually?

Edit: Rather than use 3.1, I instead installed 3 and that worked.

d58e7

Nope Trying to update the database from a version 1.4 forum and it just sits at:

Executing upgrade script 1 of 2.
Executing: "Updating and creating indexes..." (1 of 19 - of this script).

Then it becomes

!!Error!

sadierose


Rupert Hawkes

I get this error too!

I am running 1.1.5, have uploaded the large package (yes all files got there!), edited the upgrade.php to match the 3.1 beta then ran the script.  I reports some language files are out of date (so I select skip).

Then I get the error...

"Error !!"

..whilst running...

Executing upgrade script 1 of 2.
Executing: "Updating and creating indexes..." (1 of 19 - of this script).

How can *WE* fix this??????????????????????????

N3RVE

All three of you ::)

Please Download SMF 2.0 Beta 3 Public here

Upgrade to that version and apply the 2.0 Beta 3.1 Public Patch from the Package manager.

Note: As this is in early beta we do not suggest running SMF 2.0 Beta 3.1 Public on a production site.
Ralph "[n3rve]" Otowo
Former Marketing Co-ordinator, Simple Machines.
ralph [at] simplemachines [dot] org                       
Quote"Somewhere, something incredible is waiting to be known." - Carl Sagan

Rupert Hawkes

#5
OK, tried SMF 2.0 Beta 3 and now get this error right at the start of the upgrade process!  I'm using WinSCP to upload the files and according to the logs ALL files were uploaded successfully.  Any ideas?  TA!!!

The upgrader found some old or outdated files.

Please make certain you uploaded the new versions of all the files included in the package.

N3RVE

Do you have any other language files in use apart from English?

-[n3rve]
Ralph "[n3rve]" Otowo
Former Marketing Co-ordinator, Simple Machines.
ralph [at] simplemachines [dot] org                       
Quote"Somewhere, something incredible is waiting to be known." - Carl Sagan


Rupert Hawkes

ARRGHHH!  That link above seem to be for a new install - NOT an upgrade.  Where can I get an upgrade for 1.1.5 --> 2.0 Beta 3.  This is driving me nuts!

Rupert Hawkes

Yes I tried editing the file as per those suggestions (as did the others here) and got the error...

!!Error

Please read the thread - I already said...

I get this error too!

I am running 1.1.5, have uploaded the large package (yes all files got there!), edited the upgrade.php to match the 3.1 beta then ran the script.  I reports some language files are out of date (so I select skip).

Then I get the error...

"Error !!"

..whilst running...

Executing upgrade script 1 of 2.
Executing: "Updating and creating indexes..." (1 of 19 - of this script).

How can *WE* fix this?? 


Rupert Hawkes

#11
Tried again from scratch...

1.  Deleted all files from mny dev site.
2.  Copied all files from live site to dev site.
3.  Uploaded ALL files from the 2.0 Beta 3 release (as suggested above)
4.  Ran the upgrade.
5.  Then whilst doing this...

Executing database changes
Please be patient - this may take some time on large forums. The time elapsed increments from the server to show progress is being made!
Executing upgrade script 1 of 2.
Executing: "Updating and creating indexes..." (1 of 19 - of this script).

...It reports "!!Error".

ARGH!  Not helpful.  Now what????????  I have tried 2.0 Beta 3.0 and 2.0 Beta 3.1

And NO it's not the script problem whereby it's showing the wrong verion.  Any ideas?????????????????

Should I wait till it's out of beta and a proper upgrader is released?

N3RVE

Sorry, but you may have to be a little more patient;

The 1.1.5 package was rebuilt a couple of weeks ago.

A request has been sent to the developers for the 2.0 package to be rebuilt.  We honestly regret any inconviniences this might have caused you.

-[n3rve]
Ralph "[n3rve]" Otowo
Former Marketing Co-ordinator, Simple Machines.
ralph [at] simplemachines [dot] org                       
Quote"Somewhere, something incredible is waiting to be known." - Carl Sagan

Rupert Hawkes

OK, rebuilt because of that little script error to do with the versioning?

It doesn't seem to be the script error as if I correct that I still get an error.

Rumbaar

Yes that certainly isn't much of a descriptive error message...

Are you able to access your RAW server logs and see if it can give us any additional information to what is causing the error.
"An important reward for a job well done is a personal sense of worthwhile achievement."

[ Themes ]

RoyceMcKnight

I'm getting the same "!!Error" error. There are no further messages in the apache error log.

SleePy

Start the upgrade over and check the debug mode option.

This should hopefully provide us with more information on why this is occurring  :D
Jeremy D ~ Site Team / SMF Developer ~ GitHub Profile ~ Join us on IRC @ Libera.chat/#smf ~ Support the SMF Support team!

RoyceMcKnight

I already used the debug option. But as I said, there's no error message displayed nor is there an error message in the apache error log.

Zeshin

Has this been dropped or something?

I originally downloaded the Large Upgrade package for SMF Beta Public 3.1 and I got the same error as above. Then I downloaded the 3.0 large upgrade and I think I got the same error with a little more details:

Quote

Executing upgrade script 1 of 2.
Executing: "Updating and creating indexes..." (1 of 19 - of this script).

Database Updates Complete! Click Continue to Proceed.
Updating indexes on "messages"...
!!
Error!



Anything on this? Luckily this is just my development forum, so no big rush right now.

cuscus

#19
Yep, i'll be joining this party. Getting the exact same problem. :'(
Would someone be kind enough to pm me or something if a solution is found? Cheers!

metallica48423

If interested, could you guys could please try the beta 4 upgrader?
Justin O'Leary
Ex-Project Manager
Ex-Lead Support Specialist

QuoteMicrosoft wants us to "Imagine life without walls"...
I say, "If there are no walls, who needs Windows?"


Useful Links:
Online Manual!
How to Help us Help you
Search
Settings Repair Tool

RoyceMcKnight

It tried it, but it's almost the same error.


Database Changes
Executing database changes
Please be patient - this may take some time on large forums. The time elapsed increments from the server to show progress is being made!
Executing upgrade script 1 of 2.
Executing: "Updating and creating indexes..." (1 of 19 - of this script).

Database Updates Complete! Click Continue to Proceed.
Updating indexes on "messages"...


and then after abount 10 seconds
!!
Error!
Unknown Error!

metallica48423

hmmm... i wonder where its tripping up..

1.) what is the *last thing* it says prior to erroring?
2.) Do you get any errors logged by your webserver in its error log?
Justin O'Leary
Ex-Project Manager
Ex-Lead Support Specialist

QuoteMicrosoft wants us to "Imagine life without walls"...
I say, "If there are no walls, who needs Windows?"


Useful Links:
Online Manual!
How to Help us Help you
Search
Settings Repair Tool

RoyceMcKnight

Well, I am wondering too :-)

1. sh screenshot
2. no there's no entry in the apache error log. There's only one in the access log which shows the POST event after hitting the upgrade button.

217.227.30.114 - - [18/Sep/2008:15:52:33 +0200] "POST /smf2/upgrade.php...............

metallica48423

Justin O'Leary
Ex-Project Manager
Ex-Lead Support Specialist

QuoteMicrosoft wants us to "Imagine life without walls"...
I say, "If there are no walls, who needs Windows?"


Useful Links:
Online Manual!
How to Help us Help you
Search
Settings Repair Tool

RoyceMcKnight

Yeah, well, you can't see it, because I'm stupid and did not attach it  O:)

metallica48423

That will do it :P

I'll have to have a look at what exactly its doing when i get home a little later.

how big is your messages table?
Justin O'Leary
Ex-Project Manager
Ex-Lead Support Specialist

QuoteMicrosoft wants us to "Imagine life without walls"...
I say, "If there are no walls, who needs Windows?"


Useful Links:
Online Manual!
How to Help us Help you
Search
Settings Repair Tool

RoyceMcKnight

It's not that big: 21.000 Records taking about 18MB of space.

RoyceMcKnight

Any news there? In the meantime I tried upgrading to the newest Beta of v2 un another Board of mine, which gives the exact same error. The other board has about 55.000 records taking 38mb of space.

torquone

#29
I'm not able to understand what are the problems during upgrade.
I uploaded smf 2.0 beta 4 large upgrade files on my smf forum directory on the web server.
It seems that some database instructions fails.

I have installed also italian language pack for smf 2.0 beta 4 because my forum had italian as default language.

Here's my forum info :

Link of my test forum : http://area51.quattrochiacchere.net/smf2/ [nofollow]

The status page link : http://area51.quattrochiacchere.net/smf2/status.php [nofollow]

MySQL version : 5.0.32
PHP Version     : 5.2.0-8+etch11
                          memory_limit            128M   
                          register_globals        Off   
                          max_execution_time  30
                          max_input_time        60
                          session.use_trans_sid   0
                          post_max_size        8M
                          upload_max_filesize  20M

SMF starting version : 1.1.5



Here's the Mods installed on my smf forum :

Mod Name                        Mod version














SMF Staff Page  1.5.1
Wikipedia BBCode (Italiano)  1.0
Image Align Tag  0.3
Seo 4 SMF  0.2.9.9
Auto Embed Video Clips  1.3
Global Headers Footers  1.3
Contact Page  1.1
RSS Feed Icon  1.1
Topic Ratings  1.03
Advanced Visual Verification  1.1
Wikipedia BBCode  1.2
Tagging System  1.0.4
Googlebot & Spiders Mod  2.0.3

My messages table have 644 records for 4.2MB of space.

I have this Theme Installed :

Millenium 1.1
Christmas Season 1.1
Dilber Multicolor 1.1
                                      
Before i launched the upgrade.php from my site , I also ticked the checkbox "Output extra debugging information" but this don't help me :-(

Thanks in advance for help us.
My site : http://www.quattrochiacchiere.net [nofollow]

gumgone

is this still outstanding ... because I'm getting sick ... this might be my problem..

wow.... this is the only FORUM ... under this name ... all of the other 17 forums are under another software FORUM.... and this look to be a nightmere....I have a large group of business users ... that are probably wondering what's wrong ....

I downloaded this file and copied after unzip  ... however it now seems to be a fresh install ... because it is asking for for host name and dbname....

smf_2-0-beta3p_install.zip

shaking my head... and F U ...!!!!!!!!!   $%^&(


metallica48423

i'm going to ask a developer to look at this.   Thanks.

And respectfully, in the future, do not swear at us.  Thank you.
Justin O'Leary
Ex-Project Manager
Ex-Lead Support Specialist

QuoteMicrosoft wants us to "Imagine life without walls"...
I say, "If there are no walls, who needs Windows?"


Useful Links:
Online Manual!
How to Help us Help you
Search
Settings Repair Tool

gumgone

#32

Anyone knows where the updater is ?????

the updater is ?????



gumgone

Quote from: metallica48423 on September 28, 2008, 08:13:00 PM
i'm going to ask a developer to look at this.   Thanks.

And respectfully, in the future, do not swear at us.  Thank you.

do you have any suggestions how to find this updater>>

metallica48423

the upgrade package for beta 4 is on our downloads page:
http://download.simplemachines.org/

If you scroll down to the 2.0 section you will see the part where it says "Large Upgrade"

That is the upgrade package.
Justin O'Leary
Ex-Project Manager
Ex-Lead Support Specialist

QuoteMicrosoft wants us to "Imagine life without walls"...
I say, "If there are no walls, who needs Windows?"


Useful Links:
Online Manual!
How to Help us Help you
Search
Settings Repair Tool

SleePy

Is there any processes in the mysql processlist?  You can find that in phpMyAdmin.What is phpMyAdmin?
Jeremy D ~ Site Team / SMF Developer ~ GitHub Profile ~ Join us on IRC @ Libera.chat/#smf ~ Support the SMF Support team!

RoyceMcKnight

Hi there, nope, there's no process shown in the mysql process list (while upgrading). I used phpMyAdmin and mytop to look at it.

torquone

#37
Hi everebody , i checked mysql process list during upgrade process by phpMyAdmin , but there wasn't any process except for the list process itself.  ::)
My site : http://www.quattrochiacchiere.net [nofollow]

Oldiesmann

I can't figure out why that box is being displayed if $upcontext['error_message'] isn't even set.

Based on the information you've given, it appears the error is occurring early on in the upgrade_1-1.sql script:
$request = upgrade_query("
SHOW KEYS
FROM {$db_prefix}messages");
$found = false;
while ($row = mysql_fetch_assoc($request))
$found |= $row['Key_name'] == 'ID_BOARD' && $row['Column_name'] == 'ID_MSG';
mysql_free_result($request);

if (!$found)
upgrade_query("
ALTER TABLE {$db_prefix}messages
DROP INDEX ID_BOARD");


What do you get if you run that SHOW KEYS statement in phpMyAdmin? (Remember to replace {$db_prefix} with your actual DB prefix)
Michael Eshom
Christian Metal Fans

RoyceMcKnight

I attached the phpMyAdmin output as screenshot

Nathaniel

Bumping this so that the other SSers see it. :)

Have any of you guys tried moving your forum data onto a local server, and then upgrading it there? Its a long shot, but it might work. ;)
SMF Friend (Former Support Specialist) | SimplePortal Developer
My SMF Mods | SimplePortal

"Quis custodiet ipsos custodes?" - Who will Guard the Guards?

Please don't send me ANY support related PMs. I will just delete them.

N3RVE

I don't even know who and who still require assistance ???
I'll lock this topic, it has come a long way and makes the Support process a little tough :P
If anyone require support, please start a new topic :)

-[n3rve]
Ralph "[n3rve]" Otowo
Former Marketing Co-ordinator, Simple Machines.
ralph [at] simplemachines [dot] org                       
Quote"Somewhere, something incredible is waiting to be known." - Carl Sagan

Advertisement: