• Welcome to Simple Machines Community Forum. Please login or sign up.
September 28, 2021, 12:09:17 AM

News:

Join the Facebook Fan Page.


Fatel Error 1.1.4-to-2.0 Upgrade

Started by lordtron, August 05, 2008, 03:28:36 AM

Previous topic - Next topic

lordtron

Whenever I try to upgrade from 1.1.4 to 2.0 I get this error:

Fatal error: Call to undefined function: mysql_real_escape_string() in /v2/forums/Sources/Subs-Db-mysql.php on line 145

VainSoftGames.com - New Design To Gaming

greyknight17

How are you installing the upgrade? Are you downloading the large upgrade package and overwriting all your files on the server?

lordtron

Yes, I downloaded the Large Upgrade Package and overwrote all the files on the server with the package files.



VainSoftGames.com - New Design To Gaming

Rumbaar

I'm not 100% sure, but that function is part of CORE PHP functionality.  What version of php are you running?
"An important reward for a job well done is a personal sense of worthwhile achievement."


[ Themes ]

lordtron

Last time I checked, it was PHP 2.4.0

VainSoftGames.com - New Design To Gaming

Rumbaar

Quote from: lordtron on August 11, 2008, 12:01:51 PM
Last time I checked, it was PHP 2.4.0
huh!  I think you might want to check again.  But if that is true ... as we're up to PHP 5 now ... and PHP 4.4.9 is the latest stable version ... PHP 2 is OLD.=, I don't know how SMF is working at all on that.

http://www.php.net/mysql_real_escape_string - (PHP 4 >= 4.3.0, PHP 5, PECL mysql:1.0)
"An important reward for a job well done is a personal sense of worthwhile achievement."


[ Themes ]

lordtron

Alright, my phpMySQL is 2.4.0
My PHP is 4.2.2

VainSoftGames.com - New Design To Gaming

Rumbaar

Well that is your problem as well then PHP 4 >= 4.3.0.  I'm sure 4.2.2 is quite old as well, you need to be greater than or equal to 4.3.0.  So an upgrade of your PHP is in order.
"An important reward for a job well done is a personal sense of worthwhile achievement."


[ Themes ]

lordtron

Well that is out of the question then.
I guess I am gonna need to use my own server or get a new hosting plan if I want to move to 2.0 for this website.

VainSoftGames.com - New Design To Gaming

Rumbaar

Well I would look to a better host that is willing to use up-to-date (and most likely) more secure software.

Not sure even after the conversion process there aren't any >= 4.2.2 functions needed, so I'm not sure it will run after the upgrade on another system and moved back.
"An important reward for a job well done is a personal sense of worthwhile achievement."


[ Themes ]

lordtron

lol
I have the funniest thing to say. This topic post was about my new hosting. It has the most up-to-date version of PHP and MySQL and that is how I am getting this error.

Any answers about that?

PHP: 5.2.6
MySQL: 5.0.51B(I do have access to 6.0.4 Alpha)

VainSoftGames.com - New Design To Gaming

Rumbaar

You getting the exact same error? When you are trying to upgrade your 1.1.4 SMF forum to 2.0 BETA Public 3.1 on that host?

... and this isn't the computer that's sitting next to you?
"An important reward for a job well done is a personal sense of worthwhile achievement."


[ Themes ]

lordtron

I get a different error all together when I upgrade on my old hosting.

But I am talking about my own server that I have when I try to upgrade from 1.1.4 SMF forum to 2.0 Beta Public 3.1. The one that is the computer next to me.

VainSoftGames.com - New Design To Gaming

Rumbaar

You started this thread, you got an error. I asked what PHP version you're running to get this error and you said 4.2.2.  Now you say you're on PHP: 5.2.6.  So what error are you getting now?!!
"An important reward for a job well done is a personal sense of worthwhile achievement."


[ Themes ]

lordtron

This error message came from the PHP 5.2.6 server.

VainSoftGames.com - New Design To Gaming

Rumbaar

So when I first asked why did you answer this?
Quote from: lordtron on August 11, 2008, 06:30:07 PM
Alright, my phpMySQL is 2.4.0
My PHP is 4.2.2
Are you sure you're working on the same server, can you try it again!
"An important reward for a job well done is a personal sense of worthwhile achievement."


[ Themes ]

lordtron

Now it won't even tell me what the error is. It just says Error when I am on Step 4: Database Changes

Executing upgrade script 1 of 2.
Executing: "Updating and creating indexes..." (1 of 19 - of this script).

VainSoftGames.com - New Design To Gaming

Rumbaar

Try this search and see if any of those thread offer any assistance Executing: Updating and creating indexes...
"An important reward for a job well done is a personal sense of worthwhile achievement."


[ Themes ]

lordtron

Just found a million other issues, well not a million, but a ton of other issues. Someone else had my issue, but was using 1.1.5 and never got an answer for it.

VainSoftGames.com - New Design To Gaming

Rumbaar

Well look at more than one, and try to look at the 'solved' ones then..  I sure I saw at least 3 on the first page of that search.  You might have to look past the very first one you look at ...
"An important reward for a job well done is a personal sense of worthwhile achievement."


[ Themes ]

Advertisement: