• Welcome to Simple Machines Community Forum. Please login or sign up.
September 22, 2021, 08:40:06 PM

News:

SMF 2.0.18 has been released! Please update. Read more.


Trouble uploading backup

Started by robbieruckus, August 06, 2008, 12:13:25 AM

Previous topic - Next topic

robbieruckus

ok so i made a boo boo.

i allowed a member to be admin i shouldn't have.  lost half my members.  tried getting into phpmyadmin to upload a backup and couldnt remember my password. 

i changed it without changing it in my forums first so now im getting a server busy message and cant access the forums to change the password in the forum.

ive been trying to remember what the password was and change the phpmyadmin pass back to no avail.

anyway i could change the password within the forum to match the database without having access to the site.

any help would be greatly appreciated.

:'( :'( :'(

bros

You can contact your host for your cPanel password.

robbieruckus

cpanel password isnt what im looking for

i changed the password to the database

and im trying to figure how to change the password for the forum to access the password without being able to get into the forum.

Deprecated

Upload repair_settings.php to your forum base directory, change your password for your forum to access your database there. Remember to delete it when you are done.

What is repair_settings.php?

NickC

Quote from: robbieruckus on August 06, 2008, 12:32:00 AM
cpanel password isnt what im looking for

i changed the password to the database

You access your database settings from cPanel. Go to MySQL Account Maintenance, and create another user with a new password.

robbieruckus

Quote from: NickC on August 06, 2008, 04:12:06 AM
Quote from: robbieruckus on August 06, 2008, 12:32:00 AM
cpanel password isnt what im looking for

i changed the password to the database

You access your database settings from cPanel. Go to MySQL Account Maintenance, and create another user with a new password.

i know how to change the database password....  throught cPanel.

nevermind.  i will try the repair settings.

robbieruckus

ok repair settings got me back to the board.

i used restore backup to get my members back..

but now im getting this message on the index and almost every other page :

Table 'nin0805609065395.smf_boards' doesn't exist
File: /home/content/m/a/s/masstrickery/html/nintendope/forum/Sources/BoardIndex.php
Line: 84

Note: It appears that your database may require an upgrade. Your forum's files are currently at version SMF 1.1.5, while your database is at version 1.1.4. The above error might possibly go away if you execute the latest version of upgrade.php.


any ideas on how to resolve this?

also i noticed i placed this in the wrong section because im using 1.1.5

sorry feel free to move it.

robbieruckus

ok so i have somewhat resolved this, i got the main board back up.

but the actual posts are getting the same errors and the arcade?

Table 'nin0805609065395.smf_arcade_games' doesn't exist
File: /home/content/m/a/s/masstrickery/html/nintendope/forum/Sources/Display.php
Line: 815

Note: It appears that your database may require an upgrade. Your forum's files are currently at version SMF 1.1.5, while your database is at version 1.1.4. The above error might possibly go away if you execute the latest version of upgrade.php.

Rumbaar

This indicates that during the restoration process not all tables were created, which in this regards was for the arcade mod.  You've got the mod code in your forum files, but not the table in the db access.

Are you sure the backup you used to restore with was a current backup with all latest entries and data?
"An important reward for a job well done is a personal sense of worthwhile achievement."


[ Themes ]

Advertisement: