Advertisement:

Author Topic: Highslide Image Viewer  (Read 271988 times)

Offline Sabre™

  • SMF Hero
  • ******
  • Posts: 2,527
  • Gender: Male
  • IF IT AINT BROKE, I CAN FIX IT TILL IT IS!!
Re: Highslide Image Viewer
« Reply #80 on: October 14, 2008, 02:51:16 AM »
Hey thats pretty cool!!
You made that anonymizer yourself?
Congrats mate, its a nice add.

Back on topic :D
Glad you got it to work just how you wanted it mate.
Good job! :)
Do NOT give admin and/or ftp details to just anybody, see if they are trust worthy first!!  Do your homework ;)


Offline locau

  • Semi-Newbie
  • *
  • Posts: 40
Re: Highslide Image Viewer
« Reply #81 on: October 14, 2008, 07:49:33 PM »
...only thing missing compared to lightbox - is lightbox shades the background web page with a very dark filter to help the images stand out.  Enjoying the slide show :)
No problem - Highslide can do this
http://highslide.com/example-mini-gallery.html
 
[view the sourcecode of the example]  ;)
 
Or add:
Code: [Select]

     hs.dimmingDuration = "15";
    hs.dimmingOpacity = 0.75;

I have tried this but it simply doesn't work, i can't even get a solid color. And yes i checked highslide.css and i have:
Code: [Select]
.highslide-dimming {
    position: absolute;
    background: black;
}

I have flash things on my site, can this be causing the issue ?

Offline Sabre™

  • SMF Hero
  • ******
  • Posts: 2,527
  • Gender: Male
  • IF IT AINT BROKE, I CAN FIX IT TILL IT IS!!
Re: Highslide Image Viewer
« Reply #82 on: October 14, 2008, 08:28:18 PM »
Its a possibilty, I just tried it, and its working fine.
I noticed a slight delay when there are moving(gif) images, but its still working.
Do NOT give admin and/or ftp details to just anybody, see if they are trust worthy first!!  Do your homework ;)


Offline cqinzx

  • Semi-Newbie
  • *
  • Posts: 13
Re: Highslide Image Viewer
« Reply #83 on: October 14, 2008, 08:56:10 PM »
The creator of this mod is a God! I love this mod, its so useful and now my forums looks so much cleaner and not cluttered with big images.

Offline Tanks

  • Full Member
  • ***
  • Posts: 583
  • Gender: Male
  • Danish Dude
Re: Highslide Image Viewer
« Reply #84 on: October 15, 2008, 02:45:20 AM »
maybe

Code: [Select]
hs.dimmingOpacity = 0.75;

should actually be

Code: [Select]
hs.dimmingOpacity = "0.75";


Just a thought :) don't know if im right ! - but now it is working on my forum after i made that change ;)
« Last Edit: October 15, 2008, 02:55:30 AM by Tanks »

Offline Sabre™

  • SMF Hero
  • ******
  • Posts: 2,527
  • Gender: Male
  • IF IT AINT BROKE, I CAN FIX IT TILL IT IS!!
Re: Highslide Image Viewer
« Reply #85 on: October 15, 2008, 03:13:41 AM »
Heey congrats, good stuff!
Do NOT give admin and/or ftp details to just anybody, see if they are trust worthy first!!  Do your homework ;)


Offline ssabo

  • Newbie
  • *
  • Posts: 7
Re: Highslide Image Viewer
« Reply #86 on: October 15, 2008, 09:30:23 AM »
Tried to install this morning...but received following error message.

Quote
Parse error: parse error in

/home/tlcc/public/htdocs/forum/Sources/Subs.php on line 3576

Fatal error: Call to undefined function: writelog() in

/home/tlcc/public/htdocs/forum/index.php on line 171

Thought it may be because I am using a Theme called "Helios_Multi", so I switched to "default", but still no go?

Any thoughts as to where I should go to check from here?

Offline WRC

  • Semi-Newbie
  • *
  • Posts: 11
    • MundoFOTO
Re: Highslide Image Viewer
« Reply #87 on: October 15, 2008, 11:44:36 AM »
Thanks for the mod.

spanish_es

Code: [Select]
// spanish_es language strings
hs.lang = {
loadingText : "Cargando...",
loadingTitle : "Haz click para cancelar",
focusTitle : "Haz click para traer al frente",
fullExpandTitle : "Redimensionar a tamaño actual",
creditsText : "Modificación por <i>Highslide JS</i>",
creditsTitle : "Ir a la página de Highslide JS",
previousText : "Anterior",
nextText : "Siguiente",
moveText : "Mover",
closeText : "Cerrar",
closeTitle : "Cerrar (esc)",
resizeTitle : "Redimensionar",
playText : "Iniciar",
playTitle : "Iniciar presentación (espacio)",
pauseText : "Pausa",
pauseTitle : "Pausar presentación (espacio)",
previousTitle : "Anterior (flecha izda)",
nextTitle : "Siguiente (flecha dcha)",
moveTitle : "Mover",
fullExpandText : "Tamaño completo",
number: "Imagen %1 de %2",
restoreTitle : "Haz click para cerrar imagen, arrastrar y soltar para mover. Usa las flechas para anterior/siguiente."
};


 ;)

Offline jmil

  • Jr. Member
  • **
  • Posts: 252
  • Gender: Male
  • The Chief
    • Mid-Atlantic X Riders
Re: Highslide Image Viewer
« Reply #88 on: October 15, 2008, 04:29:40 PM »
Installed this on a 1.1.6
Custome Theme

The upload went fine and I did the manual edits as listed on the Mod Download page - but the Mod does not work. In the header of every page is about 25 lines of code overwriting on top of the theme - I have done many mods to the theme before but I can't seem to get this one.

Any assistance please.

I attached a copy of my "Modified" Sources/sub.php and my Default/Themes/index.template.php


Offline digger

  • Sr. Member
  • ****
  • Posts: 787
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Highslide Image Viewer
« Reply #89 on: October 15, 2008, 06:22:26 PM »
Installed this on a 1.1.6
Custome Theme

The upload went fine and I did the manual edits as listed on the Mod Download page - but the Mod does not work. In the header of every page is about 25 lines of code overwriting on top of the theme - I have done many mods to the theme before but I can't seem to get this one.

Any assistance please.

I attached a copy of my "Modified" Sources/sub.php and my Default/Themes/index.template.php
You installed mod twice.

Offline Dr'Rin

  • Newbie
  • *
  • Posts: 1
Re: Highslide Image Viewer
« Reply #90 on: October 15, 2008, 11:29:37 PM »
Hello digger : )

I've installed this mod , but it doesn't work with the custom theme :' (

The installation is completely success.

How can I solve the problem ?


P.S. I cannot read the language used in the forum you've posted before, so I want you to explain in English  ;D

Offline digger

  • Sr. Member
  • ****
  • Posts: 787
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Highslide Image Viewer
« Reply #91 on: October 16, 2008, 08:14:56 AM »
Hello digger : )

I've installed this mod , but it doesn't work with the custom theme :' (

The installation is completely success.

How can I solve the problem ?


P.S. I cannot read the language used in the forum you've posted before, so I want you to explain in English  ;D

Go to the mod page http://custom.simplemachines.org/mods/index.php?mod=1450

and look Manual Install Instructions for SMF x.x

Offline jmil

  • Jr. Member
  • **
  • Posts: 252
  • Gender: Male
  • The Chief
    • Mid-Atlantic X Riders
Re: Highslide Image Viewer
« Reply #92 on: October 16, 2008, 02:55:58 PM »
Installed this on a 1.1.6
Custome Theme

The upload went fine and I did the manual edits as listed on the Mod Download page - but the Mod does not work. In the header of every page is about 25 lines of code overwriting on top of the theme - I have done many mods to the theme before but I can't seem to get this one.

Any assistance please.

I attached a copy of my "Modified" Sources/sub.php and my Default/Themes/index.template.php
You installed mod twice.

That is correct (Lame Brain thing i did) so I have modified all checked all three files - the code is fine now but it does not work - I click on the attachment for the larger file as usual - it made no changes to the normal function.

So - What could be wrong - Should the Manual Ch ages to the "/default/Index.template.php" be done to my /Themes/custom theme/index.template.php"/??

Offline digger

  • Sr. Member
  • ****
  • Posts: 787
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Highslide Image Viewer
« Reply #93 on: October 16, 2008, 03:14:48 PM »
Installed this on a 1.1.6
Custome Theme

The upload went fine and I did the manual edits as listed on the Mod Download page - but the Mod does not work. In the header of every page is about 25 lines of code overwriting on top of the theme - I have done many mods to the theme before but I can't seem to get this one.

Any assistance please.

I attached a copy of my "Modified" Sources/sub.php and my Default/Themes/index.template.php
You installed mod twice.

That is correct (Lame Brain thing i did) so I have modified all checked all three files - the code is fine now but it does not work - I click on the attachment for the larger file as usual - it made no changes to the normal function.

So - What could be wrong - Should the Manual Ch ages to the "/default/Index.template.php" be done to my /Themes/custom theme/index.template.php"/??
You must modify index.template.php and display.template.php in your custom theme.

Offline jmil

  • Jr. Member
  • **
  • Posts: 252
  • Gender: Male
  • The Chief
    • Mid-Atlantic X Riders
Re: Highslide Image Viewer
« Reply #94 on: October 16, 2008, 03:20:09 PM »
That is what I figured - I followed the instructions on the Mods page which indicated that you modify the "DEFAULT" . Now - Should I take those changes out?? and then modify the themes/index template etc.. or can I leave the Defaults there as is?


Offline digger

  • Sr. Member
  • ****
  • Posts: 787
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Highslide Image Viewer
« Reply #95 on: October 16, 2008, 03:47:27 PM »
That is what I figured - I followed the instructions on the Mods page which indicated that you modify the "DEFAULT" . Now - Should I take those changes out?? and then modify the themes/index template etc.. or can I leave the Defaults there as is?

Instruction don't know which theme you use. It always show for default theme. But you need modify your custom theme.
If you installed mod, you don't need modify default theme.

Offline jmil

  • Jr. Member
  • **
  • Posts: 252
  • Gender: Male
  • The Chief
    • Mid-Atlantic X Riders
Re: Highslide Image Viewer
« Reply #96 on: October 16, 2008, 03:49:24 PM »
Thanks - I will let you know how it goes shortly - THANKS!!! :D

Offline jmil

  • Jr. Member
  • **
  • Posts: 252
  • Gender: Male
  • The Chief
    • Mid-Atlantic X Riders
Re: Highslide Image Viewer
« Reply #97 on: October 16, 2008, 04:23:27 PM »
YEA - It WORKS!!!! Thanks Digger - Now the Dumb Question - Can this be modified to work with the SMF Gallery??

BTW - The Mods looks very very good! Nice Work


Offline digger

  • Sr. Member
  • ****
  • Posts: 787
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Highslide Image Viewer
« Reply #98 on: October 16, 2008, 06:55:58 PM »
YEA - It WORKS!!!! Thanks Digger - Now the Dumb Question - Can this be modified to work with the SMF Gallery??

You can modify SMF Gallery to work with Highslide mod. (Tested with SMF Gallery 1.9.3)

in Gallery.template.php
find four places looks like this code (there may be some differences like alt='')
Code: [Select]
echo '<td align="center"><a href="' . $scripturl . '?action=gallery;sa=view;id=' . $row['ID_PICTURE'] . '">
<img ' . ($GD_Installed == true ?  'src="' . $modSettings['gallery_url'] . $row['thumbfilename'] . '" ' : 'src="' . $modSettings['gallery_url'] . $row['filename'] . '" height="78" width="120" ')  . ' border="0" alt="" /></a><br />';
and replace with
Code: [Select]
echo '<td align="center"><a href="' . $modSettings['gallery_url'] . $row['filename'] . '" class="highslide" rel="highslide">
<img ' . ($GD_Installed == true ?  'src="' . $modSettings['gallery_url'] . $row['thumbfilename'] . '" ' : 'src="' . $modSettings['gallery_url'] . $row['filename'] . '" height="78" width="120" ')  . ' border="0" alt="' .  '<a href=\'' . $scripturl . '?action=gallery;sa=view;id=' . $row['ID_PICTURE'] . '\'>[Detail]</a>' . '" /></a><br />';
echo '<div class="highslide-heading">' , @$context['gallery_cat_name'] , '</div>';

Demo here http://simple-machines.ru/index.php?action=gallery;cat=1
« Last Edit: October 16, 2008, 07:08:23 PM by digger »

Offline ssabo

  • Newbie
  • *
  • Posts: 7
Re: Highslide Image Viewer
« Reply #99 on: October 16, 2008, 11:05:34 PM »
I have tried installing this mod several times and still get the same error message.  Could someone please give me some sort of idea where I may have gone wrong.

First I am using the Theme “Helios_Multi”, so I manually edited the files using Highslide Image Viewer – Installation Instructions for 1.1.6

./Sources/Subs.php
./Themes/Helios_Multi/index.template.php
./Themes/Helios_Multi/Display.template.php


I then moved the included directory "Highslide" to "./Themes/Helios_Multi".

After editing the files as soon as I click on anything in the SMF Forum, I get the following error message.

Parse error: parse error in /home/tlcc/public/htdocs/forum/Sources/Subs.php on line 3576

Fatal error: Call to undefined function: writelog() in /home/tlcc/public/htdocs/forum/index.php on line 171


Any help you could give would be most appreciated, I really would like to use this mod  :D