News:

SMF 2.0.19 has been released! Please update. Read more.

Main Menu

Chinese characters beome un-readable

Started by zeroandone, September 19, 2008, 04:48:00 PM

Previous topic - Next topic

zeroandone

After upgraded from Beta 3.1 to Beta 4.0, all Chinese characters on my forum became ???. But when I log into my DB with phpMyAdmin, every Chinese character is displaying correctly. Can some one help me on this?

Thanks very much,

Jeffrey
ASP.NET developer
Drupal fan
Joomla fan
Ubuntu newbie
http://www.codingbeaver.com

H

Please post a link to your site.

Which theme are you using?

Are you using UTF8? See: UTF-8 Readme
-H
Former Support Team Lead
                              I recommend:
Namecheap (domains)
Fastmail (e-mail)
Linode (VPS)
                             

zeroandone

Theme: SunSet 2.0
I also tried to use the Default SMF Theme, but no difference.

Here is the link: www.lubbockchinesechurch.net (the forum title is correctly displayed, but the board name and contents are not)

Thanks,
ASP.NET developer
Drupal fan
Joomla fan
Ubuntu newbie
http://www.codingbeaver.com

greyknight17

Go into phpMyAdmin and click on your database. Then look at the collation column for all your tables there. Are they all listed in the correct UTF8 format?

zeroandone

All tables' collation is utf8-general-ci, except "smf_admin_info_file", "smf_approval_queue", "smf_log_group_requests", which is latin1_swedish_ci".

Very strange, where does "swedish" come from?
ASP.NET developer
Drupal fan
Joomla fan
Ubuntu newbie
http://www.codingbeaver.com

zeroandone

ASP.NET developer
Drupal fan
Joomla fan
Ubuntu newbie
http://www.codingbeaver.com

N3RVE

Can you provide one of us with Admin access to see if we can figure out the problem?
If you will not want to give out confidential information, we understand and will try to provide help via the forums.

How did you do the upgrade?
Admin CP notification or upgrade package?
Do the language files exist at ./Themes/default/languages and do they have UTF 8 at the end?
Admin CP -. Server Settings -> Forum Language: ??? what is it set to, Chinese(-UTF 8)?

-[n3rve]
Ralph "[n3rve]" Otowo
Former Marketing Co-ordinator, Simple Machines.
ralph [at] simplemachines [dot] org                       
Quote"Somewhere, something incredible is waiting to be known." - Carl Sagan

zeroandone

>>>How did you do the upgrade?
I downloaded the upgrade package for the upgrade.

Before the upgrade, I was using English as the default forumn language and I could enter Chinese and the forum could display Chinese without any problem. But after the upgrade, every Chinese character becomes ???. I tried changing the default forum language to Chinese Simplified, but no help.

>>>Do the language files exist at ./Themes/default/languages and do they have UTF 8 at the end?
No UTF-8 at the end. Only "english" and "chinese-simplified" at the end.

>>>Admin CP -. Server Settings -> Forum Language:  what is it set to, Chinese(-UTF 8)?
It is English right now, but switching to Chinese-Simplified does not make any difference.

Please let me know if you need more information.

Thanks,
ASP.NET developer
Drupal fan
Joomla fan
Ubuntu newbie
http://www.codingbeaver.com

zeroandone

Oh, one more thing. If I manually change those "???" to Chinese characters, they will display correctly.
ASP.NET developer
Drupal fan
Joomla fan
Ubuntu newbie
http://www.codingbeaver.com

N3RVE

#9
Quote from: zeroandone on September 30, 2008, 10:35:36 AM
>>>Admin CP -. Server Settings -> Forum Language:  what is it set to, Chinese(-UTF 8)?
It is English right now, but switching to Chinese-Simplified does not make any difference.

Ok, set to English, not English UTF-8 right?
  • Download the English UTF-8 and Chinese UTF-8 Language packs from the download section linked above.
  • Upload them to ./Themes/default/Languages
  • Visit the Forum Maintenance section of your Forum's Admin CP and convert HTML entities to UTF-8.

    -[n3rve]
Ralph "[n3rve]" Otowo
Former Marketing Co-ordinator, Simple Machines.
ralph [at] simplemachines [dot] org                       
Quote"Somewhere, something incredible is waiting to be known." - Carl Sagan

zeroandone

n3rve, you rock!!
The conversion to UTF-8 solved the problem, even though I didn't install those UTF-8 language packs.

Thank you soooooooo much,

Have a good one.
ASP.NET developer
Drupal fan
Joomla fan
Ubuntu newbie
http://www.codingbeaver.com

N3RVE

Quote from: zeroandone on September 30, 2008, 11:06:49 AM
The conversion to UTF-8 solved the problem, even though I didn't install those UTF-8 language packs.
That's weird, UTF-8 requires it's own language files.

Quote
Thank you soooooooo much

You're welcome, I'll mark this as solved.

-[n3rve]
Ralph "[n3rve]" Otowo
Former Marketing Co-ordinator, Simple Machines.
ralph [at] simplemachines [dot] org                       
Quote"Somewhere, something incredible is waiting to be known." - Carl Sagan

zeroandone

One thing though, when I tried to install those language packs online through AP interface (Server Settings -> Languages), I got an error saying "Package contains illegal paths - please contact Simple Machines". I posted this error in another post. Here is the link: http://www.simplemachines.org/community/index.php?topic=264838.0
ASP.NET developer
Drupal fan
Joomla fan
Ubuntu newbie
http://www.codingbeaver.com

N3RVE

#13
Thanks for reminding me, some other users had reported that issue earlier today.
I'll bring that to attention in the right section shortly.
Thank you :)

-[n3rve]
Ralph "[n3rve]" Otowo
Former Marketing Co-ordinator, Simple Machines.
ralph [at] simplemachines [dot] org                       
Quote"Somewhere, something incredible is waiting to be known." - Carl Sagan

N3RVE

Ralph "[n3rve]" Otowo
Former Marketing Co-ordinator, Simple Machines.
ralph [at] simplemachines [dot] org                       
Quote"Somewhere, something incredible is waiting to be known." - Carl Sagan

faifai

i did all these steps but still showing ?? for chinese input.

Any help please?

N3RVE

Ralph "[n3rve]" Otowo
Former Marketing Co-ordinator, Simple Machines.
ralph [at] simplemachines [dot] org                       
Quote"Somewhere, something incredible is waiting to be known." - Carl Sagan

faifai

Quote from: [n3rve] on October 23, 2008, 05:49:54 AM
How do I ask support questions the smart way?

-[n3rve]

I followed these steps but the chinese traditional character is still unreadable at category, discussion content.

1. upgrade language files at  ./Themes/default/languages which UTF 8 at the end.

2 . Completed this: Admin CP -. Server Settings -> Forum Language:  what is it set to, Chinese(-UTF 8)?

Can u help me? Many thanks.

zeroandone

Quote from: faifai on October 27, 2008, 12:42:16 AM
Quote from: [n3rve] on October 23, 2008, 05:49:54 AM
How do I ask support questions the smart way?

-[n3rve]

I followed these steps but the chinese traditional character is still unreadable at category, discussion content.

1. upgrade language files at  ./Themes/default/languages which UTF 8 at the end.

2 . Completed this: Admin CP -. Server Settings -> Forum Language:  what is it set to, Chinese(-UTF 8)?

Can u help me? Many thanks.

Have you tried this step mentioned in n3rve's second post?
Visit the Forum Maintenance section of your Forum's Admin CP and convert HTML entities to UTF-8.

ASP.NET developer
Drupal fan
Joomla fan
Ubuntu newbie
http://www.codingbeaver.com

N3RVE

Thank you, Zeroandone ;)
faifai, do you still require assistance?
Please, start a new topic for your issue next time as we tend not to look at topics that have the 'solved icon'.

-[n3rve]
Ralph "[n3rve]" Otowo
Former Marketing Co-ordinator, Simple Machines.
ralph [at] simplemachines [dot] org                       
Quote"Somewhere, something incredible is waiting to be known." - Carl Sagan

Advertisement: