Advertisement:

Author Topic: TinyPortal  (Read 753802 times)

Offline FragaCampos

  • Sophist Member
  • *****
  • Posts: 1,302
  • Gender: Male
    • docsPT
Re: TinyPortal
« Reply #940 on: November 29, 2010, 10:51:32 AM »
Hello.
I'm still using TinyPortal v1.0 beta 4 with SMF 1.1.12 and i'm having two errors that are filling my log:
Code: [Select]
2: in_array() [<a href='function.in-array'>function.in-array</a>]: Wrong datatype for second argument
File: public_html/Themes/default/languages/TPShout.portuguese.php (main sub template - eval?)
Line: 414

and

Code: [Select]
2: Invalid argument supplied for foreach()
File: public_html/Themes/default/languages/TPShout.portuguese.php (main sub template - eval?)
Line: 15

Any idea about what might be causing this?

Offline IchBin™

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,115
  • Gender: Male
  • I don't speak German.
Re: TinyPortal
« Reply #941 on: November 29, 2010, 07:56:44 PM »
Can you use this mod to enable/disable eval() to see if you get a more specific error?
http://custom.simplemachines.org/mods/index.php?mod=2054
IchBin™        TinyPortal
Coding Guidelines       

Offline FragaCampos

  • Sophist Member
  • *****
  • Posts: 1,302
  • Gender: Male
    • docsPT
Re: TinyPortal
« Reply #942 on: November 30, 2010, 07:15:17 PM »
Hi IchBin™ and thanks a lot for answering.
I did what you told and it seems the problem stems from a hack i did sometime ago.
It doens't have nothing to do with TinyPortal, but you can find it here.

Cheers.

Offline IchBin™

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,115
  • Gender: Male
  • I don't speak German.
Re: TinyPortal
« Reply #943 on: November 30, 2010, 07:45:29 PM »
Cool. Thanks for letting me know the problem.
IchBin™        TinyPortal
Coding Guidelines       

Offline anto74

  • Semi-Newbie
  • *
  • Posts: 91
Re: TinyPortal
« Reply #944 on: December 01, 2010, 05:52:07 AM »
I'm sorry for this stupid question and for my poor english: now i have TP 5beta-1, for upgrade to TP RC1 i must only install the RC1 package? I don't uninstall TP 1beta5-1?
In installaton test i have only two file modified...it's possible?

Thanks
Antonio

Offline DarioBros

  • Newbie
  • *
  • Posts: 6
Re: TinyPortal
« Reply #945 on: December 01, 2010, 01:42:46 PM »
There's a small bug in the search function ( yoursite.com/index.php?action=search ) with smf 1.1.11 (now 1.1.12) and TPRC1:
Even if "Downloads Manager" is disabled, in that page there is a link to search inside downloads.

I've modified TPsubs.template.php to hide it, searching
Code: [Select]
<span class="topslice"><span></span></span>
<p style="margin: 0; padding: 0 1em;">
<a href="' . $scripturl. '?action=tpmod;sa=searcharticle">' . $txt['tp-searcharticles2'] . '</a> |
<a href="' . $scripturl. '?action=tpmod;dl=search">' . $txt['tp-searchdownloads'] . '</a>';

and replacing with:
Code: [Select]
<span class="topslice"><span></span></span>
<p style="margin: 0; padding: 0 1em;">';
if (allowedTo('tp_dlmanager'))
echo '
<a href="' . $scripturl. '?action=tpmod;sa=searcharticle">' . $txt['tp-searcharticles2'] . '</a> |';
                        if (allowedTo('tp_articles'))
echo ' <a href="' . $scripturl. '?action=tpmod;dl=search">' . $txt['tp-searchdownloads'] . '</a>';
     

Is this the right way to fix it?

Offline IchBin™

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,115
  • Gender: Male
  • I don't speak German.
Re: TinyPortal
« Reply #946 on: December 01, 2010, 03:02:50 PM »
Well, there's no permission for just using search. The permission you use in your code there is for a user who has TP download manager permissions. It would probably be better to just check if the downloads manager is turned on or not.

if($context['TPortal']['show_download']==0)
IchBin™        TinyPortal
Coding Guidelines       

Offline latch

  • Newbie
  • *
  • Posts: 6
Re: TinyPortal
« Reply #947 on: December 01, 2010, 05:37:04 PM »
Hi, attempt to apply TinyPortal is failing.

List of all installs:
SMF v1.1.12
SMF Gallery Lite v3.0.2
Default Avatar v1.3
- End List

Version of TinyPortal attempting to apply: v1.101

Errors encountered:
9.    Execute Modification    ./Themes/default/index.template.php    Test failed
10.    Execute Modification    ./Themes/babylon/index.template.php    File not found

I was initially using the Full Down theme when trying to install Tiny Portal which caused errors 9 and 10 so switched to Default theme.
Errors 9 and 10 persist.
Is there a way to overcome these two errors so I can apply this Mod?
-Latch

Offline IchBin™

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,115
  • Gender: Male
  • I don't speak German.
Re: TinyPortal
« Reply #948 on: December 01, 2010, 06:47:38 PM »
TinyPortal is searching for code in those files that has either been modified by a previous mod, or modified by you. If I were you, I would do this:

1. Backup files and database
2. Install the mod and proceed even with those 2 errors reported.
3. Click the parse link on the mod page, and follow the manual instructions for modifying those files.
IchBin™        TinyPortal
Coding Guidelines       

Offline FragaCampos

  • Sophist Member
  • *****
  • Posts: 1,302
  • Gender: Male
    • docsPT
Re: TinyPortal
« Reply #949 on: December 03, 2010, 12:41:36 PM »
Hello again.
Now that i've cleaned the error log, i'm left with two very old errors that i've never been able to solve.
Here they are:
Code: [Select]
2: Invalid argument supplied for foreach()
File: /home/docspt/public_html/Themes/default/TPortal.template.php
Line: 15

and

Code: [Select]
8: Undefined index: boardnews
File: public_html/Themes/default/TPortal.template.php
Line: 15

It's nothing serious nor urgent, since the forum has no problems, but i would like to get rid of these.
Thanks once more.

Offline IchBin™

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,115
  • Gender: Male
  • I don't speak German.
Re: TinyPortal
« Reply #950 on: December 03, 2010, 05:56:31 PM »
Can you do what I posted in this message and let me know what the errors say after that?
http://www.simplemachines.org/community/index.php?topic=27642.msg2866238#msg2866238
IchBin™        TinyPortal
Coding Guidelines       

Offline FragaCampos

  • Sophist Member
  • *****
  • Posts: 1,302
  • Gender: Male
    • docsPT
Re: TinyPortal
« Reply #951 on: December 04, 2010, 10:21:24 AM »
I still have that mod installed and the messages don't change  :-\

Don't know if this helps, but these errors are only made by guests and always in pairs, when one happens, the other also happens.

Offline IchBin™

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,115
  • Gender: Male
  • I don't speak German.
Re: TinyPortal
« Reply #952 on: December 04, 2010, 11:31:54 AM »
Is it the link in your signature? You are 2 versions of TP behind. There has been a beta4 and an RC1 version of TP since then. A lot of bugs were fixed by Bloc since then. I'd update and see if the same errors exist.
IchBin™        TinyPortal
Coding Guidelines       

Offline FragaCampos

  • Sophist Member
  • *****
  • Posts: 1,302
  • Gender: Male
    • docsPT
Re: TinyPortal
« Reply #953 on: December 04, 2010, 02:37:56 PM »
Yes it is. But no problem, it's nothing serious. I'll update to RC1 when i update my SMF to 2.0. That way i can make all the needed changes at the same time.

Thanks anyway.

Offline IchBin™

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,115
  • Gender: Male
  • I don't speak German.
Re: TinyPortal
« Reply #954 on: December 06, 2010, 04:52:57 PM »
Updated for SMF 2 RC4. Post if there's any problems.
IchBin™        TinyPortal
Coding Guidelines       

Offline Sabre™

  • SMF Hero
  • ******
  • Posts: 2,527
  • Gender: Male
  • IF IT AINT BROKE, I CAN FIX IT TILL IT IS!!
Re: TinyPortal
« Reply #955 on: December 07, 2010, 02:19:33 AM »
Good work IchBin 8)

Found a very small error. Nothing serious, but thought I'd bring it to light.
You're not in the TP credits
Code: [Select]
Developer
Bjoern "Bloc" Kristiansen

TP Team
JPDeni, Ianedres, Freddy888, Ken, Lesmond, ZTN, ZarPrime, Renegd98, Crip, Agridoc and lurkalot.

TP Friends
Xarcell, Fussilet,nokonium, StormLrd, RebelRose, Ray, Max, Thurnok, Dragooon, eld^kar, PhilH, Maya, Moocat, Rasyr, gerrymo, BorgBOB, redone, Aku, Anunlike, Tuxie, deniz, feline, and eeek.
« Last Edit: December 07, 2010, 02:27:32 AM by Sabre™ »
Do NOT give admin and/or ftp details to just anybody, see if they are trust worthy first!!  Do your homework ;)


Offline IchBin™

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,115
  • Gender: Male
  • I don't speak German.
Re: TinyPortal
« Reply #956 on: December 07, 2010, 10:03:53 AM »
Strange... wonder how my name got removed. I haven't even touched the credits. Oh well, I'll fix it up for the next release. Thanks for the heads up!
IchBin™        TinyPortal
Coding Guidelines       

Offline crustybum

  • Jr. Member
  • **
  • Posts: 368
Re: TinyPortal
« Reply #957 on: December 07, 2010, 10:21:46 AM »
Hi, i am having problems getting an RSS feed in one of the blocks...can anyone guide me through..?  i am on 1.1.12

Thanks

Offline IchBin™

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,115
  • Gender: Male
  • I don't speak German.
Re: TinyPortal
« Reply #958 on: December 07, 2010, 10:41:44 AM »
Have you tried other feeds? Some times feeds have errors in them and will not display. You can try a feed from the TP chat board on the support site to see if it works. This link worked for me.

http://www.tinyportal.co.uk/index.php?action=.xml;board=9;type=rss
IchBin™        TinyPortal
Coding Guidelines       

Offline crustybum

  • Jr. Member
  • **
  • Posts: 368
Re: TinyPortal
« Reply #959 on: December 07, 2010, 11:09:53 AM »
No good....just getting nothing...stumped