• Welcome to Simple Machines Community Forum. Please login or sign up.
December 06, 2021, 03:25:42 AM

News:

Want to get involved in developing SMF, then why not lend a hand on our github!


Affiliates System

Started by Diego Andrés, December 04, 2008, 07:29:28 AM

Previous topic - Next topic

Kindred

are you using English or English-utf-8?
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.<br /><br />"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

johnpaul2k2

Quote from: Kindred on December 06, 2012, 07:38:26 AM
are you using English or English-utf-8?

top of my Affiliates.english.php



secondly , i added the utf-8 html code on my theme



I just finished trying English-utf-8 yet no way

Kindred

ummmm.... no. Look in your SMF settings.  What language is your forum set to?  English is a DIFFERENT language from English-UTF-8 as far as SMF is concerned

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.<br /><br />"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

johnpaul2k2

while checking my site with some different online website analytic , they were all saying my site doesn't have "language code' so i have to add "en" html code. the same with "UTF-8" ( complaining of character encoding)

my question now is .should i remove them?? or any of them?

Kindred

John,

you are not reading what I type.   I don't care what the analytics say. I don't care what the web page displays as. I don't care what the file saves as.

WHAT IS YOUR LANGUAGE SET TO IN SMF'S ADMIN SETTINGS?
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.<br /><br />"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

johnpaul2k2

1.this is my first time of visit this side  :D








2 i went to "add language" , searched for "English" and i saw the following. should i removed the "utf-8" tag and install the one from SMF



Hope i am not running faster than my shadow

Kindred

argh....

* Kindred slaps head

sorry... my mistake. Looking at the actual code would actually help me once in a while...

$txt['saAffiliates']

in Modifications.english.php
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.<br /><br />"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

johnpaul2k2

don't slap anymore .......never an easy task to solve hundreds of people's problem

it is working now :D

Alexa Lynne

I'm using the SA Affiliates mod, but i'm running into a problem. I have "Enable Affiliates on Boardindex" checked, but it's not showing up. I've tried uninstalling, and reinstalling the mod. Can anyone help me fix this?  This is the only problem i'm having.

Kindred

are you running smf 1.1.x or did you add a theme to 2.0.x after installing the mod? (or did you misss the "apply this mod to additional themes checkboxes?)

If yes to any of that... you will have to manually apply the mod to your custom themes if you have them
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.<br /><br />"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Alexa Lynne

Quote from: Kindred on December 07, 2012, 01:54:03 PM
are you running smf 1.1.x or did you add a theme to 2.0.x after installing the mod? (or did you misss the "apply this mod to additional themes checkboxes?)

If yes to any of that... you will have to manually apply the mod to your custom themes if you have them

I changed themes. . . So, now i have uninstalled the mod. Trouble is now, it won't re-install back. The page keeps timing out, so i'm not sure if it's the ISP or what. It doesn't matter right now. I can do it when i get off work in 4 hours. I'm just bored to death and need something to do. . lol

hcfwesker

Seems like it's working, you get it figured out?

Alexa Lynne

Quote from: hcfwesker on December 10, 2012, 10:40:19 AM
Seems like it's working, you get it figured out?


Yeah, it's workin now. . Not sure for how long. . lol

Sulfur

hi,

I have a problem with this mod, I have 2 SMF foruns and in 1 of then the mod works really nice without problem, but in the 2, when someone clicks on a banner the link of my forum stays first...

Exemple:

My forum: www.atuamaede4.com

My affiliate: www.electroground.org

when anyone click on the banner the link goes http://atuamaede4.com/www.electroground.org

I have no ideia whats wrong cuz its working fine in one of then

Kindred

you did not enter the full URL for the affiliate
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.<br /><br />"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

hcfwesker

Quote from: Sulfur on December 10, 2012, 11:29:10 AMwhen anyone click on the banner the link goes http://atuamaede4.com/www.electroground.org

Take a second look at that URL, you'll see the problem right there.  You added both yours and the affiliates link in the same box when adding their URL.

Kindred

actually, I think he added the affiliate's url without the http - so the system is trying to interpret it as an internal/relative link.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.<br /><br />"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Sulfur

it resolve by itself... just added again, the same way and it worked... wierd but, yeah, it works now :)

johnpaul2k2

Quote from: SA™ on December 03, 2012, 02:12:35 PM


in Sources/AffiliatesHooks.php

just change the par in red

aff_array_insert($menu_buttons, 'search',

where do you want the menu button to show?

i am consodering updating and recoding this mod if anyone is interested?

Sorry for repeating this , incase you have forgotten

this is what i did with   the mod on my forum here

if you will work on this mod, please consider the followings

1. let it have GRID view(s)
2. if possible, make it HTML code enabled for Live Adverts and Widgets
3. Categories like health, business and co
4. Add prices and payment module in front of every products

because i cannot afford SMFhack Smf Store mod

thanks


Kindred

johnpaul2k2,

this is an affiliates mod, not an advert mod.
affiliates don't pay - they match banner for banner.

neither is this a "links" mod, so, why categories?
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.<br /><br />"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Advertisement: