• Welcome to Simple Machines Community Forum. Please login or sign up.

Cannot install mods, getting error messages

Started by Clickout, August 07, 2009, 03:30:12 AM

Previous topic - Next topic

Clickout

When I tried to install new mod, error messages are popping up. One message I got is

"You cannot download or install new packages because the Packages directory or one of the files in it are not writable!"

But I've made the files CHMOD 777, still I got the above message.

Sometimes I got a PHP error showing that the script took more than 10 sec to execute the file.

What should I do? Is it a normal error or a serious one? Please help.

JBlaze

You can try making a directory inside of your /Packages directory called /temp and CHMOD it to 777 or 755 as some hosts dont like 777.
Jason Clemons
Former Team Member 2009 - 2012

Clickout

August 07, 2009, 04:33:26 AM #2 Last Edit: August 07, 2009, 04:47:14 AM by jithin123
still i'm getting the error message:

"You cannot download or install new packages because the Packages directory or one of the files in it are not writable!"

my software version is SMF 2.0 RC1-1

JBlaze

You may have to contact your host then and see what file permissions they allow.
Jason Clemons
Former Team Member 2009 - 2012

N3RVE

You need to chmod both the ./Packages and ./Packages/"temp" directories accordingly.

-[n3rve]
Ralph "[n3rve]" Otowo
Former Marketing Co-ordinator, Simple Machines.
ralph [at] simplemachines [dot] org                       
Quote"Somewhere, something incredible is waiting to be known." - Carl Sagan

Clickout

I'm getting this error message:

Fatal error: Maximum execution time of 10 seconds exceeded in /home/********/public_html/Sources/Class-Package.php on line 806

What should i do? is this a problem with my server?  ::)

Arantor

Installing a mod is a complex process, but shouldn't be taking 10 seconds unless it's a big mod.

Do you have control of the configuration of PHP on the server?
No good deed goes unpunished
All helpful urges should be circumvented

Clickout

i'm afraid i dont' have permission to configure PHP on the server.

i was trying to install the admod, prettyurl mod and the sitemap mod. but none of them works. all shoing the same error messages.

Arantor

You need to talk to your host about extending the PHP execution time back to the default of 30 seconds.
No good deed goes unpunished
All helpful urges should be circumvented

Clickout

Is it the problem with the execution time only?

Clickout

Everything now works fine, i think the problem caused due to some temporary server issues. :D :D :D

thank you very much for helping me :)

Arantor

Good to hear it's working now. I've marked this topic solved but if you need any more help please do come back.
No good deed goes unpunished
All helpful urges should be circumvented

Advertisement: