• Welcome to Simple Machines Community Forum. Please login or sign up.
December 08, 2021, 12:17:00 PM

News:

SMF 2.0.18 has been released! Please update. Read more.


RSS Feeder

Started by SlammedDime, January 11, 2009, 06:06:42 AM

Previous topic - Next topic

Kindred

Thing is -- those are generally UTF-8 characters which have not been translated correctly
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.<br /><br />"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

420Connect.co.uk

Would you happen to know if it's possible to "tell it to" translate them as it should be? and would this be file edits/regex to achieve this?
www.420Connect.co.uk ~ A Social Network For The #CannabisCommunity ~ Come say "High" ;)

Low

Can this work for 2.0.10?

420Connect.co.uk

I have this set up and running at the moment on a 2.0.10 Installation..

I found it kept switching off by itself every so often though, so find a 'sweet spot' for how often to grab feeds! :)
www.420Connect.co.uk ~ A Social Network For The #CannabisCommunity ~ Come say "High" ;)

lomaalta

I am looking at the code within ScheduledTasks.php in an effort better format the incoming feeds.

right around here....


// Format the post
$message =
($item->get_permalink() !== null ? '[url=' . $item->get_permalink() . ']' . $title . '[/url]' : $title) . '
' . ($item->get_date() !== null ? '[b]' . $item->get_date() . '[/b]
' : '') . '
' . $body . '

' . (!empty($source) ? '[b]' . $txt['rss_feed_source'] . ':[/b] ' . $source . '



...  and am wondering if I can throw a few double quotes in that code, so I can say <span class="permalink"> instead of only using bbc code.

Thanks in advance.

Siirist

Hi,

Just a quick question.

I have a board for each RSS feed.
If I check the box for "Post Items In Single Topic" that means that the MOD will NOT create a New Topic for each feed that comes from that site?

Thanks,
Siirist
Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

420Connect.co.uk

www.420Connect.co.uk ~ A Social Network For The #CannabisCommunity ~ Come say "High" ;)

Siirist

Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

lomaalta

Been running this for awhile and been very very happy.  Well, I recently changed host, that may have a later version of php? And now when posting, I am getting a lot of funky characters in the posts. Suspecting php, or character issue in the db, or the stripping function in Subs-rss.php.  Any ideas would be greatly appreciated.  Thanks.


420Connect.co.uk

Quote from: lomaalta on March 26, 2016, 09:01:11 AM
Been running this for awhile and been very very happy.  Well, I recently changed host, that may have a later version of php? And now when posting, I am getting a lot of funky characters in the posts. Suspecting php, or character issue in the db, or the stripping function in Subs-rss.php.  Any ideas would be greatly appreciated.  Thanks.

I also had this issue.. My workaround is using the smf censored words tool to replace the strange characters to their true punctuation mark or space etc. But if any can help in a coding sort of way that would be cool! 
www.420Connect.co.uk ~ A Social Network For The #CannabisCommunity ~ Come say "High" ;)

cuongvttt

Hi guys,

I'm using SMF 2.0.14, and now i want to use this mod RSS Feeder but now it seems it's only compatible with: 2.0 RC4
Can you guys tell me is there a mod that has the same features of this mod.

Thank you guys so much.

Gryzor

Hello!

I know this hasn't been updated in ages, but it was working just fine with my 2.0.15 installation.

However, over the past few days, it decided to start fetching items multiple times (the feeds are correct, btw) and ignoring posts in other feeds! Any help?

Thanks - and, oh! have a great 2018 everyone!

T

Advertisement: