• Welcome to Simple Machines Community Forum. Please login or sign up.
December 07, 2021, 07:48:27 AM

News:

SMF 2.0.18 has been released! Please update. Read more.


SMF and Mambo integration

Started by acbs, April 23, 2009, 06:12:18 PM

Previous topic - Next topic

acbs

I'm trying to get SMF and Mambo to share logins.

Mambo www.aylard.ca/acbs [nofollow]
SMF www.aylard.ca/acbs/smf [nofollow]

Versions:
Mambo 4.6.5
SMF 1.1.8
Joomla-SMF Forum option com_smf  2.0.2

user = acbs
passwd = acbsbw

php settings:
php 4.4.7
magic_quotes_sybase Off
session.save_path /tmp
file_uploads On
upload_tmp_dir no value

acbs

Anyone,?   I'd really like to get this integration working, but I'm lost and can't see why the users can't connect.

Orstio

The Joomla-SMF Forum component from Joomlahacks is not compatible with Mambo 4.6.x.

There is a Mambo bridge here in the downloads section of the SMF site....

acbs

Thanks Orstio:

I have installed the bridge from the SMF site and configured it.
I created a menu item using the compenent SMF Bridge.

When I sign on in Mambo and then click the forum menu item, I get the SMF forum but I'm not logged in with the Mambo user account.  It's still Guest in SMF.

What am I doing wrong?

acbs

I've got it working.

Seems to work great.  Thanks for working with me.

bubuaz

Could you post what you did to resolve your issue?  I am having the same problem, my SMF loads up when I use the menu item I added to my main menu but the user is not logged into SMF in fact the users aren't showing up if i log into SMF as the admin, none of my mambo users are there.  In the SMF bridge configuration I have the registration option set to Bridge Registration.

here are my mambo specs:
PHP built On:       Windows NT WINDOWS032307 5.2 build 3790
Database Version:    4.1.20-community-nt
PHP Version:    4.3.11
Web Server:    Microsoft-IIS/6.0
WebServer to PHP interface:    cgi-fcgi
Mambo Version:    Mambo 4.6.0 Release Candidate 2 [ Kare ] 3-July-2006 03:00 GMT

I'm using SMF 1.0.7, should I upgrade it?

Orstio

There is no currrent bridge for SMF 1.0.x.  You should have upgraded years ago.

Advertisement: