News:

SMF 2.0.19 has been released! Please update. Read more.

Main Menu

Mod Stop Spammer

Started by snoopy_virtual, February 08, 2009, 09:04:45 AM

Previous topic - Next topic

snoopy_virtual

Debido a la cantidad de ataques de spammers que se están produciendo últimamente y a que soy administrador de bastantes foros ahora mismo, la verdad es que este tema me interesa bastante, pues este mod me está ayudando muchísimo en mi trabajo.

Os lo recomiendo encarecidamente a todos.

Enlace al mod

Cuando M-DVD creó el mod, abrió un post de ayuda en inglés:

http://www.simplemachines.org/community/index.php?topic=283309

Pero como ya ha habido un par de colegas míos que también están interesados en el tema y no hablan inglés, he pensado en abrir este post para que también puedan aportar ideas para mejorarlo las personas que solo hablen nuestra lengua.

Evidentemente yo no soy el que ha creado el mod, pero como ya os digo que me ha interesado mucho el tema, lo he analizado muy a fondo y me lo sé como si fuera mío, por lo que creo que os podré ayudar si tenéis cualquier problema.

Además el creador del mod (M-DVD) también habla español perfectamente y ya le he dicho que se pase por aquí.

Un saludo.

El verdadero sabio es aquel que lo ve todo, lo estudia todo, lo analiza todo y molesta poco.
A true wise man is he who sees everything, studies everything, analyses everything and hardly ever annoys.

saira

Buena iniciativa, pero tengo un problema, revisando los archivos a modificar, yo no tengo alguno de los que ahí aparecen, mi versión es la 1.0.10 y no se si me servirá.
Un saludo.

M-DVD

1.- Este MOD aunque hace muchos cambios y es complejo, con mucha seguridad no requiere instalación manual, aunque se tenga otro theme o se tengan muchos MODs instalados.

2.- Los spammers son uno más de tus problemas. Actualiza tu foro. Luego ya no tendrás problemas con los MODs ni con nada más.

3.- No he probado el MOD en esa versión. Por lo menos en las 1.1.X debe andar bien.

snoopy_virtual

Yo la he probado en el SMF 1.1.8 y funciona de maravilla, quitando solo el pequeño detalle que ya le he comentado a M-DVD de que en su versión 2.0 del mod tiene que declarar como global la variable $db_prefix en la función checkreportMembers para que funcione bien el botón de "Revisar Usuarios".

Pero aparte de ese pequeño detalle (que supongo que M-DVD corregirá en cuanto reciba el mensaje que le he mandado) todo lo demás funciona perfectamente.

En SMF 1.0.10 no lo he probado yo tampoco, pero si quieres hacerlo tú cuentanos que tal funciona ahí para que lo sepamos todos.

El verdadero sabio es aquel que lo ve todo, lo estudia todo, lo analiza todo y molesta poco.
A true wise man is he who sees everything, studies everything, analyses everything and hardly ever annoys.

toldeman

Hola.
He instalado el mod en 1.1.8 y se instalo con éxito.
Pero en el panel de la admin, no veo donde usar su funcionalidad.

Gracias

snoopy_virtual

Administración > Usuarios > Registro de usuarios > Configuración




M-DVD hizo ayer una FAQ maravillosa en inglés, pero se ve que no ha terminado todavía de traducirla a español.

Con paciencia y saliva...

El verdadero sabio es aquel que lo ve todo, lo estudia todo, lo analiza todo y molesta poco.
A true wise man is he who sees everything, studies everything, analyses everything and hardly ever annoys.

M-DVD

En este tema hay una FAQ, aún le debo añadir un pequeño detalle y dudo que pueda reescribirla en castellano dentro de poco.

Está en mi primitivo inglés :P y junto con las imágenes, creo que se puede entender la mayoría. Y si tienes duda de algo en particular lo preguntas.

toldeman

Quote from: snoopy_virtual on February 09, 2009, 09:52:21 AM
Administración > Usuarios > Registro de usuarios > Configuración




M-DVD hizo ayer una FAQ maravillosa en inglés, pero se ve que no ha terminado todavía de traducirla a español.

Con paciencia y saliva...

Hola.
Gracias por reponder, perdonar mi ignoracia pero unicamente veo la imagen que os adjunto:

Gracias..

tonho

Quote from: snoopy_virtual on February 08, 2009, 07:22:46 PM
Yo la he probado en el SMF 1.1.8 y funciona de maravilla, quitando solo el pequeño detalle que ya le he comentado a M-DVD de que en su versión 2.0 del mod tiene que declarar como global la variable $db_prefix en la función checkreportMembers para que funcione bien el botón de "Revisar Usuarios".

Por esto es por lo q se me queda el navegador en blanco después de darle a "Revisar usuarios" ¿¿??

salu2
Powered by SMF 2.0 RC1.2

snoopy_virtual

Quote from: tonho on February 09, 2009, 01:05:11 PM
Quote from: snoopy_virtual on February 08, 2009, 07:22:46 PM
Yo la he probado en el SMF 1.1.8 y funciona de maravilla, quitando solo el pequeño detalle que ya le he comentado a M-DVD de que en su versión 2.0 del mod tiene que declarar como global la variable $db_prefix en la función checkreportMembers para que funcione bien el botón de "Revisar Usuarios".

Por esto es por lo q se me queda el navegador en blanco después de darle a "Revisar usuarios" ¿¿??

salu2

Ese pequeño error está arreglado en la versión 2.1

Si has instalado otra desinstalala y ponle la última versión.

El verdadero sabio es aquel que lo ve todo, lo estudia todo, lo analiza todo y molesta poco.
A true wise man is he who sees everything, studies everything, analyses everything and hardly ever annoys.

snoopy_virtual

Quote from: toldeman on February 09, 2009, 11:12:47 AM

Gracias por reponder, perdonar mi ignoracia pero unicamente veo la imagen que os adjunto:


Por lo que veo en esa imagen no has instalado nada o no lo has instalado bien.

Prueba a desinstalarlo y volverlo a instalar (asegurate de que sea la última versión 2.1) y en caso de que te salga algún error durante la instalación, toma nota de cual es para decírnoslo.

El verdadero sabio es aquel que lo ve todo, lo estudia todo, lo analiza todo y molesta poco.
A true wise man is he who sees everything, studies everything, analyses everything and hardly ever annoys.

M-DVD

#11
Quote from: tonho on February 09, 2009, 01:05:11 PM
Por esto es por lo q se me queda el navegador en blanco después de darle a "Revisar usuarios" ¿¿??

salu2

Si tienes la versión v2.0 del MOD, debes poner la v2.1 porque se me pasó ese detalle que menciona snoopy_virtual.

Pero me parece que eso que mencionas es porque la web SFS ha tenido unas horas que ha estado caída en estos dos días. De hecho, justo luego de laznar esta nueva versión, ocurrió eso  :-\ (es casualidad, no tienen relación, supongo).

toldeman

#12
Quote from: snoopy_virtualPrueba a desinstalarlo y volverlo a instalar (asegurate de que sea la última versión 2.1) y en caso de que te salga algún error durante la instalación, toma nota de cual es para decírnoslo.

Exacto era eso, no había instalado la versión correcta.

Gracias ahora podre mirar las Faq para poder saber mas sobre este mod.

salu2..

EDITO: Me parece que me falta una pestaña en la administracion de usuarios, por lo menos fue lo que vi en las FAQ http://www.simplemachines.org/community/index.php?action=dlattach;topic=283309.0;attach=85509;image
Adjunto captura de mi panel

snoopy_virtual

Quote from: toldeman on February 10, 2009, 12:41:24 AM

EDITO: Me parece que me falta una pestaña en la administracion de usuarios, por lo menos fue lo que vi en las FAQ http://www.simplemachines.org/community/index.php?action=dlattach;topic=283309.0;attach=85509;image
Adjunto captura de mi panel


Esperate a que el programa te encuentre un par de spammers.

Mientras no tengas ningún usuario esperando aprobación no verás esa pestaña.

De hecho, ahí puedes llegar a tener hasta 4 pestañas.

Además de las 2 normales de Ver todos los usuariosBuscar por usuarios puedes tener una de Esperando aprobación (si hay algún usuario que no esté aprobado todavía) y otra de Esperando activación (si hay alguno así)

La de "Esperando activación" solo sale cuando tienes el foro de forma que a los usuarios nuevos que se registran, el programa les manda por email un código de activación que tienen que meter para poder usar su cuenta (Esto es para comprobar que la dirección de email es válida y que no se la han inventado)

La de "Esperando aprobación" sale normalmente cuando tienes el foro de forma que los usuarios nuevos que se registran no pueden usar sus cuentas hasta que un administrador no los haya comprobado y aprobado su cuenta a mano.

Por eso en este mod M-DVD decidió hacer que cada vez que el programa detecte un spammer, automáticamente lo ponga en ese estado.

De esa forma los spammers no pueden usar sus cuentas (a no ser claro que el admin se equivoque y les apruebe a mano)  >:(

Ya verás en cuanto detectes un par de ellos como te aparecen en esa zona.

El verdadero sabio es aquel que lo ve todo, lo estudia todo, lo analiza todo y molesta poco.
A true wise man is he who sees everything, studies everything, analyses everything and hardly ever annoys.

toldeman

Hola.
Gracias por la aclaración. Comentar que yo el registro de usuarios lo tengo de forma inmediata.
Mi pregunta es: tendría que cambiar la forma de registro de los usuarios par el control de los spanner?.

Gracias y un saludo

M-DVD

Quote from: toldeman on February 10, 2009, 02:44:52 PM
Hola.
Gracias por la aclaración. Comentar que yo el registro de usuarios lo tengo de forma inmediata.
Mi pregunta es: tendría que cambiar la forma de registro de los usuarios par el control de los spanner?.

Gracias y un saludo

No, para nada.

Justo este es uno de los objetivos de este MOD. Tener el registro inmediato activado y no causar molestia a los usuarios (y uno mismo).

El MOD se encarga de aplicar esto automáticamente solo a los Spammers o sospechosos. :)

toldeman

Gracias M-DVD por tu aclaración y sobre todo por la creación de este mod.
Un ultimo apunte, como debo de hacer o como tengo que configurar la instalación del mod para que averigue si la cuenta de correo escrita en el registro del usuario es correcta o no?.

Gracias.

M-DVD

El foro ya revisa (dentro de lo que cabe) si el mail es válido o no.

La única forma "real" de comprobar si el mail es válido, es enviando un mail de activación. Si te rebota es porque no existía esa dirección email.

tonho

Quote from: snoopy_virtual on February 09, 2009, 08:17:16 PM
Quote from: tonho on February 09, 2009, 01:05:11 PM
Quote from: snoopy_virtual on February 08, 2009, 07:22:46 PM
Yo la he probado en el SMF 1.1.8 y funciona de maravilla, quitando solo el pequeño detalle que ya le he comentado a M-DVD de que en su versión 2.0 del mod tiene que declarar como global la variable $db_prefix en la función checkreportMembers para que funcione bien el botón de "Revisar Usuarios".

Por esto es por lo q se me queda el navegador en blanco después de darle a "Revisar usuarios" ¿¿??

salu2

Ese pequeño error está arreglado en la versión 2.1

Si has instalado otra desinstalala y ponle la última versión.

Tengo la 2.1 :)

salu2
Powered by SMF 2.0 RC1.2

snoopy_virtual

Quote from: tonho on February 11, 2009, 06:11:01 AM
Quote from: snoopy_virtual on February 09, 2009, 08:17:16 PM
Quote from: tonho on February 09, 2009, 01:05:11 PM
Quote from: snoopy_virtual on February 08, 2009, 07:22:46 PM
Yo la he probado en el SMF 1.1.8 y funciona de maravilla, quitando solo el pequeño detalle que ya le he comentado a M-DVD de que en su versión 2.0 del mod tiene que declarar como global la variable $db_prefix en la función checkreportMembers para que funcione bien el botón de "Revisar Usuarios".

Por esto es por lo q se me queda el navegador en blanco después de darle a "Revisar usuarios" ¿¿??

salu2

Ese pequeño error está arreglado en la versión 2.1

Si has instalado otra desinstalala y ponle la última versión.

Tengo la 2.1 :)

salu2

Debido a la enorme cantidad de spammers que están atacando sin parar, hay veces que la web de www.stopforumspam.com está saturada (a veces durante ratos largos) y tarda en responder.

Pero eso no ocurre siempre, sino que solo "a veces".

Por eso añadió M-DVD en la verión 2.1 del mod el nuevo estado en amarillo de "este usuario no ha podido ser comprobado", por si al intentar comprobarlo la web de stopforumspam estaba saturada y así puedes comprobar a ese usuario más tarde cuando ya no lo esté.

¿Lo de que el navegador se te quede en blanco después de darle a "Revisar usuarios" te ocurre todas las veces?

¿No ha habido ninguna vez que no te haya ocurrido?

Si es así, prueba a desinstalar el mod y a volverlo a instalar otra vez a ver si te da algún error durante el proceso de instalación y nos lo cuentas.

El verdadero sabio es aquel que lo ve todo, lo estudia todo, lo analiza todo y molesta poco.
A true wise man is he who sees everything, studies everything, analyses everything and hardly ever annoys.

Advertisement: