• Welcome to Simple Machines Community Forum. Please login or sign up.
January 21, 2022, 07:00:12 AM

News:

Want to get involved in developing SMF, then why not lend a hand on our github!


[Theme] Aqua Soft.org skin ported to SMF :)

Started by Nightwish, March 17, 2005, 10:30:24 PM

Previous topic - Next topic

[Unknown]

What source files did you have to change?  I would, of course, like to avoid the necessity of such changes.

-[Unknown]

Nightwish

Quote from: [Unknown] on April 10, 2005, 05:49:28 AM
What source files did you have to change?  I would, of course, like to avoid the necessity of such changes.

-[Unknown]
First, the theme does NOT rely on any source changes...  I've verified that it works flawlessly with a default SMF 1.0.3 installation. The theme also has support for some mods in it (rating for example), but that's optional and has to be enabled by editing index.template.php

The changes I did to smf are minimal..

Modded constructPageIndex to allow the << >> (prev/next) links even in the compact display. That's something the theme doesn't have to care about...

modded timeformat to allow these relative timestamps (x hours ago, x minutes ago and so on..). Again, unrelated to the theme.

In BoardIndex and MessageIndex I added m.icon to the sql query (and subsequently to $boards[last_post]) to allow showing the post icon for the last post entry..

I also added a [last_post][long_subject] to allow the full subject as a title="" tooltip in the last post column (in case, it's too long and needs to be truncated).

Modified theme_linktree() for the 2-lines inline linktree (but that's in the theme anyway).

The optional features need to be explicitly enabled by setting a few variables in index.template.php, so that, when running with a default installation, the theme will not cause any errors or warning messages (like unknown offset for example).
Every program has at least one bug and can be shortened by at least one instruction -- from which, by induction, one can deduce that every program can be reduced to a single instruction that doesn't work.
EoS - SMF-based forum under development.

lchance

Will the error be addressed during a reply? I get:

Line 123, 'document.getElementById(...)' is null or not an object.

Nightwish

Quote from: lchance on April 10, 2005, 10:39:13 AM
Will the error be addressed during a reply? I get:

Line 123, 'document.getElementById(...)' is null or not an object.
Thanks for this...
<done>
Every program has at least one bug and can be shortened by at least one instruction -- from which, by induction, one can deduce that every program can be reduced to a single instruction that doesn't work.
EoS - SMF-based forum under development.

lchance

Thank you for your rapid response! 'Tis a very nice theme indeed. I am waiting for its release.

How about the image under "Users Online" in the index page? It is a broken link for me. It's probably that image isn't done yet?

Nightwish

Quote from: lchance on April 10, 2005, 11:15:16 AM
Thank you for your rapid response! 'Tis a very nice theme indeed. I am waiting for its release.

How about the image under "Users Online" in the index page? It is a broken link for me. It's probably that image isn't done yet?
Actually, there are still a few images missing. That's why I'am not yet releasing it. I'am thinking about creating aqua-style icons for the info center aswell.
Every program has at least one bug and can be shortened by at least one instruction -- from which, by induction, one can deduce that every program can be reduced to a single instruction that doesn't work.
EoS - SMF-based forum under development.

Aravot


nothing_special

The topbar(Home-Help-Search etc) doesn't look good on firefox though, but in IE, its FLAWLESS!

Nightwish

Quote from: nothing_special on April 10, 2005, 09:44:15 PM
The topbar(Home-Help-Search etc) doesn't look good on firefox though, but in IE, its FLAWLESS!
Whats wrong? I'am using Firefox almost exclusivly and cannot see any problems.

Could you provide a screenshot?
Every program has at least one bug and can be shortened by at least one instruction -- from which, by induction, one can deduce that every program can be reduced to a single instruction that doesn't work.
EoS - SMF-based forum under development.

nothing_special


Logue

Probably, I think that it is because the <ul> <li> tag is used. :-\

Nightwish

April 11, 2005, 09:30:31 AM #31 Last Edit: April 11, 2005, 11:10:04 AM by Nightwish
Quote from: Logue on April 11, 2005, 09:17:38 AM
Probably, I think that it is because the <ul> <li> tag is used. :-\
Yes, I think so, although I do not see the behaviour. The icons are lined up properly and I'am also using FF 1.0.2.

It seems to be a page reflow problem, possibly related to a bug in FF. What happens if the page is reloaded?

Anyway, I think it can be done without using a "list" at all.

edit: Done. The toolbar is no longer a list, but is now div based. I hope that fixes the reflow problems with firefox..

http://hell.at.eu.org/forums/index.php?theme=11
Every program has at least one bug and can be shortened by at least one instruction -- from which, by induction, one can deduce that every program can be reduced to a single instruction that doesn't work.
EoS - SMF-based forum under development.

nothing_special


alvinleephd

Worthless Forums-A Place to Kill Time.  Get your fix.

Elijah Bliss

is it possible for you to add a drop shadow to the Display template?

Nightwish

Quote from: Elijah Bliss on April 12, 2005, 02:33:40 AM
is it possible for you to add a drop shadow to the Display template?
A *good* drop shadow would require quite some changes - maybe later, but for now, I think the display template is ok.
Every program has at least one bug and can be shortened by at least one instruction -- from which, by induction, one can deduce that every program can be reduced to a single instruction that doesn't work.
EoS - SMF-based forum under development.

Nightwish

A beta release of my AQUA-style theme is now available for download at my forum. Please refer to the included README before installing the theme.

http://hell.at.eu.org/forums/index.php/topic,559.html

Downloading does not require registration.

Every program has at least one bug and can be shortened by at least one instruction -- from which, by induction, one can deduce that every program can be reduced to a single instruction that doesn't work.
EoS - SMF-based forum under development.

Aravot

April 13, 2005, 09:03:16 PM #37 Last Edit: April 13, 2005, 09:12:40 PM by Aravot
Installed on a test server SMF 1.0.1

http://www.protechsystems.us/smf

One problem using smfaqua.zip file to insall the theme, created a SMFAQUA sub-folder in smfaqua themes folder with the files in the sub-folder had to move all the files from sub-folder into smfaqua folder manually.

Themes
---------+default
---------+smfaqua
---------------------+SMFAQUA

Nightwish

Quote from: Aravot on April 13, 2005, 09:03:16 PM
Installed on a test server SMF 1.0.1

http://www.protechsystems.us/smf

One problem using smfaqua.zip file to insall the theme, created a SMFAQUA sub-folder in smfaqua themes folder with the files in the sub-folder had to move all the files from sub-folder into smfaqua folder manually.

Themes
---------+default
---------+smfaqua
---------------------+SMFAQUA
So, a theme shouldn't contain it's own subfolder in the .zip or .tgz archive?
Every program has at least one bug and can be shortened by at least one instruction -- from which, by induction, one can deduce that every program can be reduced to a single instruction that doesn't work.
EoS - SMF-based forum under development.

Aravot

April 13, 2005, 09:29:00 PM #39 Last Edit: April 13, 2005, 09:41:13 PM by Aravot
Quote from: Nightwish on April 13, 2005, 09:23:02 PM
Quote from: Aravot on April 13, 2005, 09:03:16 PM
Installed on a test server SMF 1.0.1

http://www.protechsystems.us/smf

One problem using smfaqua.zip file to insall the theme, created a SMFAQUA sub-folder in smfaqua themes folder with the files in the sub-folder had to move all the files from sub-folder into smfaqua folder manually.

Themes
---------+default
---------+smfaqua
---------------------+SMFAQUA
So, a theme shouldn't contain it's own subfolder in the .zip or .tgz archive?

I don't know I guess not cause it didn't work for me had to move the files from the subfolder to the main folder.

Installed the theme on/in SMF 1.1 beta 1 http://www.peterosipof.com/smf/index.php, seems OK but didn't look thoroughly


Advertisement: