• Welcome to Simple Machines Community Forum. Please login or sign up.

Problem with smf who is online 2 transalation

Started by German_AC, May 10, 2009, 03:43:28 PM

Previous topic - Next topic

German_AC

Hi, I just installed who is online 2 in my mambo site, wich is in spanish. Everything works fine but it still shows "Guests and Users" in english.
I can't find the way to translate this two words.

Thanks!



Artificial intelligence is not a rival for natural stupidity.

Kindred

I can not recall if I hardcoded those or used the SMF strings...    check the mod_smf_whosonline2.php file...
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.<br /><br />"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

German_AC

Thanks kindred. I got it solved.

Now I m having a new problem. If I click on user name to see the profile, or if I click on PM button, the smf send pm page and profile page appear corrupt, i guess its something about template.

Any ideas?



Artificial intelligence is not a rival for natural stupidity.

Kindred

I'm not sure exactly what you are reporting...  however, I suspect one of two things...
1- your template is non-standard and may be broken...   2- you are using SMF 2.0RC1 (which I suspect will not work correctly with the 1.1.x versions of the bridge modules)
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.<br /><br />"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

German_AC

Check it.

http://www.etowers-20.net/~hvpsn/

If you click on the online users, even when you cannot see profiles being a visitor you may see that the template corrupts and doesn't display correctly.

Template was downloaded from official smf site, and I'm using smf 1.1.9.

Thanks



Artificial intelligence is not a rival for natural stupidity.

Kindred

again, I don't really understand what you mean by "template corrupts".  I went to your site, but there are no users online so I was unable to view any...


but I just looked at the profile link from the recent posts module...
http://www.etowers-20.net/~hvpsn/index.php?option=com_smf&Itemid=&?action=profile;u=1

I do, however, notice that your FORUM is not actually using com_smf...

your forum links to
http://www.etowers-20.net/~hvpsn/foro/index.php?www

which is NOT the bridge....
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.<br /><br />"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

German_AC

Ok, let me show you the problem. This happens when I click con send PM (the same happens with profile):



This is how it should be. If you enter first to the forum and click send PM, it work fine:




Artificial intelligence is not a rival for natural stupidity.

German_AC

Quote from: Kindred on May 25, 2009, 07:45:04 PM
your forum links to
http://www.etowers-20.net/~hvpsn/foro/index.php?www

which is NOT the bridge....

I linked directly to forum url. How should I do? Which is the bridge url?

Thanks



Artificial intelligence is not a rival for natural stupidity.

Kindred

You need to create an item in the main menu that points to the com_smf component

I suspect that the missing language strings are due to how you have the board set up...    (i.e.  Do you have "sync language" checked off in the bridge set up?   Do you have the default enlgish language files present in your themes/default/languages directory?
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.<br /><br />"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

German_AC

Quote from: Kindred on May 25, 2009, 10:16:38 PM
You need to create an item in the main menu that points to the com_smf component

Ok, I go to add item, Component->Select SMF Bridge but when I click in the new item, nothing happens, only a blank page.
I also tried to add a Link to component, but the bridge doesn't appears in the list of components available to link.

I'm so lost, sorry.
Thanks for the patience



Artificial intelligence is not a rival for natural stupidity.

Kindred

PM me an admin login for mambo/smf and I will take a look.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.<br /><br />"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

German_AC

Quote from: Kindred on May 25, 2009, 10:28:47 PM
PM me an admin login for mambo/smf and I will take a look.

I just send you account data. Thanks a lot man!



Artificial intelligence is not a rival for natural stupidity.

German_AC

Quote from: Kindred on May 25, 2009, 10:16:38 PM
I suspect that the missing language strings are due to how you have the board set up...    (i.e.  Do you have "sync language" checked off in the bridge set up?   Do you have the default enlgish language files present in your themes/default/languages directory?

I set sync language to NO, and is worst. Take a look:



I have both, default english files and spanish files.



Artificial intelligence is not a rival for natural stupidity.

Orstio

The language synch in the bridge is for use with the Nokkaew component.  If you don't have that installed, then you should always turn it off.

German_AC

Well, after going around and testing different options I finally get it working fine!

I add a link to the componente (the bridge), set integration Unwrapped and sync language to NO. When I click on PM or user profile now screen shows perfect.

Thanks for the support.



Artificial intelligence is not a rival for natural stupidity.

German_AC

Well, me again with another question. I'm using bridge registration. Everything works fine but, activation email still in english even when i installed spanish language, and last message after registration remains in english to. Where can I modify this?

Thanks



Artificial intelligence is not a rival for natural stupidity.

Kindred

look in components/com_smf_registration/languages
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.<br /><br />"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

German_AC

I don't have any languages directory in /components/com_smf_registration

Only two files:

smf_registration.php
smf_registration.html.php



Artificial intelligence is not a rival for natural stupidity.

Kindred

hmmm....   check the two files for hard-coded language strings....
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.<br /><br />"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

German_AC




Artificial intelligence is not a rival for natural stupidity.

German_AC

I can't find it, tried everything, but the message after registation complete, and activation mail steel been displayed in english.



Artificial intelligence is not a rival for natural stupidity.

Orstio

Bridge registration uses the Mambo registration email.  Have you installed the language pack in Mambo?

German_AC

Yes, if I set mambo registration instead bridge registration it works fine, but when using bridge registration dont.



Artificial intelligence is not a rival for natural stupidity.

Orstio

Is there a reason you prefer to use the bridge registration instead of the Mambo registration?

German_AC

Well, I tried mambo registration, but the best results was using bridge.

So, tecnically, modificating registration.po it should work??



Artificial intelligence is not a rival for natural stupidity.

Orstio

Results should be the same regardless of registration type, as long as you have the proper mambots published.

Technically, yes, but I'm not sure that the bridge registration component was updated so well for Mambo 4.6.x.  It has never been a terribly popular choice, from past experience.  People seem to prefer either Mambo registration, SMF registration, or CB registration.

Advertisement: