News:

Want to get involved in developing SMF, then why not lend a hand on our github!

Main Menu

groovie's upgrading to 1.0.4 probs

Started by groovie, June 08, 2005, 08:34:41 AM

Previous topic - Next topic

groovie

this was started somewhere else but its very busy there, so hopefully this makes it easier to follow (i have redirected the previous posts here).  this contains all history so far, from the beginning...

Quote- groovie - hello,

well i've JUST got:

- smf bridged to mambo
- coppermine gallery bridged to smf

so i'm a bit nervous about doing the upgrade.

are there any foreseeable problems when upgrading in these circumstances?

the only smf mod i am using is the login mod i guess.

any responses appreciated, thanks

Quote- unknown - This should not affect the bridge in any way...

-[Unknown]

Quote- Kindred - the smf-mambo bridge does not modify anything that is checked/updated in this upgrade.

As alwasy... backup your site...  but there should be no trouble at all doing this...
(although you may want to drop out of the bridge into the forum alone to do the updgrade, since mambo still has some issues with directory and file permissions)

Quote- groovie - just tried to upgrade in the circumstances quoted above, using the package manager, and eventually ran into this error:

An Error Has Occurred!
2: fopen(/home/*****/public_html/forum/changelog.txt): failed to open stream: Permission denied
File: /home/*****/public_html/forum/Sources/Subs-Package.php
Line: 1476

um, help!

Quote- Kindred -
as I noted in the mambo birdge discussion area...   the best way to install this patch is to go to the forum directly... bypass mambo, because mambo likes to have control of file permissions.

Quote- Ben_S -
The files need to be writable, chmod them to 777.

Quote- groovie - i was in the forum area, logged in and just went to package manager, is this what you mean?

ps i read somewhere changing permission would help so i tried, still didnt help, so i undid the changes and now i have this when i try to apply the mod from the package manager (its getting messy!):

Apply Mod
Please remember to always make regular backups of your sources and database before installing mods, especially beta versions.

Package Manager - Install Actions
Install Actions for archive smf_1-0-4_package.tar.gz:
Installing this package will perform the following actions:
   Type    Action    Description
1.    Execute Modification    ./changelog.txt    Failure
2.    Execute Modification    ./changelog-themes.txt    Failure
3.    Execute Modification    ./index.php    Failure
4.    Execute Modification    ./Sources/Admin.php    Success
5.    Execute Modification    ./Sources/Subs.php    Success
6.    Execute Modification    ./Themes/default/Admin.template.php    Success
7.    Execute Modification    ./Themes/default/languages/Admin.english.php    Success
8.    Execute Modification    ./Themes/default/Profile.template.php    Success

FTP Information Required
Some of the files this package needs to modify are not writable. This needs to be changed by logging into FTP and chmoding the files.


Quote- grudge - groovie,

Do you by any chance not have changelog.txt or changelog-themes.txt in your install?

Also, the problem with index.php is you are not using the standard version number, check it's correct.

For all the people having problems with files ending in ~, this is the package manager trying to make backup files. You need to chmod the DIRECTORY which the files sit in to be writable (777 or similar), this needs to be done for the forums root directory, Sources, Themes/default and Themes/default/languages - alternatively turn off "Create Backup" from Settings.

groovie

now i go to package manager, and after 'SMF 1.0.4 Update Package - 1.0.4' go [apply mod]  and i get failure on:

1.     Execute Modification     ./changelog.txt     Failure
2.    Execute Modification    ./changelog-themes.txt    Failure
3.    Execute Modification    ./index.php    Failure

So in the smf directory i chmodded changelog.txt, changelog-themes.txt, index.php to 777 and i still get the same failure messages as above.

Kindred

bypass mambo...   do not log into mambo at all.
if your forum is in mysite.com/forum, then go directly there using mysite.com/forum/index.php?action=admin

for some reason, Mambo won't let you modify some files...  especially those in the forum root directory.
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

groovie

Quote - GRUDGE -
Do you by any chance not have changelog.txt or changelog-themes.txt in your install?

yes they are in my smf forum folder. 

Quote - GRUDGE -
Also, the problem with index.php is you are not using the standard version number, check it's correct.

i dont understand what this means, can u explain please?

Quote - GRUDGE -
For all the people having problems with files ending in ~, this is the package manager trying to make backup files. You need to chmod the DIRECTORY which the files sit in to be writable (777 or similar), this needs to be done for the forums root directory, Sources, Themes/default and Themes/default/languages - alternatively turn off "Create Backup" from Settings.

1.  where is "Create Backup" in the settings area? i am in admin>edit server settings and cant see it.

2.  settings:

smf forum directory is 777
sources is 777
themes/default is 777
themes/mytheme is 777
themes/default/languages is 777
themes/mytheme/languages is 777

i even tried 777'ing my public html folder!

and still when i got to package manager>apply mod i get the following failures:

1.    Execute Modification    ./changelog.txt    Failure
2.    Execute Modification    ./changelog-themes.txt    Failure
3.    Execute Modification    ./index.php    Failure

i'm stuck :(

ps just saw last post here by KINDRED and i went straight to http://www.******.com/forum/index.php?action=admin and tried to apply mod from there and i got the same failures. 

Kindred

groovie... pm me your site and some login information. I will take a look...
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

groovie

thank you, have sent the necessary information. 

groovie

#6
Quotefrom kindred:

OK.....   it looks like the patch has been partially applied...

Here's what you do, and this should fix all your problems (especially since, with a partially applied patch, you have no idea how MANY times it was actually applied (you may have duplicate code)

Since you only have the mambo mod installed in the package manager...
download the upgrade.zip file from the download section of this SMF site...

from that, extract the files and FTP them to your site.
This will OVERWRITE the existing files!!!
(in this case, this means you will have a clean install)

then re-apply the mambo mod in your package manager...

robin asks:

Quotejust to clarify...

1.  so i downlaod the smf_1-0-4_upgrade.zip and not the update?

2.  once extracted i upload all the files to my smf directory via ftp overwriting everything that is already there?  (Will that mean i will loose all my data - users, posts, boards etc?)

3.  And after that re-apply the Mambo Integration 1.0 mod?

thank you. 

additionally will this overwrite all modifications i have made to welcome emails and things of this nature?  thankyou

ps i guess not if i leave my own themes folder there? what about the login module and the modifed text i have made there? hmmm


groovie

from kindred:

QuoteWhoops....   You are correct, you want the UPDATE zip file...

This will change a number of files...
Mostly in the Sources directory, however, it looks like a couple of the default template files were also changed...

specifically, Admin, BoardIndex, Display, ManageMembers, Packages, Poll, Profile, Recent, Search, Wireless

If you have modified any of these files in the DEFAULT theme directory, then the modifications will be removed.... otherwise, you're cool...

You will NOT lose users or messages, etc by doing this

and correct...   after doing the update, re-apply the mambi integration mod...

groovie

wo, that was close!! i had JUST thought 'bugger it, whats the worst that can happen, i wil just go ahead and do it' :)

so i will now do the UPDATE thing and NOT the UPGRADE thing. 

i cant remember modifying files in the default folder, hmm, here goes!....


groovie

from kindred:

Quote
I almost forgot....   run upgrade.php from your forum root directory....

robin:

Quotewhen and how do i do this?  sorry :)

kindred:

QuoteAfter loading the files via FTP, go to:

http://www.******.com/forum/upgrade.php

that will update your database, if it needs it.

groovie

ftp'ing went well, deleted upgrade.php as prompted, then uninstalled mambo integration from package manager and then went to 'apply mod' and got failure here:

Install Actions for archive smf_mambo3.1.tar.gz:
Installing this package will perform the following actions:
   Type    Action    Description
1.    Execute Modification    ./Sources/Subs.php    Failure
2.    Execute Modification    ./index.php    Success

[ Proceed ]

any ideas?

Kindred

#11
hmmm... hang on a sec....  I'll take a quick look at it.


Hmmm.... there is absolutely no reason that the modification to Subs.php should be failing.
The two actions in subs.php are properly defined...

Oh well...   try this:
Click  [proceed]

then in your filemanager, open subs.php

Confirm that the followin has been done:

// Don't exit if we're coming from index.php; that will pass through normally.
if (!$from_index || WIRELESS)
exit;

is replaced by

// Don't exit if we're coming from index.php; that will pass through normally.
if (!$from_index || WIRELESS)
{
if (function_exists('mambo_smf_exit'))
mambo_smf_exit($do_footer && !WIRELESS);
else
exit;
}


and


if (function_exists('mambo_smf_url'))
$setLocation = mambo_smf_url($setLocation);

has been added AFTER

// Put the session ID in.
if (defined('SID') && SID != '')
$setLocation = preg_replace('/' . preg_quote($scripturl, '/') . '(?!\?' . preg_quote(SID, '/') . ')(\?)?/', $scripturl . '?' . SID . '&', $setLocation);
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

groovie

i cant thank u enough kindred, really.  this is the sort of forum assistance that adds so much to the attractiveness of software such as mambo or smf  - seriously if the forum vibe and ability isnt happening then someone is much less likely to use the software.  i have had great experiences over at the mambo forum and now i can say, from my experiences over the last few weeks, i have here as well.  words travel, i have often followed a link to, and later used, some software because people have praised the software and the community in a forum.  and a few times i have done a hasty uninstall after realising the community attached to some software was impolite, too small or unhelpful.  i'll be sure to sing smf's praise wherever i shall go ;) 

all the code in subs was there and everything seems to working fine! phew!  only took a few hours!

bring on the next update! :)


Grendel

Quote from: Kindred on June 08, 2005, 11:42:25 AM
Hmmm.... there is absolutely no reason that the modification to Subs.php should be failing.

I seem to have some hack installed, but I don't know which one is responsible. I looked at the code of sub.php and found this in case #1


// Don't exit if we're coming from index.php; that will pass through normally.
//mambohacks
if ((!$from_index || WIRELESS) && !defined( '_VALID_MOS' ))
exit;


code #2:


// (MODED) Put the session ID in.
if (defined('SID') && SID != '')
$setLocation = preg_replace('/' . preg_quote($scripturl, '/') . '(?!\?' . preg_quote(SID, '/') . ')(\?)?/', $scripturl . '?' . SID . '&', $setLocation);

// Send the header only.


I guess I can edit the files manually, but don't want to break anything ;-)
regards,

Grendel

Kindred

you are running the mambohacks version of the bridge, which may (and probably does) modify things differently than I described. I listed the changes needed for Orstio's version of the bridge.

(BTW: I noticed that you were running SMF in a Wrapper... not calling for the bridge component...   doesn't that sort of defeat the purpose?
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

rjoe_brandon

Hi all,

I am having a similiar problem to groovie except I do get the correct success information:

Quote
Install Actions for archive smf_mambo3.1.tar.gz:
Installing this package will perform the following actions:
   Type    Action    Description
1.    Execute Modification    ./Sources/Subs.php    Success
2.    Execute Modification    ./index.php    Success
3.    Extract File    ./Sources/MOS_SMF.php

And it also has at the bottom of that screen a request for some FTP information which is correcty filled out.  When I click proceed the exact same screen as described comes back with no errors.  It just looks as if I have clicked "apply mod" again.

The only possible thing I can see that might not be set correctly is my local path to SMF which the default is public_html  so I also tried it with the path from edit server settings.  I also tried turning off "create back up copies" under the Package Manager -> Installation Options.

All of my directories are properly chmoded following these posts.

I am logged in directly to the forum not through Mambo.

Thanks for any ideas - you folks & SMF are awesome.


rjoe_brandon

Quote from: rjoe_brandon on June 09, 2005, 10:14:23 AM

I am having a similiar problem to groovie except I do get the correct success information:


Apparently I scared the program into working  ;D  I took a last stab and unpacked the 1.04 locally and ftp's up the Subs.php file and retried an "Apply Mod" (with backups turned off) and it went in fine.

Advertisement: