Advertisement:

Author Topic: [Theme] Simply White (SMF 1.0 / SMF 1.1)  (Read 76929 times)

Offline J. Williams

  • SMF Hero
  • ******
  • Posts: 1,535
  • Gender: Male
  • Don't ask me what DiCB stands for!
    • ByMoi
Re: [Theme] Simply White (SMF 1.0 / SMF 1.1)
« Reply #80 on: October 10, 2005, 12:39:29 PM »
I've checked this in the css validator ,passed ok but some warnings

URI : http://www.virtualchill.com/index.php?action=forum;theme=4
Line : 83 (Level : 2) Redefinition of margin-top : #autoXML22652102265210
URI : http://www.virtualchill.com/Themes/SimplyWhite1/style.css?beta3
Line : 3 (Level : 1) You have no color with your background-color : .board_rules
Line : 12 (Level : 1) You have no background-color with your color : a:visited
Line : 12 (Level : 1) You have no background-color with your color : a:visited
Line : 17 (Level : 1) Same colors for color and background-color in two contexts .button:hover and a:hover
Line : 17 (Level : 1) You have no background-color with your color : a:hover
Line : 24 (Level : 1) You have no background-color with your color : .nav:visited
Line : 24 (Level : 1) You have no background-color with your color : .nav:visited
Line : 24 (Level : 1) You have no background-color with your color : .nav:visited
Line : 30 (Level : 1) You have no background-color with your color : a.nav:hover
Line : 30 (Level : 1) Same colors for color and background-color in two contexts .button:hover and a.nav:hover
Line : 43 (Level : 1) You have no background-color with your color : td
Line : 60 (Level : 1) You have no background-color with your color : button
Line : 60 (Level : 1) You have no background-color with your color : button
Line : 60 (Level : 1) You have no background-color with your color : button
Line : 75 (Level : 1) You have no background-color with your color : select
Line : 85 (Level : 1) Same colors for background-color and color : .hrcolor
Line : 85 (Level : 1) Same colors for background-color and color : .hrcolor
Line : 117 (Level : 1) You have no background-color with your color : .codeheader
Line : 117 (Level : 1) You have no background-color with your color : .codeheader
Line : 133 (Level : 1) You have no background-color with your color : .meaction
Line : 176 (Level : 1) You have no background-color with your color : .titlebg a:hover
Line : 176 (Level : 1) Same colors for color and background-color in two contexts .button:hover and .titlebg a:hover
Line : 197 (Level : 1) You have no color with your background-color : .bordercolor
Line : 204 (Level : 1) You have no color with your background-color : .tborder
Line : 226 (Level : 1) You have no color with your background-color : #headerarea
Line : 236 (Level : 1) You have no background-color with your color : .sep
Line : 236 (Level : 1) Same colors for color and background-color in two contexts .catbg2 and .sep
Line : 236 (Level : 1) Same colors for color and background-color in two contexts .catbg and .sep
Line : 242 (Level : 1) You have no color with your background-color : #bodyarea
Line : 262 (Level : 1) You have no color with your background-color : .headerbodies
Line : 276 (Level : 1) You have no color with your background-color : .forumnews
Line : 358 (Level : 1) You have no color with your background-color : .no_new_posts:hover
Line : 358 (Level : 1) You have no color with your background-color : .no_new_posts:hover
Line : 358 (Level : 1) You have no color with your background-color : .no_new_posts:hover
Line : 403 (Level : 1) You have no color with your background-color : .newsinfo
Joshua Jon Williams
Back in Action.

Offline codenaught

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 14,653
  • Gender: Male
  • Formerly Known As akabugeyes
Re: [Theme] Simply White (SMF 1.0 / SMF 1.1)
« Reply #81 on: October 22, 2005, 07:42:13 PM »
! Theme updated for SMF 1.1 RC1. A number of changes have also been made to improve the look of the theme and usability.

Download
Live Demo
Dev Consultant
Former SMF Doc Coordinator

Offline mirigoyen

  • Semi-Newbie
  • *
  • Posts: 68
Re: [Theme] Simply White (SMF 1.0 / SMF 1.1)
« Reply #82 on: December 11, 2005, 11:04:18 PM »
I want to add a counter to the bottom of my forum and I was wondering if you could tell me how I would go about doing that.  What page would I edit??

Thanks,

Offline UnpackedRope

  • Semi-Newbie
  • *
  • Posts: 10
Re: [Theme] Simply White (SMF 1.0 / SMF 1.1)
« Reply #83 on: December 13, 2005, 02:45:06 PM »
Hi.

I currently have 'Show buttons as images instead of text' unchecked but I want the profile buttons to use the images.

In Display.template.php (below) what do I have to change to show the image buttons instead of the usual "View Profile  Email  Personal Message (Online)"?

I'm guessing it's to do with '$settings['use_image_buttons']' but I've no idea how to remove it...

Thanks.

Code: [Select]
// Show the profile, website, email address, and personal message buttons.
if ($settings['show_profile_buttons'])
{
// Don't show the profile button if you're not allowed to view the profile.
if ($message['member']['can_view_profile'])
echo '
<a href="', $message['member']['href'], '">', ($settings['use_image_buttons'] ? '<img src="' . $settings['images_url'] . '/icons/profile_sm.gif" alt="' . $txt[27] . '" title="' . $txt[27] . '" border="0" />' : $txt[27]), '</a>';

// Don't show an icon if they haven't specified a website.
if ($message['member']['website']['url'] != '')
echo '
<a href="', $message['member']['website']['url'], '" title="' . $message['member']['website']['title'] . '" target="_blank">', ($settings['use_image_buttons'] ? '<img src="' . $settings['images_url'] . '/www_sm.gif" alt="' . $txt[515] . '" border="0" />' : $txt[515]), '</a>';

// Don't show the email address if they want it hidden.
if (empty($message['member']['hide_email']))
echo '
<a href="mailto:', $message['member']['email'], '">', ($settings['use_image_buttons'] ? '<img src="' . $settings['images_url'] . '/email_sm.gif" alt="' . $txt[69] . '" title="' . $txt[69] . '" border="0" />' : $txt[69]), '</a>';

// Since we know this person isn't a guest, you *can* message them.
if ($context['can_send_pm'])
echo '
<a href="', $scripturl, '?action=pm;sa=send;u=', $message['member']['id'], '" title="', $message['member']['online']['label'], '">', $settings['use_image_buttons'] ? '<img src="' . $settings['images_url'] . '/im_' . ($message['member']['online']['is_online'] ? 'on' : 'off') . '.gif" alt="' . $message['member']['online']['label'] . '" border="0" />' : $message['member']['online']['label'], '</a>';

Offline codenaught

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 14,653
  • Gender: Male
  • Formerly Known As akabugeyes
Re: [Theme] Simply White (SMF 1.0 / SMF 1.1)
« Reply #84 on: December 17, 2005, 01:01:54 PM »
mirigoyen, do you have the code for the counter? It would probably need to be added somewhere in index.template.php of the theme.

hyt, erase each occurance in Display.template.php of:

', ($settings['use_image_buttons'] ? ' (appears after <a href.......>)

and

' : $txt[X]), ' (appears after border="0" />)

So
Code: [Select]
if ($message['member']['can_view_profile'])

echo '

<a href="', $message['member']['href'], '">', ($settings['use_image_buttons'] ? '<img src="' . $settings['images_url'] . '/icons/profile_sm.gif" alt="' . $txt[27] . '" title="' . $txt[27] . '" border="0" />' : $txt[27]), '</a>';

Would become:
Code: [Select]
if ($message['member']['can_view_profile'])

echo '

<a href="', $message['member']['href'], '"><img src="' . $settings['images_url'] . '/icons/profile_sm.gif" alt="' . $txt[27] . '" title="' . $txt[27] . '" border="0" /></a>';
Dev Consultant
Former SMF Doc Coordinator

Offline UnpackedRope

  • Semi-Newbie
  • *
  • Posts: 10
Re: [Theme] Simply White (SMF 1.0 / SMF 1.1)
« Reply #85 on: December 21, 2005, 01:11:11 PM »
hyt, erase each occurance in Display.template.php of:

', ($settings['use_image_buttons'] ? ' (appears after <a href.......>)

and

' : $txt[X]), ' (appears after border="0" />)

Thanks mate.  Appreciated.

Offline piskè

  • Newbie
  • *
  • Posts: 4
Re: [Theme] Simply White (SMF 1.0 / SMF 1.1)
« Reply #86 on: January 05, 2006, 06:20:29 PM »
this theme rocks awesome work akabugeyes

i have a question. the "new - no new messages in this forum section" text buttons at the index page.. they work fine with english (displayed).. but when i tried change the default language they aren't shown anymore

why?

got it

was the

$txt['forum_news'] ='Forum News';
$txt['user_info'] ='User Info';
$txt['no_new'] ='No new';
$txt['newposts'] ='New';
$txt['newchildposts'] ='New';
$txt['blank'] ='<span class="sep">-</span>';

at the index.languagename.php

^^ thx anyway
« Last Edit: January 05, 2006, 06:31:25 PM by piskè »

Offline Dem0n

  • Full Member
  • ***
  • Posts: 520
  • Gender: Male
  • Word Lyfe!
    • TheTVStop
Re: [Theme] Simply White (SMF 1.0 / SMF 1.1)
« Reply #87 on: September 06, 2007, 12:56:00 AM »
how do I get the on/off images to work in child boards?

Offline csmc

  • Semi-Newbie
  • *
  • Posts: 27
Re: [Theme] Simply White (SMF 1.0 / SMF 1.1)
« Reply #88 on: October 23, 2007, 04:41:40 PM »
I have tried all the links in this thread but have not been able to see anything, I keep getting error messages or sent back to this thread.

I really would like to see the theme!