News:

SMF 2.0.19 has been released! Please update. Read more.

Main Menu

Simple Audio Video Embedder

Started by SMFHacks.com Team, August 09, 2010, 10:42:47 PM

Previous topic - Next topic

HunterP

Quote from: vbgamer45 on February 01, 2013, 08:10:28 PM
Not sure what would cause that might be a general SMF issue.
I saw you posted also that you couldn't install the new SMF patch either.

That's on a different board and has already been fixed :)

vbgamer45

Hmm not sure then. I would try that same fix on your other board and see if it helps.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

HunterP

Ok, trying to hunt down the problem. When I only install AutoEmbedMediaPro2.xml, it *does* make the changes...

HunterP

Quote from: vbgamer45 on February 01, 2013, 08:14:57 PM
Hmm not sure then. I would try that same fix on your other board and see if it helps.

I'm sure it is unrelated as I have more (host related) problems on that board.
Also, the file modifications do install (see previous post), so it should be something else...?

vbgamer45

It could be the cache or video folder it creates but you can do the file edits then just do the manual file copies yourself
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

HunterP

Quote from: vbgamer45 on February 01, 2013, 08:31:44 PM
It could be the cache or video folder it creates but you can do the file edits then just do the manual file copies yourself

Yes, when I removed the two require-dir lines, it worked. Weird, but problem solved :)

As far as I can see, quoted embedding can't be disabled? I'd really like such an option  8)

Glasso

I can confirm 2.0.7a does not install though it says it installed successfully.
I went back to 2.0.6 and it installs perfectly.

NightzKung

mod very cool thank you vbgamer45  ;)
ขอบคุณมากมายครับท่าน  vbgamer45

vbgamer45

Quote from: NightzKung on February 06, 2013, 08:50:30 AM
mod very cool thank you vbgamer45  ;)
ขอบคุณมากมายครับท่าน  vbgamer45
Glad you enjoy it!
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Adrek

Update works good :) Just one question, because I have installed SimplePortal.

Video Embedder is changing Youtube URLs posted on Shoutbox into YT player. So I edited AutoEmbedMediaPro2.php and added check inside MediaProProcess():

if(!empty($topic))


So it only works inside topics. Is it good solution?
It works, but I'm asking here, as you know better this mod :)
Polskie wsparcie SMF na simplemachines.org

the simplest solution is most likely the right one

vbgamer45

That's pretty good. That will make it work only on topic pages.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

HunterP

Quote from: HunterP on February 02, 2013, 04:25:41 AM
As far as I can see, quoted embedding can't be disabled? I'd really like such an option  8)

I had to deinstall this mod because of this. We have lots of quoted movies and AEVA had an option not to embed them.
Any chance, vbgamer?

vbgamer45

That would be tricky to do maybe... This mod just looks for raw links and embeds them.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Neek

Quote from: phantomm on February 06, 2013, 10:39:29 AM
Update works good :) Just one question, because I have installed SimplePortal.

Video Embedder is changing Youtube URLs posted on Shoutbox into YT player. So I edited AutoEmbedMediaPro2.php and added check inside MediaProProcess():

if(!empty($topic))


So it only works inside topics. Is it good solution?
It works, but I'm asking here, as you know better this mod :)

What exactly did you do?

Adrek

AutoEmbedMediaPro2.php:
Code (Find) Select
global $boarddir, $modSettings;
Code (Replace with) Select

global $boarddir, $modSettings, $topic;

if(empty($topic))
return $message;
Polskie wsparcie SMF na simplemachines.org

the simplest solution is most likely the right one

Neek

This works, thanks a lot.

Unfortunately this also disables embedded videos on EzPortal's news block. I'm trying to allow embedded videos there but disallow embedded videos on EzPortal's shoutbox block.

NightzKung

็Hello vbgamer45

Simple Audio Video Embedder Not compatible with anti spam links v1.0.1

thank

vbgamer45

I might also add a setting just to allow embeding on posts/topic display thinking about it.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Chalky

The first time someone tries to embed a Facebook video on my forum and it doesn't work!  Any help please??

http://www.facebook.com/video/embed?video_id=4517377140741

http://www.facebook.com/photo.php?v=4517377140741

SAVE doesn't embed either of them, and yes, I have checked that FB is enabled in the settings.  I'm running the latest version of SAVE, upgraded last week, on SMF 2.0.4.

vbgamer45

Quote from: ChalkCat on February 08, 2013, 11:47:55 AM
The first time someone tries to embed a Facebook video on my forum and it doesn't work!  Any help please??

http://www.facebook.com/video/embed?video_id=4517377140741

http://www.facebook.com/photo.php?v=4517377140741

SAVE doesn't embed either of them, and yes, I have checked that FB is enabled in the settings.  I'm running the latest version of SAVE, upgraded last week, on SMF 2.0.4.
It looks like they changed the Video Embed code will check it out now
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Advertisement: