• Welcome to Simple Machines Community Forum. Please login or sign up.
November 29, 2021, 09:54:54 AM

News:

SMF 2.0.18 has been released! Please update. Read more.


Member count etc.

Started by liamtoo, October 30, 2010, 08:26:58 AM

Previous topic - Next topic

liamtoo

RC3.
I want to get rid of the member count, post count and topic count on the main page but cannot find the option anywhere. I only allow the curve theme. Is it something simply I'm overlooking?
Thanks

Kays

Admin CP > Current Theme > Show statistics on board index:

Does unchecking that that do what you want?

If not could you please post a screenshot of what you want to get rid of?

If at first you don't succeed, use a bigger hammer. If that fails, read the manual.
My Mods

liamtoo

I have that option unchecked but that doesn't seem to affect it.
Attached is a screenshot.
Thanks

Kays

I forgot about that happening when that option is disabled.

In BoardIndex.template.php look for:


// Show some statistics if stat info is off.
if (!$settings['show_stats_index'])
echo '
<div id="index_common_stats">
', $txt['members'], ': ', $context['common_stats']['total_members'], ' &nbsp;•&nbsp; ', $txt['posts_made'], ': ', $context['common_stats']['total_posts'], ' &nbsp;•&nbsp; ', $txt['topics'], ': ', $context['common_stats']['total_topics'], '
', ($settings['show_latest_member'] ? ' ' . $txt['welcome_member'] . ' <strong>' . $context['common_stats']['latest_member']['link'] . '</strong>' . $txt['newest_member'] : '') , '
</div>';


And comment it out.


// Show some statistics if stat info is off.
/* if (!$settings['show_stats_index'])
echo '
<div id="index_common_stats">
', $txt['members'], ': ', $context['common_stats']['total_members'], ' &nbsp;•&nbsp; ', $txt['posts_made'], ': ', $context['common_stats']['total_posts'], ' &nbsp;•&nbsp; ', $txt['topics'], ': ', $context['common_stats']['total_topics'], '
', ($settings['show_latest_member'] ? ' ' . $txt['welcome_member'] . ' <strong>' . $context['common_stats']['latest_member']['link'] . '</strong>' . $txt['newest_member'] : '') , '
</div>';
*/


That should disappear it then.

If at first you don't succeed, use a bigger hammer. If that fails, read the manual.
My Mods

liamtoo

Quote from: Kays on October 30, 2010, 10:39:08 AM
I forgot about that happening when that option is disabled.

In BoardIndex.template.php look for:

Thanks, that worked fine. Is that a known bug then?

Kays

Not a bug but a feature. ::)

Someone thinks that it should displayed elsewhere if it's disabled in the Info Center. Others, like you, disagree.

I'll mark this as solved.

If at first you don't succeed, use a bigger hammer. If that fails, read the manual.
My Mods

Advertisement: