• Welcome to Simple Machines Community Forum. Please login or sign up.

Wrong value type sent to the database. Integer expected. (id_msg)

Started by PacoCro, April 04, 2012, 08:52:00 AM

Previous topic - Next topic

PacoCro

Started to happen on my forum. Dont know why... didnt change forum for a while and suddenly it came.


Database error:
Wrong value type sent to the database. Integer expected. (id_msg)

Link
c9fans.com/forum/c9-general-discussion/new-topic-is-here/

PS:
When I want to create a post it comes with this:

Table 'banitara_c9forum.related_subjects' doesn't exist
File: /home/banitara/public_html/woi/forum/Sources/Subs-RelatedFulltext.php
Line: 110

emanuele

Hello PacoCro and welcome to sm.org!

It seems to be related to a mod: Subs-RelatedFulltext.php is not a SMF "core" file.
A quick search on google brought up:
http://www.simplemachines.org/community/index.php?topic=285866.0
that could solve your issue. :)


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

PacoCro

Thank you so much. Related topics mod was the problem. We should not use it in case we want to run forum smooth.
:)

emanuele

Well, looking closely at the error is seems that a table is missing, so either the mod was not installed properly or the table has been deleted...


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Forumtastic

This just started happening to me. I do not have that mod installed.

Wrong value type sent to the database. Integer expected. (id_msg)<br />Function: MessageIndex

Sources/MessageIndex.php

emanuele

Forumtastic a bit more informations would be helpful...for example the exact error message that appears in the error log.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Forumtastic

I can't divulge our members IP addresses (I'm leaving out session information as well) for legal reasons but here is the relevant information from the error log:

id_error: 27
url: ?/board,1.0.html
message: Wrong value type sent to the database. Integer expected. (id_msg)<br />Function: MessageIndex
error type: critical
file: Sources/MessageIndex.php
line: 145

It looks like it is happening on this line:

$smcFunc['db_insert']('replace',
    '{db_prefix}log_boards',
    array('id_msg' => 'int', 'id_member' => 'int', 'id_board' => 'int'),
    array($modSettings['maxMsgID'], $user_info['id'], $board),
    array('id_member', 'id_board')
);

So it appears it has something to do with logging which boards have been seen.

emanuele

Do you have any other error message that could be related, maybe just before that one in the same file?

And also: mods installed?


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Arantor

Better question, in the settings table, is there an entry for maxMsgID and if so what is it?
No good deed goes unpunished
All helpful urges should be circumvented

Forumtastic

maxMsgID = 553384

And no related errors.

It's not consistent either. It generated about 300 errors within a couple of days but most of the time, people do not receive the error. It's a very busy forum.

Arantor

No good deed goes unpunished
All helpful urges should be circumvented

Advertisement: