• Welcome to Simple Machines Community Forum. Please login or sign up.

want my logo at top left to link back to my homepage

Started by scottkahn, May 18, 2010, 05:05:04 PM

Previous topic - Next topic

scottkahn

Where do I edit the code so that my graphic in the top left corner of the forums (that replaces the Simple Machines logo) links back to my homepage when someone clicks it?

Thanks,

Scott

Yağız...


scottkahn

I guess I should have been more specific. I'm not a developer/programmer.

Where is the specific line of code, within that index.template file or otherwise, that needs to be modified, and how do I modify it so that my graphic, which IS showing up on the page in place of the SimpleMachines logo, links back to my website's home page? I'm not sure where to even find it within all that code!

Thanks -- I'm a newbie at this customization stuff.

Scott

Yağız...

Oh, sorry there was a better way :) Go to Admin > Current Theme > Site Slogan and put:
<a href="link"><img src="img url" alt="" /></a>

YogiBear

May 20, 2010, 06:45:43 PM #4 Last Edit: May 20, 2010, 06:51:55 PM by YogiBear
I'm sure there's already a mod for this called Clickable Banner or Click On Banner. It also gives the option for the smf logo to be clickable plus there's a click on logo mod Have a look in...


http://custom.simplemachines.org/mods/index.php


PS Found it! It's this one...


http://custom.simplemachines.org/mods/index.php?mod=1370
SMF v2.0.19  Mods : Ohara YouTube Embed v1.2.9,  Custom Tab v1.2 , Bakers' Dozen Pages v1.2 , SMFPacks Shoutbox v1.1,  Board Color & Icons v1.1 , Simple Image Upload , Snow & Garland v1.4,  PHP  v.7.4.25

Cheese Head

Sorry for not starting new topic even though this one is old, but correct place.

The Clickable Banner mod only works up to SMF 1.1.7 and I'm using SMF 2.0 RC2.

I want to make a top left clickable banner that takes me back to my website's homepage.

As recommended above I've gone Admin > Configuration > Themes and Layout > Theme Settings and removed my "Logo image URL" and in "Site slogan:" added the code above with my Homepage URL and banner image address, works well, except the image was on the right and at top left I had my "Forum Title", so I went to Admin > Configuration > Server Settings and changed my "Forum Title" to blank (assume there is no problem in doing that). That got rid of it and moved my clickable banner up but still on right. How do I move it to top left via the "Site Slogan" text/code box and if not possible can you please redirect me to a thread on how to hard code it?

Many thanks.

Madzgo

December 27, 2010, 10:14:57 AM #6 Last Edit: December 27, 2010, 10:22:33 AM by madzgo
CSS.

Find (in the first half of the document, line 1370):

#siteslogan, img#smflogo
{
margin: 0;
padding: 0;
float: right;
line-height: 3em;
}


Replace with:

#siteslogan, img#smflogo
{
margin: 0;
padding: 0;
float: left;
line-height: 3em;
}



And if it's not in the right place, use:

#siteslogan, img#smflogo
{
margin: 0;
padding: 0;
        position: absolute;
        top: 25px;
        left: 10%;
line-height: 3em;
}

Change 25px and 10% to smaller or larger numbers to move it further down/further right

Cheese Head

madzgo, many thanks!

Found that line in my Themes > default > css > index.css file (I'm using default Curve theme).

Just changed right to left parameter, thanks!

Advertisement: