• Welcome to Simple Machines Community Forum. Please login or sign up.
September 17, 2021, 04:22:09 PM

News:

Follow SMF on Twitter.


Optimus

Started by Bugo, February 15, 2011, 03:48:12 PM

Previous topic - Next topic

MohammedFK

Thanks sir,
take a look at the attachments

+ SMF Default Theme - Curve

aegersz

Quote from: MohammedFK on May 20, 2021, 05:21:03 AM
+ after add my Google Analytics code to (Counters), I found:

QuoteForbidden
You don't have permission to access /index.php on this server.

I an the Administrator

Where and when are you seeing that error ? I just got Google Analytics working without any hassles.

Can you screenprint it ?
The configuration of my Linux VPS (SMF 2.0 with 160+ mods & some assorted manual tweaks) can be found here and notes on my mods can be found here (warning: those links will take you to a drug related forum). My (House) music DJ dedication page is here

MohammedFK

Quote from: aegersz on May 27, 2021, 09:38:10 AM
Can you screenprint it ?

Forbidden
You don't have permission to access /index.php on this server.



aegersz

May 27, 2021, 10:24:27 AM #843 Last Edit: May 27, 2021, 10:47:40 AM by aegersz
Yes but when does it happen ?

Are you shared hosting, Windows or Linux ?

It is a permissions error on the web root directory, I'm thinking ... could be Apache mod security too.

Can you run the scheduled task to update the sitemap without errors ?

Can we also see your .htaccess file ?
The configuration of my Linux VPS (SMF 2.0 with 160+ mods & some assorted manual tweaks) can be found here and notes on my mods can be found here (warning: those links will take you to a drug related forum). My (House) music DJ dedication page is here

MohammedFK

Quote from: aegersz on May 27, 2021, 10:24:27 AM
!!

Yes but when does it happen ?
after add the google code and press "save"

Are you shared hosting, Windows or Linux ?
VPS

Can you run the scheduled task to update the sitemap without errors ?
HOW?

Can we also see your .htaccess file ?
I don't have a .htaccess file for the forums.

aegersz

May 27, 2021, 11:43:58 AM #845 Last Edit: May 27, 2021, 12:13:57 PM by aegersz
OK, so you have a VPS as do I. I run Linux - what do you run ?

No .htaccess then I assume that you don't run https, correct ?

To run the scheduled task:

Admin > Maintenance > Scheduled Tasks > Sitemap XML Generation ... tick the "Run Now" box and hit the "Run Now" button. I am expecting an error.

Let me know if it fails.

By the way, my index.php is "-rwxrwxrwx  1 apache root       19057 May 27 13:41 index.php" and my web root is "drwxrwxrwx 29 apache apache 12288 May 27 21:25 html"

The configuration of my Linux VPS (SMF 2.0 with 160+ mods & some assorted manual tweaks) can be found here and notes on my mods can be found here (warning: those links will take you to a drug related forum). My (House) music DJ dedication page is here

shadav

if the issue is with trying to add the google analytics code into the counter box

delete that and add this mod: https://custom.simplemachines.org/mods/index.php?mod=2210

searching this topic for the word analyitcs
there's only one other person that mentioned a issue and they said that they contacted their host and it was fixed, so it seems to be something hosting related

or you could as I said above, remove your code from the counter box and install the google analytics mod

*giggles* and if you noticed the pink icon on the gender there, I am not a sir ;)

MohammedFK

Quote from: aegersz on May 27, 2021, 11:43:58 AM

Admin > Maintenance > Scheduled Tasks > Sitemap XML Generation ... tick the "Run Now" box and hit the "Run Now" button. I am expecting an error.


Fabulous; successfully done. I made it once every single day.

I will see if the map will be updated daily; It would be great.

pocttopus

Hello again, I asked this question on previous page but didn't get any tips how to solve this issue on the screenshot when I click on the sitemap link at the bottom of my forum page.



Any suggestions please.  :-[

pocttopus

Quote from: pocttopus on May 31, 2021, 09:52:27 AM
Hello again, I asked this question on previous page but didn't get any tips how to solve this issue on the screenshot when I click on the sitemap link at the bottom of my forum page.



Any suggestions please.  :-[
No one?  :-[

shadav

Quote from: pocttopus on June 01, 2021, 02:25:37 AM
Quote from: pocttopus on May 31, 2021, 09:52:27 AM
Hello again, I asked this question on previous page but didn't get any tips how to solve this issue on the screenshot when I click on the sitemap link at the bottom of my forum page.



Any suggestions please.  :-[
No one?  :-[

it seems to be more of a css issue

check to make sure that in your default theme folder, in the css folder there is the optimus folder and that it contains the three needed files

in your root folder make sure that the sitemap.xml file is correct
make sure that this line is pointing to the correct path
<?xml-stylesheet type="text/xsl" href="http://YOURSITE.TLD/Themes/default/css/optimus/sitemap.xsl"?>
or that it's using https if that's what you are using

if all seems ok, then make sure of file permissions of the css folder and files

smartmouse

Hello, I have Optimus v2.3.1 on SMF 2.1 RC2. I noticed that when I share a link of my forum there is no preview of it.
I would install the latest version of Optimus but I see that it doesn't support SMF 2.1.
What's wrong?

Ninja ZX-10RR

Quote from: smartmouse on July 02, 2021, 05:08:52 AM
Hello, I have Optimus v2.3.1 on SMF 2.1 RC2. I noticed that when I share a link of my forum there is no preview of it.
I would install the latest version of Optimus but I see that it doesn't support SMF 2.1.
What's wrong?
What's the point of asking for support for something that clearly isn't supported?
Quote from: BeastMode topic=525177.msg3720020#msg3720020
It's so powerful that on this post and even in the two PMs you sent me,you still answered my question very quickly and you're apologizing for the delay. You're the #1 support I've probably ever encountered man, so much respect for that. Thank you, and get better soon.

I'll keep this in my siggy for a while just to remind me that someone appreciated what I did while others didn't.

♥ Jess ♥

STOP EDITING MY PROFILE

smartmouse

Quote from: Ninja ZX-10RR on July 13, 2021, 12:01:09 PM
Quote from: smartmouse on July 02, 2021, 05:08:52 AM
Hello, I have Optimus v2.3.1 on SMF 2.1 RC2. I noticed that when I share a link of my forum there is no preview of it.
I would install the latest version of Optimus but I see that it doesn't support SMF 2.1.
What's wrong?
What's the point of asking for support for something that clearly isn't supported?

Sorry, I'm afraid there is a misunderstanding.
Some months ago I upgraded my forum from 2.0.x to 2.1 RC2 and I keep installed only compatible mods.
Now I'm accessing to my packages after a lot of times and I see Optimus, so I supposed that at the time I upgraded it supported SMF 2.1. Am I wrong?
That's why I asked how to install an updated version of Optimus that supports SMF 2.1, since post previews is not working.
I hope it is clear now, sorry for my english.

Kindred

Actually, Ninja -- Optimus *DOES* have a version that supports SMF 2.1


However, smartmouse, the version on the SMF mod site might not be that one.

You might need to get the 2.1 version from the author's github

https://github.com/dragomano/Optimus

Or --   Bugo might have included the updated version for 2.0 AND 2.1 into the packaged mod. 



However, SMartmouse...     if you are running SMF 2.1 RC2 -- you DESPERATELY need to update to RC4.   there have been literally THOUSANDS of commits since RC2
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

smartmouse

Quote from: Kindred on July 14, 2021, 08:57:48 AM
Actually, Ninja -- Optimus *DOES* have a version that supports SMF 2.1


However, smartmouse, the version on the SMF mod site might not be that one.

You might need to get the 2.1 version from the author's github

https://github.com/dragomano/Optimus

Or --   Bugo might have included the updated version for 2.0 AND 2.1 into the packaged mod. 



However, SMartmouse...     if you are running SMF 2.1 RC2 -- you DESPERATELY need to update to RC4.   there have been literally THOUSANDS of commits since RC2

Thank you for your reply, it was very useful to make me to figure out the situation.
Anyway, despite message on github page says "P.S. The master branch contains the Optimus 2.x version for SMF 2.1 RC3+" I can't see any master branch :(

Kindred

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."


Kindred

:D

yes, but according to the release note, the master branch (which is the default displayed there) contains both!

look at the package_info.xml file to be sure
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

smartmouse

Quote from: Kindred on July 14, 2021, 12:48:34 PM
:D

yes, but according to the release note, the master branch (which is the default displayed there) contains both!

look at the package_info.xml file to be sure

The package_info.xml file is clear: SMF 2.1 is not supported.

Advertisement: