Advertisement:

Author Topic: Error bursts  (Read 198 times)

Offline Sir Osis of Liver

  • SMF Super Hero
  • *******
  • Posts: 10,949
  • We were all equal in the end.
Error bursts
« on: October 13, 2020, 04:43:59 PM »
Seeing this again, different forum, different errors than previously.  Server logged 10.6 mb errors in two seconds this a.m., same thing last night around 23:00.  Starts with a lot of these -

Code: [Select]

[13-Oct-2020 07:00:52 America/New_York] PHP Notice:  Undefined index: is_admin in /home/freeadzf/public_html/Sources/Security.php on line 824
[13-Oct-2020 07:00:52 America/New_York] PHP Notice:  Undefined index: permissions in /home/freeadzf/public_html/Sources/Security.php on line 831
[13-Oct-2020 07:00:52 America/New_York] PHP Warning:  in_array() expects parameter 2 to be array, null given in /home/freeadzf/public_html/Sources/Security.php on line 831
[13-Oct-2020 07:00:52 America/New_York] PHP Notice:  Undefined index: is_admin in /home/freeadzf/public_html/Sources/Security.php on line 824
[13-Oct-2020 07:00:52 America/New_York] PHP Notice:  Undefined index: permissions in /home/freeadzf/public_html/Sources/Security.php on line 831


Ends with a lot of these -

Code: [Select]

Oct-2020 07:00:54 America/New_York] PHP Notice:  Undefined index: time_offset in /home/freeadzf/public_html/Sources/Subs.php on line 861
[13-Oct-2020 07:00:54 America/New_York] PHP Notice:  Undefined index: time_format in /home/freeadzf/public_html/Sources/Subs.php on line 777
[13-Oct-2020 07:00:54 America/New_York] PHP Notice:  Undefined index: time_format in /home/freeadzf/public_html/Sources/Subs.php on line 778
[13-Oct-2020 07:00:54 America/New_York] PHP Notice:  Undefined index: time_format in /home/freeadzf/public_html/Sources/Subs.php on line 778
[13-Oct-2020 07:00:54 America/New_York] PHP Notice:  Undefined index: time_format in /home/freeadzf/public_html/Sources/Subs.php on line 780
[13-Oct-2020 07:00:54 America/New_York] PHP Notice:  Undefined index: time_format in /home/freeadzf/public_html/Sources/Subs.php on line 795


Server error_log was over 42 gb yesterday when they reported problems with the forum.  Deleted it last night, two error bursts since.  Forum is currently logging just a few errors, mostly from mods.  Any way to determine which scheduled task is causing this?
“The best laid schemes o' mice an' men / Gang aft a-gley.” - Robert Burns

Offline shawnb61

  • Dev. Team Mentor
  • Developer
  • SMF Hero
  • *
  • Posts: 3,119
    • sbulen on GitHub
Re: Error bursts
« Reply #1 on: October 13, 2020, 05:01:27 PM »
Hmmm...Don’t think I’ve seen those before.  Not sure they’re tied to scheduled tasks.

I would compare time stamps on the scheduled task log to the time stamps of the error.  I would also look closely at the web access logs during that time for the corresponding activity.
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 73,189
Re: Error bursts
« Reply #2 on: October 13, 2020, 05:02:21 PM »
Bet you it’s the daily notifications digest.
No good deed goes unpunished
All helpful urges should be circumvented

Offline Sir Osis of Liver

  • SMF Super Hero
  • *******
  • Posts: 10,949
  • We were all equal in the end.
Re: Error bursts
« Reply #3 on: October 13, 2020, 05:08:18 PM »
This is interesting -

Code: [Select]

Today at 07:00:54 AM
Type of error: Template
https://www.freeadzforum.com/index.php?topic=101043.0%27%29+AND+1%3D1+UNION+ALL+SELECT+1%2CNULL%2C%27%3Cscript%3Ealert%28%22XSS%22%29%3C%2Fscript%3E%27%2Ctable_name+FROM+information_schema.tables+WHERE+2%3E1--%2F%2A%2A%2F%3B+EXEC+xp_cmdshell%28%27cat+..%2F..%2F..%2Fetc%2Fpasswd%27%29%23
Apply Filter: Only show the errors with the same message
Unable to load the 'WIRELESS_PROTOCOL_above' template.


Today at 07:00:52 AM
Type of error: Database
https://www.freeadzforum.com/index.php?topic=101043.0%27%29+AND+1%3D1+UNION+ALL+SELECT+1%2CNULL%2C%27%3Cscript%3Ealert%28%22XSS%22%29%3C%2Fscript%3E%27%2Ctable_name+FROM+information_schema.tables+WHERE+2%3E1--%2F%2A%2A%2F%3B+EXEC+xp_cmdshell%28%27cat+..%2F..%2F..%2Fetc%2Fpasswd%27%29%23
Database Error: Table 'freeadzf_smf1.smf_pretty_topic_urls' doesn't exist
File: /home/freeadzf/public_html/Sources/QueryString.php
Line: 266


Pretty urls had been uninstalled at some point, but left a lot of code in QueryString.php.  Will see If I can clean it up.
“The best laid schemes o' mice an' men / Gang aft a-gley.” - Robert Burns