• Welcome to Simple Machines Community Forum. Please login or sign up.
October 15, 2021, 07:10:08 PM

News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord


Segnale di Errore dal Server

Started by apomtbpassion, April 07, 2011, 04:26:14 AM

Previous topic - Next topic

apomtbpassion

Periodicamente ricevo questo avviso quando mi collego al forum "Errore del server
Si è verificato un errore nel sito web durante il recupero di http://www.apomtbpassion.it/forum/. Potrebbe non essere disponibile per manutenzione o essere configurato in modo errato.
Ecco qualche suggerimento:
Carica di nuovo questa pagina web in un secondo momento.
Errore HTTP 500 (Internal Server Error): Si è verificata una condizione imprevista durante il tentativo del server di soddisfare la richiesta.
".......ma non riesco a capire dove stia il problema perche il sito mi funziona bene e non mi da mai questa seganalzione....

ho Smf 2.5
server Linux -Apache


Il problema è che dopo qualche tempo ricomincia a funzionare......

ho qualche settaggio sbagliato? o qualche mod puo influire?....

Grazie in anticipo

Darknico

é un errore del server, prova a contattare il tuo hosting e chiedere...
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


apomtbpassion

perfetto ti ringrazio e tiaggiornerò sull'esito ;)

emanuele

Quote from: apomtbpassion on April 07, 2011, 04:26:14 AM
ho Smf 2.5
Il problema è che sei troppo avanti nel futuro! :P

Scherzi a parte potrebbe anche essere un problema di permessi...


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

apomtbpassion

Emanuele hai ragione è che tra versioni mod ecc ricordarsi tutto è un impresa.....
....
dunque ho fatto presente il problema ai tecnici dell'host e mi hanno segnalato dal log questi errori che ne riporto solo alcune righe ma sono moltissimi.

[Wed Apr 06 10:50:35 2011] [warn] mod_fcgid: stderr: PHP Fatal error:  Function name must be a string in /var/www/vhosts/apomtbpassion.it/httpdocs/forum/Sources/BoardIndex.php on line 132

[Wed Apr 06 10:50:37 2011] [warn] mod_fcgid: stderr: PHP Fatal error:  Function name must be a string in /var/www/vhosts/apomtbpassion.it/httpdocs/forum/Sources/BoardIndex.php on line 132

[Wed Apr 06 11:03:20 2011] [warn] mod_fcgid: stderr: PHP Fatal error:  Function name must be a string in /var/www/vhosts/apomtbpassion.it/httpdocs/forum/Sources/BoardIndex.php on line 132

[Wed Apr 06 11:03:23 2011] [warn] mod_fcgid: stderr: PHP Fatal error:  Function name must be a string in /var/www/vhosts/apomtbpassion.it/httpdocs/forum/Sources/BoardIndex.php on line 132

[Wed Apr 06 11:03:27 2011] [warn] mod_fcgid: stderr: PHP Fatal error:  Function name must be a string in /var/www/vhosts/apomtbpassion.it/httpdocs/forum/Sources/BoardIndex.php on line 132


Purtorppo non sono un programmatore e non ne capisco....
Grazie
Arturo

emanuele

Guarda nel log degli errori del forum, ci dovrebbe essere qualcosa di simile, probabilmente lo stesso messaggio.

Ad ogni modo, quello indica che manca una funzione, perciò dovresti aprire il file boardindex.php, andare alla riga 132 e copiare qui la riga di codice, così ti possiamo dire cosa manca. ;)


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

apomtbpassion

April 08, 2011, 05:15:22 AM #6 Last Edit: April 08, 2011, 05:28:51 AM by emanuele
scusami ma non sapendo quale sia la linea 132 ( ma nel log di errori ce anche la 142) ti posto tutto il file:


Edit emanuele: non postare file interi così, se proprio vuoi mettere tutto, usa la funzione allegati.

emanuele

???
Questo è strano...non ha senso quel messaggio d'errore...o meglio se avesse senso dovresti avere errori anche in molte altre righe (tipo 157, 178, 188, ecc.).

Controlla nel log se ci sono altri "tipi" di errori (quindi diversi da "Function name must be a string") oppure lo stesso tipo di errore, ma in altri file.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

apomtbpassion

April 08, 2011, 05:48:33 AM #8 Last Edit: April 08, 2011, 05:55:30 AM by apomtbpassion
ho scaricato il file error log dal servere di errori ce ne sono diversi , solo che il file è di 18mb, intanto ti allego la prima pagina di registro errori del forum se può servire.....

emanuele

Che mod hai installato?
Il tema è quello di default? (sembrerebbe di sì, giusto per conferma)
Quante pagine di log di errori hai in SMF?


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

apomtbpassion

Quote from: emanuele on April 08, 2011, 06:11:22 AM
Che mod hai installato?
Il tema è quello di default? (sembrerebbe di sì, giusto per conferma)
Quante pagine di log di errori hai in SMF?
questo il forum: www.apomtbpassion.it/forum
ho circa 300 pagine di errori..il tema è quello di default.le mod sono
   Tabbed smileys    
2.    Profile Statuses    
3.    Menu_Icons    1.0    
4.    Social Bookmarks    2.0    
5.    Join date and Location in Posts    1.1    
6.    Referrals System    3.0.2    
7.    Adk Blog    1.0.3    
8.    Advanced Reputation System    1.8.3    
9.    Google Member Map    2.0.7    
10.    AjaxChat Integration    3.2.1 (modified for SMF 2 RC3)    
11.    PingThis SMF Mod    2.0
12.    Aeva Media    1.4c    
13.    Ad Managment    3.0    
14.    Stop Spammer

emanuele

April 08, 2011, 05:25:34 PM #11 Last Edit: April 08, 2011, 05:34:48 PM by emanuele
...va beh.

Allega il file load.php, voglio capire l'errore Undefined index: default_theme_url e theme_url.

Domanda aggiuntiva: l'errore "undefined variable: smcfunc" viene riportato solo per gli utenti loggati, solo per quello specfico utente, per tutti?
Ammetto di essere abbastanza confuso...


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

apomtbpassion

April 12, 2011, 07:38:54 AM #12 Last Edit: April 12, 2011, 07:55:18 AM by apomtbpassion
non trovo il file Load.php, in quale cartella dovrebbe essere?


anzi..il file proprio non c'e' nelle cartelle salvate nel server

emanuele

Deve esserci, se non ci fosse Load.php non funzionerebbe nulla. ;)
Si trova in /Sources/


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

apomtbpassion

scusa il mio impedimento  :)


eccolo

emanuele

Tranquillo, nessun problema. ;)

Comunque la prossima volta allega il file tal quale, non è necessario copiarlo in un file di word, anzi è controproducente farlo. ;)


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

emanuele

La prima impressione che ho è che c'è un qualche errore nelle impostazioni delle directory dei temi.

Prova ad usare repair_settings per vedere se ci sono problemi.
Se non ce ne fossero e/o stai usando un tema diverso da quello di default (non mi pare, ma meglio scriverlo :P), vai in admin > configurazione > temi e layout > impostazioni temi e controlla che i percorsi dei temi siano tutti corretti.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

apomtbpassion


emanuele

C'era qualcosa di sbagliato?

Questo potrebbe/dovrebbe toglierti qualche errore, ma difficilmente tutti...


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Advertisement: