• Welcome to Simple Machines Community Forum. Please login or sign up.
December 08, 2021, 01:02:05 AM

News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord


Board di reindirizzamento in nuova scheda

Started by Phoenixauto, October 15, 2011, 11:55:47 AM

Previous topic - Next topic

Phoenixauto

Ciao a tutti avrei bisogno di un'aiuto per cortesia a farsì che alcune board che utilizzo come reinderizzamento verso altri mi aprisserero una nuova finestra e non utilizzassero la stessa uscendo dal forum nostro.. qualcuno sa dirmi dove inserire quel piccolo codice se non ricordo male "blanck" e qualcosa d'altro da inserire prima del link.. non so se sono riuscito a farmi capire...  ???

emanuele

In BoardIndex.template.php, cerca:
<a class="subject" href="', $board['href'], '" name="b', $board['id'], '">', $board['name'], '</a>';

e sostituiscilo con:
<a class="subject" ', $board['is_redirect'] ? 'target="_blank"' : '', 'href="', $board['href'], '" name="b', $board['id'], '">', $board['name'], '</a>';


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Phoenixauto

Ciao Emanuele grazie per l'aiuto, ma non trovo quella parte del codice in quel file.. stiamo parlando di smf 2.0 vero?

emanuele

Sì, tema di default.
A meno che hai fatto modifiche ci deve essere.
Eventualmente, guarda nel file originale del tema di default (scarica un nuovo pacchetto se non ce l'hai più) per avere un'idea di dove si trova. ;)

Altrimenti puoi anche cercare solo per $board['href'] e vedere se trovi qualcosa di simile.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Phoenixauto

Potrebbe essere questo?
// Is it a redirection board?
//if ($board['is_redirect'])
//echo '<img src="', $settings['images_url'], '/redirect.png" alt="*" title="*" border="0" />';


echo '</a>
</td>
<td class="windowbg2 info">
               <b><a href="', $board['href'], '" name="b', $board['id'], '">', $board['name'], '</a></b>';


è in Boardindex.template.php

emanuele

Sì, è proprio l'ultima riga che hai postato. ;)


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Phoenixauto

Mmmm c'è qualcosa in più e qualcosa in meno mi sa che faccio casini...
devo sostituire in questa maniera? da così:
<b><a href="', $board['href'], '" name="b', $board['id'], '">', $board['name'], '</a></b>';

a così?

<b>class="subject" href="', $board['href'], "', $board['href'], '" name="b', $board['id'], '">', $board['name'], '</a></b>';
scusa l'imbranataggine ma per me sto mondo è piuttosto ostile..  :D

emanuele

<b><a href="', $board['href'], '" name="b', $board['id'], '">', $board['name'], '</a></b>';

a così

<b><a target="_blank" href="', $board['href'], "', $board['href'], '" name="b', $board['id'], '">', $board['name'], '</a></b>';

;)


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Phoenixauto

Non è che c'è qualche errore? perchè quando inserisco la stringa da te indicata mi cambia anche alcune stringhe sotto..
Ti trascrivo quelle sotto..
// Is it a redirection board?
//if ($board['is_redirect'])
//echo '<img src="', $settings['images_url'], '/redirect.png" alt="*" title="*" border="0" />';


echo '</a>
</td>
<td class="windowbg2 info">
               <b><a href="', $board['href'], '" name="b', $board['id'], '">', $board['name'], '</a></b>';

// Has it outstanding posts for approval?
if ($board['can_approve_posts'] && ($board['unapproved_posts'] || $board['unapproved_topics']))
echo '
<a href="', $scripturl, '?action=moderate;area=postmod;sa=', ($board['unapproved_topics'] > 0 ? 'topics' : 'posts'), ';brd=', $board['id'], ';', $context['session_var'], '=', $context['session_id'], '" title="', sprintf($txt['unapproved_posts'], $board['unapproved_topics'], $board['unapproved_posts']), '" class="moderation_link">(!)</a>';

echo '

<p>', $board['description'] , '</p>';

emanuele



Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Phoenixauto

Ciao scusa se non mi sono più fatto sentire ma avevo parecchie cose da sistemare... tornando a noi ti post copia del file.. se provi a fare la sostituzione mi ritrovo che ad esempio la stringa // Has it outstanding posts for approval? diventa rossa da prima che era gialla e altre parole subito sotto diventano rosse da nere... scusate la niubbaggine ma non ho molta confidenza, magari non è nulla o magari c'è qualche sbaglio che mi crea questo combiamento..  :)

emanuele

Ah...sì, scusa c'è un errore:
<b><a target="_blank" href="', $board['href'], '" name="b', $board['id'], '">', $board['name'], '</a></b>';
avevo copiato un po' troppa roba... :)


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

pauless

ciao, ho provato anche io questa cosa, ma non mi funziona,
ho cercato la riga su BoardIndex e l'ho sostituita con quella suggerita da te,
poi continuando a leggere il topic ho notato che la riga che avevi messo
era troppo lunga e l'ho sostituita con la nuova riga che hai postato
ma non funziona lo stesso, non fa il redirect su nuova scheda.

emanuele

Non è che stai usando un tema che ha un boardindex custom?
In tal caso le modifiche le devi apportare al file nella directory del tuo tema.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

pauless

E no perchè il file BoardIndex lo raggiungo
direttamente dal pannello di amministrazione del forum
andando direttamente su "Tema corrente",
che nel mio caso è Flux.

pauless

A no no no no, scusa,
in realtà qualcosa è cambiato, non me ne ero accorto
perchè non era il cambiamento che mi aspettavo,
ti spiego:

adesso mi si apre una scheda nuova per ogni sezione che clicco,
ma questa regola vale solo per le sezioni, non per le sottosezioni..

in realtà io pensavo che valesse solo per i link a siti esterni,
perchè ho la necessità di aprire una nuova scheda
per il reindirizzamento di una sezione a link esterno,
che sarebbe quella del Regolamento del forum..

dai un'occhiata
http://birraepatatine.altervista.org/

emanuele

Posta esattamente il codice come l'hai cambiato.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

pauless

// No new posts at all! The agony!!
            else
               echo '
                     <img src="', $settings['images_url'], '/', $context['theme_variant_url'], 'off.png" alt="', $txt['old_posts'], '" title="', $txt['old_posts'], '" />';

            echo '
                  </a>
               </td>
               <td class="info windowbg6">
                <b><a target="_blank" href="', $board['href'], '" name="b', $board['id'], '">', $board['name'], '</a></b>';

emanuele

// No new posts at all! The agony!!
            else
               echo '
                     <img src="', $settings['images_url'], '/', $context['theme_variant_url'], 'off.png" alt="', $txt['old_posts'], '" title="', $txt['old_posts'], '" />';

            echo '
                  </a>
               </td>
               <td class="info windowbg6">
                <b><a ', $board['is_redirect'] ? 'target="_blank" ' : '', "href="', $board['href'], '" name="b', $board['id'], '">', $board['name'], '</a></b>';


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

pauless

QuoteIl file che hai tentato di salvare ha generato il seguente errore:
Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING, expecting ',' or ';' in BoardIndex.template.php on line 163

Advertisement: