• Welcome to Simple Machines Community Forum. Please login or sign up.
December 04, 2021, 01:07:34 AM

News:

SMF 2.0.18 has been released! Please update. Read more.


How to change the default sorting of posts?

Started by rubix123, November 03, 2011, 02:27:22 AM

Previous topic - Next topic

rubix123

When I go to my forum it sorts posts automatically in ascending order. If I click on "Last Post" to change it to descending, it will only stay until you click a thread... If you click a thread and go back to the forum, it will be set back to the wrong setting.

ziycon

Go to 'Profile > Look and Layout Preferences' and un-tick or tick it depending on they way you require posts to display 'Show most recent posts at the top.'.

rubix123

Ok thanks for the reply. Is that what the default is set to for all accounts created on the forum? If it is, how can I change it?.. Because now the latest post is put on the last page of the board..... I want it on the 1st page like a normal forum :/

Illori

Admin -> Current Theme -> Member Options -> Change current options for all members using this theme
Admin -> Current Theme -> Member Options -> Configure guest and new user options for this theme

rubix123

The option "Show most recent posts at the top." sets posts inside of threads to be at the top. My problem is that threads with the latest reply of any other thread gets put on the last page of the forum. The oldest thread in that forum category is on the first page at the top. I have clicked "Last Post" to change the sorting order but it will just change back after I leave the page.

Illori

there is no option to change that, and it should not be happening that way as they are basically sorted by date.

rubix123

November 05, 2011, 07:17:09 AM #6 Last Edit: November 05, 2011, 07:20:52 AM by rubix123
I think I fixed it. could you check this link please? Its the off topic section for my forum.. you don't need to be logged in to view it.

http://metal-mecca.com/index.php?PHPSESSID=eb01a2813d2f87e8f6fb2d9089ed4c29&board=5.0

Illori

the threads "on top" are from november 3, so it looks fine to me.

rubix123

Ok yes I updated my last post too late, but anyways .. I fixed it. Thanks all for your help I will mark this as solved :D

Advertisement: