• Welcome to Simple Machines Community Forum. Please login or sign up.
November 27, 2021, 07:27:23 PM

News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord


2.0.1: 'Your attachment couldn't be saved'

Started by R6, November 04, 2011, 07:58:08 PM

Previous topic - Next topic

R6

November 04, 2011, 07:58:08 PM Last Edit: November 04, 2011, 08:02:40 PM by R6
Hi guys, I'm having problems uploading attachments and would appreciate any ideas on the following error in SMF 2.0.1, please.
The file I am trying to upload is a tiny 27k jpeg, so it's not a size issue...for once.

The problem:

Quote
An Error Has Occurred!

Your attachment couldn't be saved. This might happen because it took too long to upload or the file is bigger than the server will allow.

Please consult your server administrator for more information.

Description of my SMF attachment settings in 2.0.1

Adminstration Centre
Attachments and Avatars
Attachments settings:

Attachments directory: user\htdocs\forum/attachments
Attachments mode: Enable all attachments.
Check Attachment extensions: unticked.
Allowed attachment extensions: doc,gif,jpg,mpg,pdf,png,txt,zip
Max attachment folder space: 10240 Kb
Max attachment size per post: 192 Kb
Max size per attachment: 128 kb
Max number of attachments per post: 4
Re-Encode potentially damaging dangerous image attachments: ticked
Perform extensive security checks on uploaded image attachments: unticked


I went into my FTP to have a look in the SMF forum folders:

myurl/htdocs/forum/attachments

Right clicking the yellow folder 'attachments' (not the individual files within the folder) I tried to change the files permissions for the folder which is set to  700. I got this response on the FTP software programme:

CHMOD 700

Command:   SITE CHMOD 755 attachments
Response:   550 Could not change perms on attachments: No such file or directory

Also tried 775 with the same response.

It's strange it doesn't work for attachments because  I can upload a 'Profile Picture' fine.
I looked at the file permissions in that folder and they are set to 700 too, so I don't understand why attachments won't work as it makes no sense.

This is probably silly, but I saw that there's  forward and a backslash in the SMF route to the attachments directory, and I wondered if that was the problem?
e.g. user\htdocs\forum/attachments

?

Thank you for any help.
:D

Illori

i would suggest you contact your host about that error message and see what they say.

R6


Advertisement: