• Welcome to Simple Machines Community Forum. Please login or sign up.
September 20, 2021, 10:18:29 PM

News:

Check out the SMF Function DB!


smilies not posting

Started by lillieh, December 24, 2011, 11:14:04 PM

Previous topic - Next topic

lillieh

Another problem...

On my posting forms, the smilies and other buttons (such as insert hyperlink, etc.) are not showing up in the post form when they are clicked on.  The smilies themselves are showing up, but when you click on them to insert, nothing happens and a javascript(0) error appears down in the bottom left corner.

This has to be related to the recent host change - any ideas?

www.adultadoptees.org/forum

Skhilled

Whenever you change hosting you must reset your URL, etc. by using repair_settings.php. If that does not fix it then go into admin settings and make sure that the paths for the smilies, etc. are correct. You will also want to make sure that if your site is supposed to have "www." in front of it (or not have it) that it has the same in Server Settings.

lillieh

I don't understand how that works - can you please explain how to use it, as if you were speaking to a 3 year old?   :P

I uploaded it to my forum directory, opened the site in my browser, but all I saw was the site the way it typically looks with a big red warning saying
Quote!!You have not removed repair_settings.php/  Major security risk!

I don't see any place on the forum where I can change any settings, just that warning box.  And all the other error messages are still there and the smilies sill don't post.

Please explain how to use this, thanks!

Skhilled

Sorry, long distance phone call... Meant to add that you need to run http://www.yourforum.com/repair_settings.php after you upload it. When you are finished adjusting the settings you should delete it. You can put your forum into "Forum Maintenance" while you do this so no one can see that blaring warning notice. LOL

Illori

the warning is only shown to admin not to general users.

lillieh

Quote from: Skhilled on December 25, 2011, 12:06:14 PM
Sorry, long distance phone call... Meant to add that you need to run http://www.yourforum.com/repair_settings.php after you upload it. When you are finished adjusting the settings you should delete it. You can put your forum into "Forum Maintenance" while you do this so no one can see that blaring warning notice. LOL

That link is taking me to some online education site...

Skhilled

"yourforum.com" should be the actual URL for your website.

lillieh

Ok, got it! THANK YOU THANK YOU!!! :) :) :)

It repaired the "directory is incorrect" message I was getting at the top, now my themes work much better.

But the smilies and buttons such as "insert quote" or "insert hyperlink" etc. are still not working.  They all show up, but when I click on them, nothing shows up in the post box.  Any ideas?  It seems to be a problem with all members, not just me, so I don't think it's a browser issue.  That "javascript(0)" error comes up in the bottom left corner still.

Any ideas?

Skhilled

Repair_settings.php does not always reset the path correctly for smileys, message icons, attachments and avatars on some servers for some reason. You may need to go to Admin -> Forum -> Smiley and Message Icons -> Settings and set the path correctly. Also, go to Admin -> Forum -> Attachments and Avatars and check the settings for those as well and make sure the path is correct.

lillieh

It appears they are correct.  I tried deleting and re-uploading the smilies, didn't work.  Still that javascript error.  :-[

Illori

then try uploading the js files in your themes again.

lillieh

Where do I find those and how do I do that?

Illori

can you provide a link to your forum? then we can tell you more, also a test account might help.

lillieh

www.adultadoptees.org/forum

I'll PM you the test account details; should I give you admin status?

Illori

i asked you to post the details not pm and i did not ask for you to give admin access.

dont pm unless requested

lillieh

I don't want the details out here for the world to see. 

If you don't want to help, I'm sure somebody else can.  Thanks for your time.

Illori

it is better to post it for all to see so that everyone has a chance to help you.

Advertisement: