Add & Create Social Media Icons To Profiles

Started by hcfwesker, January 30, 2012, 10:06:52 AM

Previous topic - Next topic

hcfwesker

Yes, it may have given an error cause I re-added the original package just in case of uninstall errors and users may have need the parse page for uninstalling the first version.  It lagged a little while saving, but glad to see you got it downloaded.

the 1.0.1 is a much cleaner install than the first 1.0 package :)

fungku

Contractor and Tool Man

hcfwesker

Quote from: fungku on February 01, 2012, 01:04:05 AM
excellent

No problem.  :)

And, I didn't have a proper image ready.  There is a G+ image, but not cropped well.  attached below is 2 to chose from and both align with the other SMI icons much better.  I'll have the cleaner image in the next update.

rickmastfan67

Nice mod, however, I'm having trouble getting 1.0.1 to work.  I just installed a 2.0.2 forum and noticed you addon and installed it.  Installing didn't cause any problems or throw up any errors, however, I got an error whenever I tried to go to my profile page.

Database Error
Unknown column 'mem.deviantart' in 'field list'
File: /*****/********/***********/****/smf2/Sources/Load.php
Line: 1005


Don't know if this is a problem with how my forum is setup, or you missed something with making the 1.0.1 version.

Just thought I would let you know.

Also, I just tried to install 1.0, and that works perfectly fine for my forum.

hcfwesker

#24
Quote from: rickmastfan67 on February 01, 2012, 07:01:12 AM
Nice mod, however, I'm having trouble getting 1.0.1 to work.  I just installed a 2.0.2 forum and noticed you addon and installed it.  Installing didn't cause any problems or throw up any errors, however, I got an error whenever I tried to go to my profile page.

Database Error
Unknown column 'mem.deviantart' in 'field list'
File: /*****/********/***********/****/smf2/Sources/Load.php
Line: 1005


Don't know if this is a problem with how my forum is setup, or you missed something with making the 1.0.1 version.

Just thought I would let you know.

Also, I just tried to install 1.0, and that works perfectly fine for my forum.

Yikes!  Thank you for the notice.   Was tiny typo in one of the lines, causing deviantart to be written over by googleplus in the database table.


Fixed package uploaded in v1.0.1.  Along with the cleaner Google+ image updated.

This error won't affect those who originally had v1.0 installed.  For those who first downloaded and used v1.0.1 , redownload the fixed package and replace it.


Kindred

had to manually apply the update of adding googleplus. :)  but it's on my mod test site. :)
Слова
Украина

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

hcfwesker

Any updates after v1.0.1 I plan on implementing the Upgrade element to future updates.  So if it's possible, you may want to update the newly applied v1.0.1 version :)   The 1.0 edits were kinda sloppy with before/after edits, 1.0.1 are all replace edits except for the language files.

I seen your post in Event Registration MOD about the 150+ MODs on test site.  :D  From what I recall, this one does throw errors on forums like that, but mostly directed in the mem. statements in Load.php

Kindred

well, I'll tackle that when it comes to it. lol...


However, I disagree with your choice to use replace instead of add-before/add-after

IMO, it is better to ALWAYS use add-before and add-after if you are not changing the original source... Replace should onyl be used when you are actually changing an original source line.
Слова
Украина

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

hcfwesker

Quote from: Kindred on February 01, 2012, 11:03:33 AMIMO, it is better to ALWAYS use add-before and add-after if you are not changing the original source... Replace should onyl be used when you are actually changing an original source line.

thank you, and noted!  However, when I tried to use the Upgrade element in the latest update, it added everything just fine, but when I wanted to uninstall the updated package as a whole, threw out too many errors.

So, I made sure to chose carefully which replace lines for statements that wouldn't be modified by other mods.    Lines like below, are replaced just as originally were, so adding after/before would have caused the same outcome.

// Show the profile, website, email address, and personal message buttons.

however, the mem. statements in Load.php are unavoidable due to so many MODs editing those lines.  But I'll take your advice

Matthew K.

There are usually ways of sneaking around using the commonly hacked lines, and even better ways of doing most edits that just take a minute of thought to find.

I do agree with Kindred though, only use replace when necessary.

Also - I would encourage you to make a new patch (1.0.2 for instance) if you fix something, it just helps people keep track of what's going on better, rather than updating the same version package with a bugfix. If no one has used it yet? Sure, fix it, and upload it. But if people have already started using it, I'd suggest adding a new 1 :)

hcfwesker

#30
I Fail at this!  :(

Next version I'll work back in the before/after edits, and once I get everything synced in properly, the Upgrade elements should be integrated easily as well.  I just think my first version was riddled with random spaces in between edits that added before/after coding, reason I got so many uninstall errors when trying to uninstall after the Upgrade version was tacked on.

And, I'll remember to upload fixes with newer versions.   I guess I was a little embarassed with so many mistakes this early on lol.  I'm a learning though.  slowly but surely.

My plan now is to rewrite this from scratch, including just the v1.0 edits, then work in and test the v1.0.1 upgrade version to it, and see how that pulls off.  Then release the entire thing in a 1.0.2 version, so it's prepped for updated versions.



Matthew K.

You're doing fine...trust me. Keep your head up dude. It's a learning process.

hcfwesker

#32
v1.0.2
Fixed bug with Google+ not being added to database
Completely revamped file edits in modification file
Removed unnecessary language edits for Ultimate Profile
Next update release will be Upgrade compatible.


Sorry for the frequent updates.  The new package is almost flawless and this is the version I wish was originally released.  I tested and re-tested and then tested some more.  File edits are perfectly added without line edits being distorted everywhere in the files.  ( I'm hoping all was fixed)

Plus i tested Upgrade elements and after a little trial and error I have it working now, and will be available in the NEXT update.


Matthew K.

You should get the award for updating one mod the most :P

Fed Drago

Hello there great Mod Would it be possible to add a Skype link in your next Upgrade?

Cheers

Fed

hcfwesker

#35
Quote from: Fed Drago on February 02, 2012, 07:45:51 AM
Hello there great Mod Would it be possible to add a Skype link in your next Upgrade?

Problem is that Skype doesn't exactly belong in this category.  But the edits used in this MOD are almost the exact same for adding Instant Messengers, so it wouldn't be too tough of a task.   And with all the other Skype MODs out dated I suppose I could see about submitting an updated Skype MOD for SMF 2.0.x   Or make one that would add several IMs , like Skype, Google Talk, etc.  ( I really don't know what the new popular IMs are these days besides msn and skype)

hcfwesker

v1.0.3
Error fixed with Icons not displaying in Edit Buddies page with Ultimate Profiles installed.

To upgrade from v1.0.2 simply upload the v1.0.3 Package and install, no need to uninstall v1.0.2

Fed Drago

Quote from: hcfwesker on February 02, 2012, 03:44:41 PM
v1.0.3
Error fixed with Icons not displaying in Edit Buddies page with Ultimate Profiles installed.

To upgrade from v1.0.2 simply upload the v1.0.3 Package and install, no need to uninstall v1.0.2

Makes sense thank you for getting back to me.

hcfwesker

Quote from: Fed Drago on February 02, 2012, 05:30:30 PM
Makes sense thank you for getting back to me.

No problem. I'm working on the other MOD now. :)

Fed Drago

Quote from: hcfwesker on February 02, 2012, 05:45:41 PM
Quote from: Fed Drago on February 02, 2012, 05:30:30 PM
Makes sense thank you for getting back to me.

No problem. I'm working on the other MOD now. :)

I just installed this Mod and it is Fantastic thank you for it.

Cheers

Advertisement: