• Welcome to Simple Machines Community Forum. Please login or sign up.
January 26, 2022, 04:05:31 AM

News:

Wondering if this will always be free?  See why free is better.


Adk Blog (A blog system for each user)

Started by lucas-ruroken, August 30, 2010, 05:12:44 PM

Previous topic - Next topic

david090366

Is this mod playing nice with easyportal yet?

Apllicmz




Argon3000

Hello!

I have installed mod: Adk Blog 3.0 - Does not work.
http://custom.simplemachines.org/mods/index.php?mod=2611
---------
I set: SMF 2.0.13, PortaMx-SEF 1.54.

uninstall PortaMX - mod Adk Blog 3.0 WORK.
install PortaMX - mod Adk Blog 3.0 NOT WORK.
SEF Manager PortaMX ==> disable.
:(

Test Forum: http://qrz.center/test1/index.php?action=blogs [nofollow]
My blog ==> http://qrz.center/test1/index.php?blog=1 [nofollow] not work.   :(

---------
I have tried everything but I am obviously doing something wrong. 
In advance thank you.  (index.php - image)
SMF 2.0.15, PortaMx-SEF 1.54

ninik

Hi guys I have a question:

Although everything works fine in the forum, whenever someone logs in, or searches for a topic etc. I always get an error log, which is:

8: Undefined index: notify

I could locate the source of the problem in the following file:

forum/Sources/Subs-adkblog.php

in the following 2 lines:

Line: 61

Line: 63


In other words, all errors derive from these two lines.

The code of this part is the following:



'blog_notify' => array(
'title' => $txt['blog_not'].' <i>('.$context['notify'][1].')</i>',   <---- line 61
'href' => $scripturl.'?action=blog_notify',
'show' => $context['notify'][0],                                              <---- line 63
),
),
array_slice($buttons, $find_me)
);



Could anyone tell me how to resolve that issue?

Thank you in advance guys

Meanman

Hi i have this error Message body required is there a fix please.

Kindred

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

shadav

bug
in display.template.php
<li><a href="'.$scripturl.'?blog='.$message['member']['id'].'" title="'.$txt['blog_principal_title'].'"><img alt="" src="'.$boardurl.'/blog/easymoblog.png" /></a></li>
should be
<li><a href="'.$scripturl.'?blog='.$message['member']['id'].'" title="'.$txt['blog_principal_title'].'"><img alt="" src="'.$boardurl.'/blog/images/easymoblog.png" /></a></li>

captcha

I installed it on a new SMF 2.0.17 server. It is only package I installed.
But the blog can only be seen by administrator. No any other user or guest can see the "Blog" item.
Is there any permission need to be changed? I can not find any setting up for this package.

captcha

March 27, 2020, 08:22:05 AM #728 Last Edit: March 27, 2020, 08:37:14 AM by captcha
Quote from: captcha on March 26, 2020, 10:55:23 PM
I installed it on a new SMF 2.0.17 server. It is only package I installed.
But the blog can only be seen by administrator. No any other user or guest can see the "Blog" item.
Is there any permission need to be changed? I can not find any setting up for this package.
I mean there is no tab or link to "Blog" for guest and registered users, only Administrator can see the "Blog" tab.
The problem solved. I find how to change the setting to permit other users to view and create their blog. It is in the configuration.

Kindred

October 29, 2020, 06:33:03 PM #729 Last Edit: November 12, 2020, 11:21:43 AM by Kindred
Just FYI:


Installed into SMF 2.0.17 on PHP 7.3 and got errors.

Since I was looking at the code anyway, I have updated the Subs-adkblog file (in Sources) to fix the problem and the BlogFeatures.template,php fiule (in default theme directory) to get rid of the tables (and make it more mobile friendly)

As a note for anyone who wants to us this -- you should turn off the SMF WYSIWYG editor for this to work....
additional reminder: the edit to display.template.php is also needed

Quote from: shadav on August 30, 2019, 10:31:51 PM
bug
in display.template.php
<li><a href="'.$scripturl.'?blog='.$message['member']['id'].'" title="'.$txt['blog_principal_title'].'"><img alt="" src="'.$boardurl.'/blog/easymoblog.png" /></a></li>
should be
<li><a href="'.$scripturl.'?blog='.$message['member']['id'].'" title="'.$txt['blog_principal_title'].'"><img alt="" src="'.$boardurl.'/blog/images/easymoblog.png" /></a></li>

here's it working...
https://test.turtleshellprod.com/index.php?action=blogs



-11/12 edit - added a revised version of the template file since I realized that my original post had a bug in it that caused errors on every new blog post.
Additionally, have noted an issue when editing existing blog posts or comments --   line breaks get read into the editor as html <br/>. Think I know why but won't be able to fix until next week.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

njtweb

If anybody is using this, an you post a link to your site so I can see what it looks like?

Kindred

Did you not read the post with the link just above??
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

shadav

I know this is old, sorry but is there a way to hide the blog button/icon in display.template.php if the user hasn't created a blog
tried searching the thread but didn't find an answer

and thanks kindred ;) I snagged your updated files

Diego Andrés

Not without adding an additional query per user probably not  :P
Unless you add a new column to the members table with the number of blogs

SMF Tricks - Free & Premium Responsive Themes for SMF.

shadav

figures  :P was worth asking....
wishful thinking it was something simple I just wasn't seeing

Mike66

Hi folks

Once installed, would it be possible to set this up as a single blog post with comments/replies shown as the most recent comment/reply first?

So, in effect, a kind of 'timeline'  ;)

I love the way SMF boards/topics/replies are structured and certainly wouldn't want to change a thing, but it would be nice if we could have one 'timeline' like topic somewhere.

I'm simply thinking about a single topic (blog post?) which stays at the top (as an intro) followed by comments/replies displayed in order of the most recent first. Maybe somebody has found another way of doing this?

Cheers
Mike

Aleksi "Lex" Kilpinen

For a vanilla SMF, I'd try First Post on Every Page for repeating the OP on each page, and the post order can be reversed by default through SMF settings.
I say vanilla, because I have no idea how Adk blog actually works and I'm unsure if this would work in combination with it or not.
A Finnish Project Manager (Support Specialist)
 Happily running multiple SMF 2.x installations.
  Fooling around with i7-10700 @ 2,90GHz-4.80GHz / 16Gb / RTX-2070 Super / 3840x2160 / Win 10 x64


How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum. Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Advertisement: