• Welcome to Simple Machines Community Forum. Please login or sign up.
December 02, 2021, 08:09:54 PM

News:

Follow SMF on Twitter.


Help - All users are admins!

Started by therealkickers, April 11, 2012, 01:35:34 PM

Previous topic - Next topic

therealkickers

April 11, 2012, 01:35:34 PM Last Edit: April 11, 2012, 04:00:05 PM by therealkickers
Hi again!

Sorry I forgot each user should have his own topic about an issue, so here's mine:

We went online with our new forum yesterday and today I drown in requests to hide email adresses and IP adresses from the users profile pages. Even if I'm sure this has to be easy to solve, I can't seem to find that option. Either it needs to be globally hidable by admins or in the profile setup from each user.

Any hint highly appreciated, because every new member thinks he found out first and sends a pm.... You know.

Thanks,
Christoph

OMG - I guess we have a bigger issue - None of our restrictions seem to apply to the standard user group. All members can delete postings and other people's profiles, they can ban members and create user groups.

What the heck! In the admin panel all rights are set correct.
HELP!

Jakob Fel

Wait, so you're saying normal users and guests can see their emails and IPs, even if they set it so no one else could see their email?

Because normally, the users themselves and mods/admins can see their IPs and emails, but regular members cannot see the IPs at all. If the users set it so their email address is viewable, THEN other members could see it, but otherwise, they cannot. :)

Edit: I didn't see the last bit there at first. Did you double check to make sure that the permissions were set correctly? Also, did you maybe accidentally give certain users admin privileges as a secondary membergroup? You can find that by going into their profile, Modify, Account Settings.

If that wasn't what you were looking for, perhaps someone has a better idea. :)
Freelance writer, entrepreneur-in-training and DRM-free advocate
Support and Community Management at SMFNew Free Forum Hosting

therealkickers

Yes, I even triple checked  :(

I have created a test user and left him in the group "normal users".
When I login as admin and check this test users rights, e.g. at "delete postings" the box is not checked.

EDIT: Oh, in the upper bar of this section it says (sorry, my english) "rights that are not allowed are crossed out (written with a line through the words).
but none of the rights that are listed there is crossed out. Those which I didn't admit to the users are just missing the entry "admitted by" in the right column.
Is thatthe reason? How can I make them crossed out?

When I login as testuser, I can delete any posting in any forum, I can ban members and create and modify membergroups, I can even put myself (=the testuser) into the administrator group.

OMFG - and all this while about 900 users are trying to register. We have been testing the site and the forum for so long, but either we have not taken notice of this or it started happening yesterday when we went online.

No matter - I'm dying a brutal death at the moment.  :'(

Jakob Fel

You could put your site into maintenance mode for the time being. Admin > Server Settings > Enable Maintenance Mode > Check the box. :)
Freelance writer, entrepreneur-in-training and DRM-free advocate
Support and Community Management at SMFNew Free Forum Hosting

therealkickers

I did, thanks.

Just in case my English is too bad to understand my issue correctly, I have created a screenshot which shows how things look like.
the upper part shows that the rights are not checked, the lower part shows that they are not crossed out, but still the entry "admitted (or "granted"?) by" is blank.




therealkickers

Solved, thanks.

For some reason there had been a group based on number of postings (whereas we turned off the posting counter) which had been granted rights from a "near-admin" group. I don't have the slightest clue what made me select and then later oversee this, but hey - Done. Just some gallons of sweat to be swept into a bucket from under my desk.

Thanks!

Advertisement: