• Welcome to Simple Machines Community Forum. Please login or sign up.
October 25, 2021, 07:20:33 AM

News:

SMF 2.0.18 has been released! Please update. Read more.


script malevolo

Started by lachesi, November 16, 2012, 09:47:48 AM

Previous topic - Next topic

lachesi

Salve ragazzi eccomi qui con un nuovo problema: il  mio sito e forum smf ha subito un attacco ieri
e ora google mi ha bloccato le visite con messaggio sito malevolo. Da ieri che sto impazzendo
purtroppo non ho un bkp recentissimo. che posso fare? se faccio un updateaòòa versione 2 risolvo?

emanuele

Beh, due opzioni:
1) cercare. "Cosa" (e come) dipende dal malware.
2) usare ad esempio un large upgrade e sovrascrivere tutti i file (o meglio ancora sarebbe cancellare le directory "Sources" e "Themes" e poi caricare i file del large upgrade (dettagli a richiesta)). Questo ovviamente rimuove tutti i mod...
L'upgrade è simile alla seconda opzione.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

lachesi

Ciao Emanule dopo un controllo a tutti i file php sono riuscito a togliere lo script malevolo era ovunque.
Adesso però il forum non riesce a fare né nuovi topic ne reply
Esce una pagina bianca

emanuele

Probabilmente togliendolo hai introdotto qualche errore di sintassi...
Se è nel creare topic/post può essere in Post.php, Subs-Post.php, Poll.php...o qualche altro, inizia a guardare questi.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

lachesi

Nulla da fare ho provato a controllare i file ma non si riesce ne a fare topic, post,reply e quote nulla soluzioni aiutini''

emanuele

Come hai controllato i file?

Senza poterci mettere le mani dentro (o senza almeno sapere l'indirizzo del forum) le uniche due cose che posso suggerirti sono:
1) controlla i permessi dei file (magari hai modificato qualcosa accidentalmente),
2) ricontrolla tutti i file che hai modificato che non abbiano errori di sintassi.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

lachesi

Ciao una vota ti feci un account sul mio forum

www.wordigital.com7forum

emanuele

Possibile, ma ormai ne ho in giro così tanti di account che ho perso il conto... ;)

Ad ogni modo, altra cosa: non è che nel log degli errori c'è qualcosa?


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

lachesi

Quote from: emanuele on November 18, 2012, 02:50:08 PM
Come hai controllato i file?

Senza poterci mettere le mani dentro (o senza almeno sapere l'indirizzo del forum) le uniche due cose che posso suggerirti sono:
1) controlla i permessi dei file (magari hai modificato qualcosa accidentalmente),
2) ricontrolla tutti i file che hai modificato che non abbiano errori di sintassi.
La situazione e molto strana ho fatto l'upgrade (e andato tutto a buon fine) alla versione 2.0.2 ma e uguale non riesco a fare post reply quote nulla.
che può essere'

emanuele

Il problema è (almeno) in Subs-Post.php.

Controlla i permessi e/o rimpiazza il file.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

lachesi

Ho fatto di piu istallazione da zero di sfm e senza caricare i file del dabase per curiosità ho provato a fare un post a forum vergine risultato sempre uguale ma come e possibile'?    :-[

emanuele

Prova a riscaricare il pacchettod'installazione, da quel che ho visto ieri sera il file Subs-Post.php è o corrotto o ha permessi sbagliati. Come faccio a dirlo? Accedendo a http://www.wordigital.com/forum/Sources/Subs-Post.php ottengo una pagina bianca, quando invece dovrei vedere la scritta "hacking attempt..." come succede con ogni altro file.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

lachesi

Ciao Emanuele scusami ma succedono tutte a me sono stato una settimana senza adsl.
ho fatto altre prove e non manda neanche pm. ora che sono online pulisco tutta la cartella forum e reistallo da capo smf pulito senza nulla e da li provo a fare ost e altro. poi ti mndo i dati x il tuo account. Grazie ancora per la tua gentilezza e disponobilità

lachesi

Allora ho istallato smf in una cartella pulita diversa istallo tutto ma il risultato e sempre uguale ne post reply quote èm nulla
ora ho aperto un tiket vediamo che mi dicono da netsons

lachesi

Come dicevo sopra ho fatto nuova istallazione di smf (qui: http://wordigital.com/board) nuovo database dovrei poter fare nuovi post reply..
invece nulla 

emanuele

Nuovo database non vuol dire niente.

Il problema è dell'host.
Per qualche ragione non accetta il post di dati.
Hai per caso impostato qualcosa in htaccess?
Io contatterei l'host e chiederei lumi.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

lachesi

No il file htaccess non lo ho toccato. non posso fare neanche nuove registrazioni.
Infatti ho aperto un tiket in assistenza

emanuele

Lo so.
Con "post di dati" intendo l'invio di una qualunque forum: sia essa la registrazione, il salvare un'impostazione, lo scrivere un messaggio, il loggarsi e via dicendo.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

lachesi

ho risolto mettendo un bkp di un mese fà grazie a tutti

Advertisement: