• Welcome to Simple Machines Community Forum. Please login or sign up.

Intégration du forum dans une page web

Started by 0Connors, October 05, 2013, 12:32:24 PM

Previous topic - Next topic

0Connors

Bonjour à tous,

J'ai recensement lancé mon nouveau site : http://pafteam.com/forum/index.php,  avec une intégration du forum dans mon site (Via index.template.php de mon thème) seulement lorsque j'utilise un lien vers une section de mon forum (Board) mon CSS n'est pas appliqué.

Par exemple sur cette page : http://pafteam.com/gro.php si vous cliquez sur le bouton "nous rejoindre" vous verrai ma page déconne.... Je ne comprends pas pourquoi...

Quelqu'un aurai une idée/solution ?

En vous remerciant,
Site : www.pafteam.com

Projet : www.pafteam.com/beta-test/maj-site/

Version SMF : 2.0.9

maximus23

Bonjour,

Tu n'as pas fait une double déclaration de ta fonction d'appel de ssi ?

Regarde l'erreur qui est indiquée au dessus de ta page et revérifie ton code :)

Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

0Connors

October 05, 2013, 04:20:35 PM #2 Last Edit: October 05, 2013, 04:37:42 PM by 0Connors
Salut maximus,

L'erreur est résolu j'avais mal placé mes fichiers, merci quand même pour l'aide cependant, j'ai une nouvelle erreur au lancement du site...

Voir l'erreur en pièce jointe, par contre l'erreur ne se présente qu'une seule fois aprés le rafraîchissement de la page ça ne ce passe plus...  ???

Mais c'est moyen pour les nouveaux arrivant :(

Merci encore,  ;)
Site : www.pafteam.com

Projet : www.pafteam.com/beta-test/maj-site/

Version SMF : 2.0.9

maximus23

Bonjour,

Ma réponse ci-dessus faisait bien allusion à cette erreur.

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

0Connors

Ah donc un doublons de déclaration de mon SSI ...  :o mais il n'y est bien qu'une fois sur ma page :(

Je t'ai mis en Pièce jointe mon fichier Index.php qui corresponde à ma page principale.

En te remerciant,
Site : www.pafteam.com

Projet : www.pafteam.com/beta-test/maj-site/

Version SMF : 2.0.9

maximus23

Bonsoir,

Je regarderai ce week-end car ici j'ai rien sous la main pour le faire :)

Mais apparemment c'est dans le fichier detect.free que se trouve l'erreur :)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

0Connors

D'accord, veux tu que je te donne les accés à mon FTP, pour regarder plus profondément ? ???

En te remerciant,
Site : www.pafteam.com

Projet : www.pafteam.com/beta-test/maj-site/

Version SMF : 2.0.9

0Connors

Tu voulais plutôt dire la semaine prochaine non ?  ???

C'est pas que je suis préssé mais je suis coincé et ce genre d'erreur sur mon site ça fait tâche :(. Surtout que c'est apparu simplement en mettant mes pages dans la racine de mon site.  :-[

En te remerciant,
Site : www.pafteam.com

Projet : www.pafteam.com/beta-test/maj-site/

Version SMF : 2.0.9

maximus23

Bonjour,

Tu as toujours les deux SSI pour faire fonctionner ton site ? Car il ne devrait en rester qu'un seul avec ton nouveau site le SSI original de Smf soit SSI.php.
:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

0Connors

Oui c'est ça, mais comment je peux faire sachant que tu avais modifier un truc sur l'encodage ?  ???
Site : www.pafteam.com

Projet : www.pafteam.com/beta-test/maj-site/

Version SMF : 2.0.9

maximus23

Bonjour,

Le tout est de savoir si avec ton nouveau site tu as toujours besoin de la modification que j'avais faite ?
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

0Connors

Non, c'étais pour le PhpRaider mais nous ne nous en servons plus.  :-\
Site : www.pafteam.com

Projet : www.pafteam.com/beta-test/maj-site/

Version SMF : 2.0.9

maximus23

Bonjour,

Alors tu dois tout regrouper sur un seul SSI et tout ira pour le mieux :)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

0Connors

J'efface le SSI_ORG ? Comment je fais, à la base j'avais mis les modifications sur les deux pour évité le souci.

J'ai du mal à visualiser la procédure à suivre, tu pourrai m'éclairé ?

En te remerciant,  ;)
Site : www.pafteam.com

Projet : www.pafteam.com/beta-test/maj-site/

Version SMF : 2.0.9

maximus23

Bonsoir,

Tu dois tout regrouper tes modifications sur le SSI principal de Smf qui est bien entendu SSI.php n'oublie pas de modifier ton appel au SSI par SSI.php et de supprimer tout les autres appels de l'ancien SSI. Donc tout regrouper correctement et cela fonctionnera sans soucis.

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

0Connors

October 06, 2013, 04:17:05 PM #15 Last Edit: October 08, 2013, 02:09:51 AM by maximus23
Ok, merci je vais essayé. Du coup je les enlèves bien de mon SSI_ORG.php c'est bien ça ?

En te remerciant,

EDIT: Je viens d'essayer ce que tu ma conseillé en utilisant que le SSI.php et tout foire au niveau de l'encodage et certaines choses disparaissent... J'ai mis mes 2 fichiers PHP que j'utilise en plus des deux originaux (.older), si tu veux jeter un œil au problème j'ai aussi mis une capture d'écrans du souci.
Site : www.pafteam.com

Projet : www.pafteam.com/beta-test/maj-site/

Version SMF : 2.0.9

maximus23

Bonjour,

Là tu as un mélange de l'utf8 et de l' Iso. Remets moi en Pm les accès ftp je regarderai ce que je peux faire dès que j'aurai un moment ce qui n'est guère facile de ces temps-ci.
:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

0Connors

Bonjour,

Je t'ai tout envoyé, je te remercie encore pour ton aide.  ;D
Site : www.pafteam.com

Projet : www.pafteam.com/beta-test/maj-site/

Version SMF : 2.0.9

maximus23

Bonjour,

Le fichier DetectFree.php vient de quel mod ?

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

0Connors

Je ne sais pas du tout voici la liste de mes mods :

Simple Gravatar    21.09.2012     [ Désinstaller ] [ Lister les fichiers ] [ Effacer ]
2.   Simple ImageShack    3.1.3     [ Désinstaller ] [ Lister les fichiers ] [ Effacer ]
3.   SMF Topic Prefix Mod    1.2.2     [ Désinstaller ] [ Lister les fichiers ] [ Effacer ]
4.   Personal Messages to Membergroups    1.4.3     [ Lister les fichiers ] [ Effacer ]
5.   WoW - World of Warcraft Tooltips    1.4     [ Désinstaller ] [ Lister les fichiers ] [ Effacer ]
6.   Member Color Link    3.1     [ Lister les fichiers ] [ Effacer ]
7.   AjaxChat Integration    3.2.1 (modified for SMF 2 RC3)     [ Lister les fichiers ] [ Effacer ]
8.   Order Custom Profile Fields    1.1.1     [ Désinstaller ] [ Lister les fichiers ] [ Effacer ]
9.   SMF 2.0.5 Update    1.0     [ Désinstaller ] [ Lister les fichiers ] [ Effacer ]
10.   Table From CSV    1.30     [ Désinstaller ] [ Lister les fichiers ] [ Effacer ]
11.   SMF 2.0.3 Update    1.0     [ Lister les fichiers ] [ Effacer ]
12.   Enhanced PM Popup    1.0.1     [ Désinstaller ] [ Lister les fichiers ] [ Effacer ]
13.   Vimeo_bbc_code_Mod    1.0     [ Désinstaller ] [ Lister les fichiers ] [ Effacer ]
14.   Add Social Media Icons To Profiles    1.1.0     [ Désinstaller ] [ Lister les fichiers ] [ Effacer ]
15.   Auto Link Checker    1.0   [ Installer modification ] [ Lister les fichiers ] [ Effacer ]
16.   Default Avatar    1.1.1     [ Désinstaller ] [ Lister les fichiers ] [ Effacer ]
17.   SMF 2.0.2 Update    1.0     [ Lister les fichiers ] [ Effacer ]
18.   Gamer IDs    1.4     [ Désinstaller ] [ Lister les fichiers ] [ Effacer ]
19.   Images On Board    3.0     [ Désinstaller ] [ Lister les fichiers ] [ Effacer ]
20.   Spoiler BBCode    1.1.3     [ Désinstaller ] [ Lister les fichiers ] [ Effacer ]
21.   SimplePortal    2.3.5     [ Désinstaller ] [ Lister les fichiers ] [ Effacer ]
22.   Simple Menu Icons    1.0     [ Désinstaller ] [ Lister les fichiers ] [ Effacer ]
23.   SMF 2.0.4 Update    1.0     [ Lister les fichiers ] [ Effacer ]
24.   Adk Snow Effect    2.0     [ Désinstaller ] [ Lister les fichiers ] [ Effacer ]
25.   Aeva Media

J'ai listé tout les fichiers mais je n'ai rien trouvé, je savais meme pas que ça venais d'un mod  ???

PS : Tu as toujours le compte SMF d'actif au cas ou.
Site : www.pafteam.com

Projet : www.pafteam.com/beta-test/maj-site/

Version SMF : 2.0.9

maximus23

Bonjour,

C'est un fichier qui concerne les Iphones et je ne vois pas de mod à ce sujet ?
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

0Connors

J'ai supprimé le mod pourtant, c'étais un mod permettant d'avoir le forum au format Iphone, c'était celui la : SMF4iPhone Mod (http://custom.simplemachines.org/mods/index.php?mod=2408) il parle effectivement d'un "The mod uses the Movila Free Device Detection" ça doit être ça ?

Merci,
Site : www.pafteam.com

Projet : www.pafteam.com/beta-test/maj-site/

Version SMF : 2.0.9

maximus23

Bonjour,

Donc tu as oublié de désinstaller quelque chose il faut revoir le code complet en désinstallation.

Tu sais le faire ?
:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

0Connors

Euh, oui mais il ne me semble pas avoir vu d'erreur justement  ???.
Site : www.pafteam.com

Projet : www.pafteam.com/beta-test/maj-site/

Version SMF : 2.0.9

maximus23

Bonjour,

Tu as mal regardé car le fichier sus-mentionné est bien en appel de smf. Il faut tout revérifier de fond en comble pour irradiquer les erreurs restantes. Si tu n'en sort pas dis le je le ferai ce soir :)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

0Connors

October 07, 2013, 08:07:04 AM #25 Last Edit: October 07, 2013, 08:40:54 AM by 0Connors
Je regarde ça et je te tiens au courant, je te remercie.  ;)

EDIT: Je ne retrouve pas les fichiers qu'il modifie sur le mod... Je me souviens d'avoir émulé le forum en version 2.0 RC4, de plus j'ai retrouvé les options du mod dans la panneau de configuration comme si il n'étais pas désinstallé  :o

Là, je t'avoue que je suis surpris.  :(
Site : www.pafteam.com

Projet : www.pafteam.com/beta-test/maj-site/

Version SMF : 2.0.9

maximus23

Bonjour,

Ton mod n'est pas désinstallé du tout j'ai mis en commentaire la ligne d'appel du detectfree c'est dans le fichier Sources/load ligne 1701. Il faudrait désinstaller le tout ainsi que les modifications annexes que tu as du faire pour faire fonctionner ce mod. pour moi voir ce qui se passe je dois tout reprendre en local et rechercher tout les morceaux de code tu ne te rappelles plus de ce que tu as modifié ?

Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

0Connors

Modifier à quel a niveau au niveau du mod SMF4iphone ou sur l'intégralité des mods ?

Parce que pour le mod SMF4iphone, je me souviens que c'etais une histoire de thème spécifique détectable avec le déclencheur quand on utilise un Iphone mais j'ai jamais réussi à le faire fonctionné.

Il me semble avoir installé un thème que j'ai du supprimée aussi par la même occasion,

Sinon pour l'intégralité des mods, je me souviendrai jamais de tout, j'ai fais ça au fur et à mesure.  :(

Ça m'effarait un peu ce que tu me dis  :o, J'ai du faire une sauvegarde de la base il y a un mois, je sais pas si ça peut aider ?

En te remerciant pour ton temps,
Site : www.pafteam.com

Projet : www.pafteam.com/beta-test/maj-site/

Version SMF : 2.0.9

maximus23

Bonjour,

Tu as encore des erreurs vide ton cache et regarde ?

Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

0Connors

Effectivement, lorsque je relance mon navigateur je trouve l'erreur suivante :

Notice: SSI.php n'a pas pu charger une session ! Cela peut causer des problèmes pour la déconnexion et d'autres fonctions - veuillez vous assurer que SSI.php est inclus avant *tout* le reste de votre code dans vos scripts ! in /homez.183/pafteam/www/forum/SSI_ORG.php on line 170

Cependant, je n'ai plus l'erreur du DetecteFree.php
Site : www.pafteam.com

Projet : www.pafteam.com/beta-test/maj-site/

Version SMF : 2.0.9

maximus23

Bonjour,

Ok regarderai ce soir car là il faut tout remettre en local pour moi essayer déterminer d'où cela vient :)

Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

0Connors

Salut,

Ok, ça marche. Je te remercie en tous les cas. J'espère ne pas avoir foutu trop le bazar dans mon forum  :-[, pour que tu t'y retrouve facilement.  :-[

Encore merci,
Site : www.pafteam.com

Projet : www.pafteam.com/beta-test/maj-site/

Version SMF : 2.0.9

maximus23

Bonsoir,

Là je suis en train de perdre le restant de mes cheveux ... :) :) Bon teste pour voir .

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

0Connors

Salut,

Je crois qu'avec moi tu vas finir chauve, ça ne fonctionne toujours pas sous Chrome lorsque je ferme et ré-ouvre la page l'erreur apparaît je suis obligé de la rafraichir pour qu'elle disparaissent  :-[

C'est trop le bazar sur mon FTP ? :-X :-\
Site : www.pafteam.com

Projet : www.pafteam.com/beta-test/maj-site/

Version SMF : 2.0.9

maximus23

Bonsoir,

Moi cela fonctionne avec IE et FF regarde car tu as mis une restriction chrome sur tes pages :)

Il doit encore rester des morceaux de code mais pas évident de les retrouver .
Regarde aussi car tu as une erreur de css soit ton entête est trop petite pour ta page il manque un morceau de bannière soit le contraire.

:)

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

0Connors

Re,

Après vérification, ça ne fonctionne sur aucun des navigateur  :-[. L' header est décalé vers le bas a cause de l'erreur qui passe avant le header et me décale tout vers le bas  :-[.

Je n'ai pas de bannière c'est entièrement du CSS hormis le logo, mais techniquement tout devrais fonctionner. C'est le message d'erreur qui foire tout.

merci,
Site : www.pafteam.com

Projet : www.pafteam.com/beta-test/maj-site/

Version SMF : 2.0.9

maximus23

Bonsoir,
Bon là je vais aller au boulot donc je ne saurai pas regarder plus ce soir.
Teste pour voir si c'est bon j'ai encore retrouvé un bout de code ...

Donc à suivre.

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

0Connors

YOU ARE MY HERO !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Sérieusement, file moi ton compte paypal tu le mérite !!!!!!

Je te remercie ça marche sur tous les navigateurs, ceci dit pour éviter d'autre problème avec ce mod il faudra vérifié son bon fonctionnement je pense, on sait jamais si ça arrive à un autre.

Site : www.pafteam.com

Projet : www.pafteam.com/beta-test/maj-site/

Version SMF : 2.0.9

0Connors

Salut,

Maximus va me tuer, mais le problème et revenu. Je n'ai pourtant rien touché  :'(

J'ai modifier les options d'inscriptions pour passer approbation par email...

Là, je comprends plus !  ???
Site : www.pafteam.com

Projet : www.pafteam.com/beta-test/maj-site/

Version SMF : 2.0.9

maximus23

Bonsoir,

Voila c'est réparé je ne sais pas pourquoi tu as remis un vieux backup de ton site en date d'hier ?
Heureusement j'avais encore les fichiers modifiés.

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

0Connors

Salut Maximus,

Encore merci d'être toujours là !!!

Pas sur la partie du forum, je n'ai touché qu'au site et son CSS.  ???

C'étais bien une modif' au niveau du forum ? ???

En te remerciant pour ton soutient et ton aide.

PS : Ah si j'ai modifié mon index.template.php de mon thème, c'est peut-être ça ?
Site : www.pafteam.com

Projet : www.pafteam.com/beta-test/maj-site/

Version SMF : 2.0.9

maximus23

Bonsoir,

Non cela ne concerne que le site.

:)

Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

0Connors

Site : www.pafteam.com

Projet : www.pafteam.com/beta-test/maj-site/

Version SMF : 2.0.9

0Connors

Salut,

Le problème est revenu lorsque j'ai modifié une page de mon site pour la mettre à jour... je comprends pas d'où ça vient.

Tu peux me dire ce que tu as modifier, ou ce qui provoque cette erreur pour éviter que je t'embête avec ça ?

En te remerciant,  ;)

Site : www.pafteam.com

Projet : www.pafteam.com/beta-test/maj-site/

Version SMF : 2.0.9

maximus23

Bonsoir,

Comment arrives-tu a remettre les fichiers avec les anciennes erreurs ? Tu modifies les vieux fichiers en lieu et place des nouveaux ?

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

0Connors

Salut,

Je t'avoue que je sais pas trop, je récupère les fichiers du FTP pourtant,  :-[

Peut-être c'est aussi dû au faite que j'ai voulu réinstallé Tapatalk non ?  :o
Site : www.pafteam.com

Projet : www.pafteam.com/beta-test/maj-site/

Version SMF : 2.0.9

maximus23

Bonsoir,

Non le forum n'a rien avoir avec le site.

C'est corrigé donc quand tu modifies fait le sur les bons fichiers n'utilise plus les anciens pour faire les modifications car c'était encore les anciens fichiers qui étaient remis.

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

0Connors

Salut,

Je te remercie pour la correction, je ferai plus attention la prochaine fois.  ;D
Site : www.pafteam.com

Projet : www.pafteam.com/beta-test/maj-site/

Version SMF : 2.0.9

Advertisement: