Advertisement:

Author Topic: error on upgrade  (Read 1896 times)

Offline roshaoar

  • Jr. Member
  • **
  • Posts: 205
  • Gender: Male
error on upgrade
« on: April 23, 2015, 11:58:43 AM »
Sorry, relative newbie here, hope this is the right place to log something. I was on 2.0.9 and tried the upgrade linked on the thread and got "You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 3"

I bailed and reinstalled the old which seems to work ok as far as I can tell. This isn't a live forum but one I'm trying to prepare to open so wanted to use the latest versions.

Thanks,
-Johan

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,627
Re: error on upgrade
« Reply #1 on: April 23, 2015, 12:03:11 PM »
tried the upgrade linked in what topic? some details as to what version you are using would be useful.

if you want to run 2.1, you should not it is in beta and not ready to be run on a live forum.

Offline roshaoar

  • Jr. Member
  • **
  • Posts: 205
  • Gender: Male
Re: error on upgrade
« Reply #2 on: April 23, 2015, 12:11:33 PM »
Thanks! Linked here. It's a brand new empty forum - it'll take me a few weeks to get to know the software well so I thought I might as well work with the latest version...

Offline br360

  • Support Specialist
  • SMF Hero
  • *
  • Posts: 2,398
    • GenXcommunity
Re: error on upgrade
« Reply #3 on: April 23, 2015, 01:39:18 PM »
This link is supposed to have the latest 2.1 updates. Try using the upgrade script from here- http://nanosector.ddns.net/builds.php

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,631
  • Gender: Male
    • Kindred-999 on GitHub
Re: error on upgrade
« Reply #4 on: April 23, 2015, 02:03:19 PM »
The link in that announcement post is outdated and MANY MANY things have been corrected, fixed or changed since that beta1.

We are closer to beta2 than we are to the old beta1 at this point and the files should be gotten from GitHub rather than the old version linked in that post.  Nanosector's script pulls form github, I think... but I always prefer getting the actual build from the source.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline roshaoar

  • Jr. Member
  • **
  • Posts: 205
  • Gender: Male
Re: error on upgrade
« Reply #5 on: April 23, 2015, 02:29:50 PM »
Yes - thanks, I realised that afterwards. Don't know why but I just can't figure out Github, which file(s?) to grab

Offline Antes

  • Evil Black Cat
  • SMF Friend
  • SMF Hero
  • *
  • Posts: 8,957
  • Gender: Male
  • Black cat rulz!
    • XinYenFon on GitHub
    • merta on LinkedIn
    • @XinYenFon on Twitter
    • WoWSnips
Re: error on upgrade
« Reply #6 on: April 23, 2015, 06:51:45 PM »
You can get the latest build: https://github.com/SimpleMachines/SMF2.1/archive/release-2.1.zip (Its not generated daily or hourly its generated when you request).
Open for PAID works # Support Me

Current Project(s): [ WoWSnips ]
Past Project(s): [ ezPortal ] # [ Lunarfall ] # [ RDD (HTML5) ]