• Welcome to Simple Machines Community Forum. Please login or sign up.

Anybody having recent issues with gmail?

Started by Jailer, April 02, 2016, 07:02:20 PM

Previous topic - Next topic

Jailer

Mailgun is free up to 10,000 per month. Are you sending out more than that?

Tiribulus

Oh no LOL! I didn't know that. I will check. Thank you very much.  :)  I really would love to get this working.

Tiribulus

I don't mean to sound ungrateful man, but I have absolutely no clue what all this is it wants me to do. This is far more complicated even than gmail. Am I to conclude that it is not possible to simply enter some settings and have SMF send notifications?

Jailer

You have to also set up the records for your domain. It will vary slightly by registrar but it's not too complicated. Mailgun has tutorials and your domain registrar should have instructions as well.

Tiribulus

You guys have all been very gracious to offer to help. I appreciate it. Elastic mail actually ended up working it looks like though.
https://elasticemail.com/
I do think there is some weird under the hood issue with this server too. When I was trying to setup some service I can't even remember right now anymore, it sent an activation mail to the other admin on the site who's email address played no part whatsoever in my test registration.  :o

Jailer

Is the old admins email address still listed in the server settings?  Server settings ->General

ninjawarrior

Quote from: Shambles on April 11, 2016, 09:28:16 AM
Ok I have found a resolution to this problem, which requires a minor code change.

The clue was in this post here:

hxxp:stackoverflow.com/questions/36323790/ssmtp-no-longer-works-invalid-response-501-5-5-4-helo-ehlo-argument-myemaila [nonactive]


What I've done is edit Sources/Subs-Post.php as follows:

Code (Find) Select
// EHLO could be understood to mean encrypted hello...
if (server_parse('EHLO ' . $modSettings['smtp_host'], $socket, null) == '250')




Code (Replace With) Select
// EHLO could be understood to mean encrypted hello...
// if (server_parse('EHLO ' . $modSettings['smtp_host'], $socket, null) == '250')
if (server_parse('EHLO ' . 'localhost', $socket, null) == '250')



All seems to be working now.

Mine doesnt seem to work.

I tried with a normal gmail account (w/o 2fa) & a own domain email using gmail (2fa, app pw) and both cant work. Changed /subs-post.php as advised and SMTP 465 with SSL://smtp.gmail.com.

yan.uniko.102

Is a bug of all smf version at now. The SMTP server is ssl://mail.gmail.com but when send HELO command the smf says: HELO ssl://mail.gmail.com and the gmail server return a error by malformed HELO.

When says HELO localhost your server fall in black lists, the HELO server canot say localhost.

The solution for me is replace

if (server_parse('EHLO ' . $modSettings['smtp_host'], $socket, null) == '250')

By

if (server_parse('EHLO ' . str_replace('ssl://'.$modSettings['smtp_host']), $socket, null) == '250')

In all lines when use $modSettings['smtp_host'] except to connect in socket.

The smf need a checkbox with "enable ssl" and put the prepend schema ssl:// and check if the input of server name is a real host and not the schema.

Raffaele1977

I have 3 forums.

In 2 of them the old solution (in subs-post) worked.
In the newone, I created some days ago, it doesn't work.

Everything is similar in the forums.

Can someone help me? :(
MacOsX - 11.6
SMF 2.0.15
Safari (last) or Chrome (last)

Raffaele1977

Solved.
It should be activated in google apps the "non secure" access for apps.
MacOsX - 11.6
SMF 2.0.15
Safari (last) or Chrome (last)

Advertisement: